summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/packagegroups
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-graphics/packagegroups
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-graphics/packagegroups')
-rw-r--r--meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
new file mode 100644
index 000000000..632e7d433
--- /dev/null
+++ b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Install one of these tasks to get support for truetype fonts"
2SECTION = "fonts"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5PV = "1.0"
6PR = "r2"
7
8inherit packagegroup allarch
9
10PACKAGES += "\
11 ${PN}-core \
12 ${PN}-chinese \
13 ${PN}-japanese \
14"
15
16RRECOMMENDS_${PN} = "\
17 ${PN}-core \
18 ${PN}-chinese \
19 ${PN}-japanese \
20"
21
22RDEPENDS_${PN}-core = "\
23 fontconfig-utils \
24 \
25 ttf-dejavu-common \
26 ttf-dejavu-sans \
27 ttf-dejavu-sans-mono \
28"
29# ttf-dejavu-serif
30
31RDEPENDS_${PN}-chinese = "\
32 ${PN}-core \
33 ttf-arphic-uming \
34"
35
36RDEPENDS_${PN}-japanese = "\
37 ${PN}-core \
38 ttf-sazanami-gothic \
39 ttf-sazanami-mincho \
40"