summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/openbox
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-graphics/openbox
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-graphics/openbox')
-rw-r--r--meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
new file mode 100644
index 000000000..7c1d4a012
--- /dev/null
+++ b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
@@ -0,0 +1,47 @@
1SUMMARY = "openbox Window Manager"
2SECTION = "x11/wm"
3DEPENDS = "glib-2.0 pango libxml2 virtual/libx11"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7SRC_URI = "http://icculus.org/openbox/releases/openbox-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "00441b53cf14c03566c8e82643544ff9"
10SRC_URI[sha256sum] = "6fa90016530b3aa6102e254079461977439398531fb23e7ec076ff2c140fea0a"
11
12PR = "r2"
13
14inherit autotools gettext update-alternatives pkgconfig
15
16ALTERNATIVE_${PN}-core = "x-window-manager"
17ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/openbox"
18ALTERNATIVE_PRIORITY[x-window-manager] = "10"
19
20PACKAGECONFIG ??= ""
21PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
22PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
23PACKAGECONFIG[xrandr] = "--enable-xrandr,--disable-xrandr,libxrandr"
24PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama"
25PACKAGECONFIG[xcursor] = "--enable-xcursor,--disable-xcursor,libxcursor"
26
27PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome ${PN}-config"
28
29PACKAGES_DYNAMIC += "^${PN}-theme-.*"
30
31python populate_packages_prepend() {
32 theme_dir = d.expand('${datadir}/themes/')
33 theme_name = d.expand('${PN}-theme-%s')
34 do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
35}
36
37RDEPENDS_${PN} += "${PN}-core ${PN}-config"
38FILES_${PN}-core = "${bindir}/openbox ${libdir}/*${SOLIBS}"
39
40FILES_${PN}-lxde += "${datadir}/lxde/ \
41 ${datadir}/lxpanel \
42 ${datadir}/xsessions \
43 ${datadir}/icons"
44
45FILES_${PN}-gnome += "${datadir}/gnome/"
46
47FILES_${PN}-config += "${sysconfdir}"