diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-graphics/lxdm | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm')
-rw-r--r-- | meta-oe/recipes-graphics/lxdm/lxdm_git.bb | 36 |
1 files changed, 18 insertions, 18 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb index a6f266cc38..a24f75c654 100644 --- a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb +++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb | |||
@@ -3,11 +3,11 @@ HOMEPAGE = "http://blog.lxde.org/?p=531" | |||
3 | LICENSE = "GPLv3" | 3 | LICENSE = "GPLv3" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
5 | SRC_URI = " \ | 5 | SRC_URI = " \ |
6 | git://lxde.git.sourceforge.net/gitroot/lxde/${BPN};protocol=git;branch=master \ | 6 | git://lxde.git.sourceforge.net/gitroot/lxde/${BPN};protocol=git;branch=master \ |
7 | file://lxdm.conf \ | 7 | file://lxdm.conf \ |
8 | file://lxdm-pam \ | 8 | file://lxdm-pam \ |
9 | file://lxdm-pam-debug \ | 9 | file://lxdm-pam-debug \ |
10 | ${@base_contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \ | 10 | ${@base_contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \ |
11 | " | 11 | " |
12 | 12 | ||
13 | LXDM_PAM = "${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)}" | 13 | LXDM_PAM = "${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)}" |
@@ -29,22 +29,22 @@ S = "${WORKDIR}/git" | |||
29 | EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}" | 29 | EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}" |
30 | 30 | ||
31 | do_compile_append() { | 31 | do_compile_append() { |
32 | # default background configured not available / no password field available / no default screensaver | 32 | # default background configured not available / no password field available / no default screensaver |
33 | sed -i -e 's,bg=,# bg=,g' \ | 33 | sed -i -e 's,bg=,# bg=,g' \ |
34 | -e 's,# skip_password=,skip_password=,g' \ | 34 | -e 's,# skip_password=,skip_password=,g' \ |
35 | -e 's,# arg=.*,arg=${bindir}/X -s 0,g' \ | 35 | -e 's,# arg=.*,arg=${bindir}/X -s 0,g' \ |
36 | ${S}/data/lxdm.conf.in | 36 | ${S}/data/lxdm.conf.in |
37 | # add default configuration | 37 | # add default configuration |
38 | oe_runmake -C ${S}/data lxdm.conf | 38 | oe_runmake -C ${S}/data lxdm.conf |
39 | } | 39 | } |
40 | 40 | ||
41 | do_install_append() { | 41 | do_install_append() { |
42 | install -d ${D}${localstatedir}/lib/lxdm | 42 | install -d ${D}${localstatedir}/lib/lxdm |
43 | install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm | 43 | install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm |
44 | # ArchLinux version of pam config has the following advantages: | 44 | # ArchLinux version of pam config has the following advantages: |
45 | # * simple setup of passwordless login | 45 | # * simple setup of passwordless login |
46 | # * in XFCE powerdown/restart enabled in logoff dialog | 46 | # * in XFCE powerdown/restart enabled in logoff dialog |
47 | install -m 644 ${WORKDIR}/${LXDM_PAM} ${D}${sysconfdir}/pam.d/lxdm | 47 | install -m 644 ${WORKDIR}/${LXDM_PAM} ${D}${sysconfdir}/pam.d/lxdm |
48 | } | 48 | } |
49 | 49 | ||
50 | # make installed languages choosable | 50 | # make installed languages choosable |