diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2023-04-08 00:07:37 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-04-07 16:58:15 -0700 |
commit | faa9d6a7b14a7b204d8ea02b847e04a2db5ceed1 (patch) | |
tree | 716a2e7a702d8fb9dd56eb1b43a31c37aad7eec1 /meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb | |
parent | 44147c5bb7c42d6530e56468cc87bd00acf22fb4 (diff) | |
download | meta-openembedded-faa9d6a7b14a7b204d8ea02b847e04a2db5ceed1.tar.gz |
lvgl,lv-lib-png,lv-drivers: fix installed-vs-shipped QA issue with multilib
* with multilib BASELIB is just "lib" while baselib is "lib64"
and libdir is "/usr/lib64".
* fixes:
ERROR: QA Issue: lvgl: Files/directories were installed but not shipped in any package:
/usr/lib
/usr/lib/liblvgl.a
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
lvgl: 2 installed and not shipped files. [installed-vs-shipped]
* lowercase baselib should work for ppc64 as well (I hope)
# $baselib [3 operations]
# set oe-core/meta/conf/bitbake.conf:10
# "${BASELIB}"
# set oe-core/meta/conf/bitbake.conf:11
# [vardepvalue] "${baselib}"
# set oe-core/meta/conf/multilib.conf:2
# "${@d.getVar('BASE_LIB:tune-' + (d.getVar('DEFAULTTUNE') or 'INVALID')) or d.getVar('BASELIB')}"
# pre-expansion value:
# "${@d.getVar('BASE_LIB:tune-' + (d.getVar('DEFAULTTUNE') or 'INVALID')) or d.getVar('BASELIB')}"
baselib="lib64"
* simplify destsuffix/S setting
* I was surprised that ${WORKDIR}/${PN}-${PV} works in multilib build
but then I've noticed that it's because destsuffix is set to S which
is a bit uncommon, so drop that and use default "git"
* use ${STAGING_INCDIR} instead of ${RECIPE_SYSROOT}/${includedir}
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb')
-rw-r--r-- | meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb | 8 |
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb index 032e85f52..22b482640 100644 --- a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb +++ b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb | |||
@@ -8,21 +8,23 @@ DESCRIPTION = "Allow the use of PNG images in LVGL. This implementation uses lod | |||
8 | LICENSE = "MIT" | 8 | LICENSE = "MIT" |
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/lvgl/lv_lib_png;destsuffix=${S};protocol=https;nobranch=1" | 11 | SRC_URI = "git://github.com/lvgl/lv_lib_png;;protocol=https;nobranch=1" |
12 | SRCREV = "bf1531afe07c9f861107559e29ab8a2d83e4715a" | 12 | SRCREV = "bf1531afe07c9f861107559e29ab8a2d83e4715a" |
13 | 13 | ||
14 | S = "${WORKDIR}/git" | ||
15 | |||
14 | # because of lvgl dependency | 16 | # because of lvgl dependency |
15 | REQUIRED_DISTRO_FEATURES = "wayland" | 17 | REQUIRED_DISTRO_FEATURES = "wayland" |
16 | 18 | ||
17 | DEPENDS += "lvgl" | 19 | DEPENDS += "lvgl" |
18 | 20 | ||
19 | EXTRA_OECMAKE += "-DLIB_INSTALL_DIR=${BASELIB}" | 21 | EXTRA_OECMAKE += "-DLIB_INSTALL_DIR=${baselib}" |
20 | 22 | ||
21 | inherit cmake | 23 | inherit cmake |
22 | inherit features_check | 24 | inherit features_check |
23 | 25 | ||
24 | TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1" | 26 | TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1" |
25 | TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl" | 27 | TARGET_CFLAGS += "-I${STAGING_INCDIR}/lvgl" |
26 | 28 | ||
27 | FILES:${PN}-dev = "\ | 29 | FILES:${PN}-dev = "\ |
28 | ${includedir}/lvgl/lv_lib_png/ \ | 30 | ${includedir}/lvgl/lv_lib_png/ \ |