summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/libforms
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-13 18:22:52 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:37:48 -0700
commita116115efb97fe8b60ddb8bc449ebae36946218f (patch)
tree9951fed44a6163da6b45149709a749826fb4a62a /meta-oe/recipes-graphics/libforms
parent161072d8002d0307011dd626922f673c18cfcd20 (diff)
downloadmeta-openembedded-a116115efb97fe8b60ddb8bc449ebae36946218f.tar.gz
libforms: Fix build with -fno-common
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/libforms')
-rw-r--r--meta-oe/recipes-graphics/libforms/files/0001-Make-extern-declarations-in-header-file.patch46
-rw-r--r--meta-oe/recipes-graphics/libforms/libforms_1.2.3.bb1
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libforms/files/0001-Make-extern-declarations-in-header-file.patch b/meta-oe/recipes-graphics/libforms/files/0001-Make-extern-declarations-in-header-file.patch
new file mode 100644
index 000000000..619bad6d0
--- /dev/null
+++ b/meta-oe/recipes-graphics/libforms/files/0001-Make-extern-declarations-in-header-file.patch
@@ -0,0 +1,46 @@
1From a57c498f6c25aa297e49533c242525f2b9da7048 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 13 Aug 2020 18:20:42 -0700
4Subject: [PATCH] Make extern declarations in header file
5
6curobj is a static object in other places as well.
7Fixes build with gcc10/-fno-common
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 fdesign/sp_spinner.c | 2 +-
13 lib/flinternal.h | 4 ++--
14 2 files changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/fdesign/sp_spinner.c b/fdesign/sp_spinner.c
17index 04f2c19..6206daa 100644
18--- a/fdesign/sp_spinner.c
19+++ b/fdesign/sp_spinner.c
20@@ -29,7 +29,7 @@
21 #include "spec/spinner_spec.h"
22
23 static FD_spinnerattrib * spn_attrib;
24-FL_OBJECT *curobj;
25+static FL_OBJECT *curobj;
26
27
28 /***************************************
29diff --git a/lib/flinternal.h b/lib/flinternal.h
30index 06d847e..577bd10 100644
31--- a/lib/flinternal.h
32+++ b/lib/flinternal.h
33@@ -138,8 +138,8 @@ enum {
34
35 /* events.c or event related */
36
37-FL_OBJECT * fli_handled_obj;
38-FL_OBJECT * fli_handled_parent;
39+extern FL_OBJECT * fli_handled_obj;
40+extern FL_OBJECT * fli_handled_parent;
41
42 void fli_obj_queue_delete( void );
43
44--
452.28.0
46
diff --git a/meta-oe/recipes-graphics/libforms/libforms_1.2.3.bb b/meta-oe/recipes-graphics/libforms/libforms_1.2.3.bb
index 999d53d4a..35029f517 100644
--- a/meta-oe/recipes-graphics/libforms/libforms_1.2.3.bb
+++ b/meta-oe/recipes-graphics/libforms/libforms_1.2.3.bb
@@ -9,6 +9,7 @@ SRC_URI = "http://download.savannah.nongnu.org/releases/xforms/xforms-${PV}.tar.
9 file://fix-link-to-xforms-man.patch \ 9 file://fix-link-to-xforms-man.patch \
10 file://add-absolute-path-for-include-dir.patch \ 10 file://add-absolute-path-for-include-dir.patch \
11 file://fix-path-fdesign_LDADD.patch \ 11 file://fix-path-fdesign_LDADD.patch \
12 file://0001-Make-extern-declarations-in-header-file.patch \
12 " 13 "
13 14
14SRC_URI[md5sum] = "235720a758a8b8d9e6e452dc67190e9b" 15SRC_URI[md5sum] = "235720a758a8b8d9e6e452dc67190e9b"