summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gtkperf
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-graphics/gtkperf
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-graphics/gtkperf')
-rw-r--r--meta-oe/recipes-graphics/gtkperf/gtkperf/Makevars25
-rw-r--r--meta-oe/recipes-graphics/gtkperf/gtkperf_0.40.bb27
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gtkperf/gtkperf/Makevars b/meta-oe/recipes-graphics/gtkperf/gtkperf/Makevars
new file mode 100644
index 000000000..8b09f53b0
--- /dev/null
+++ b/meta-oe/recipes-graphics/gtkperf/gtkperf/Makevars
@@ -0,0 +1,25 @@
1# Makefile variables for PO directory in any package using GNU gettext.
2
3# Usually the message domain is the same as the package name.
4DOMAIN = $(PACKAGE)
5
6# These two variables depend on the location of this directory.
7subdir = po
8top_builddir = ..
9
10# These options get passed to xgettext.
11XGETTEXT_OPTIONS = --keyword=_ --keyword=N_
12
13# This is the copyright holder that gets inserted into the header of the
14# $(DOMAIN).pot file. Set this to the copyright holder of the surrounding
15# package. (Note that the msgstr strings, extracted from the package's
16# sources, belong to the copyright holder of the package.) Translators are
17# expected to transfer the copyright for their translations to this person
18# or entity, or to disclaim their copyright. The empty string stands for
19# the public domain; in this case the translators are expected to disclaim
20# their copyright.
21COPYRIGHT_HOLDER = Free Software Foundation, Inc.
22
23# This is the list of locale categories, beyond LC_MESSAGES, for which the
24# message catalogs shall be used. It is usually empty.
25EXTRA_LOCALE_CATEGORIES =
diff --git a/meta-oe/recipes-graphics/gtkperf/gtkperf_0.40.bb b/meta-oe/recipes-graphics/gtkperf/gtkperf_0.40.bb
new file mode 100644
index 000000000..e404a7a51
--- /dev/null
+++ b/meta-oe/recipes-graphics/gtkperf/gtkperf_0.40.bb
@@ -0,0 +1,27 @@
1SUMMARY = "GTK Performance tool"
2SECTION = "libs"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5
6SRC_URI = "http://prdownloads.sourceforge.net/${BPN}/${BPN}_${PV}.tar.gz \
7 file://Makevars"
8
9SRC_URI[md5sum] = "4331dde4bb83865e15482885fcb0cc53"
10SRC_URI[sha256sum] = "9704344e732038eecbd007dd996a56293a6b027b5b76f3f036273a3fae1ab27b"
11
12DEPENDS = "gtk+"
13
14S = "${WORKDIR}/${BPN}"
15
16inherit autotools binconfig pkgconfig gettext
17
18do_configure_prepend () {
19 rm -f ${S}/m4/init.m4
20 cp -f ${WORKDIR}/Makevars ${S}/po/
21}
22
23do_install_append () {
24 rm -rf ${D}/${exec_prefix}/doc
25}
26
27FILES_${PN} += "${exec_prefix}/share/duck.png"