summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gphoto2
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-06-15 09:18:02 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-22 17:12:37 +0200
commit9222832866c45716cea5a7e8d9332b5dd1de36f5 (patch)
treefb19e10f220e3037cd74cb31bc183e5adf51c3d5 /meta-oe/recipes-graphics/gphoto2
parent7e8e0fbadd5a83be03de757091b5267054196774 (diff)
downloadmeta-openembedded-9222832866c45716cea5a7e8d9332b5dd1de36f5.tar.gz
libgphoto2: correct compatibility issues with libjpeg-turbo-1.5.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/gphoto2')
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0002-correct-jpeg-memsrcdest-support.patch54
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.8.bb5
2 files changed, 55 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0002-correct-jpeg-memsrcdest-support.patch b/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0002-correct-jpeg-memsrcdest-support.patch
new file mode 100644
index 000000000..cf2d86da1
--- /dev/null
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0002-correct-jpeg-memsrcdest-support.patch
@@ -0,0 +1,54 @@
1--- libgphoto2-2.5.8/camlibs/ax203/jpeg_memsrcdest.h.orig 2016-06-15 09:03:20.625774684 -0400
2+++ libgphoto2-2.5.8/camlibs/ax203/jpeg_memsrcdest.h 2016-06-15 09:03:47.049774148 -0400
3@@ -1,5 +1,7 @@
4 #include <jpeglib.h>
5
6+#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
7+
8 void
9 jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
10 unsigned long bufsize);
11@@ -7,3 +9,5 @@
12 void
13 jpeg_mem_dest (j_compress_ptr cinfo, unsigned char ** outbuffer,
14 unsigned long * outsize);
15+
16+#endif
17--- libgphoto2-2.5.8/camlibs/ax203/jpeg_memsrcdest.c.orig 2016-06-15 09:03:58.689773913 -0400
18+++ libgphoto2-2.5.8/camlibs/ax203/jpeg_memsrcdest.c 2016-06-15 09:04:17.769773526 -0400
19@@ -26,7 +26,7 @@
20
21 /* libjpeg8 and later come with their own (API compatible) memory source
22 and dest */
23-#if JPEG_LIB_VERSION < 80
24+#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
25
26 /* Expanded data source object for memory input */
27
28--- libgphoto2-2.5.8/camlibs/jl2005c/jpeg_memsrcdest.h.orig 2016-06-15 09:05:01.893772632 -0400
29+++ libgphoto2-2.5.8/camlibs/jl2005c/jpeg_memsrcdest.h 2016-06-15 09:05:17.433772318 -0400
30@@ -1,5 +1,7 @@
31 #include <jpeglib.h>
32
33+#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
34+
35 void
36 jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
37 unsigned long bufsize);
38@@ -7,3 +9,5 @@
39 void
40 jpeg_mem_dest (j_compress_ptr cinfo, unsigned char ** outbuffer,
41 unsigned long * outsize);
42+
43+#endif
44--- libgphoto2-2.5.8/camlibs/jl2005c/jpeg_memsrcdest.c.orig 2016-06-15 09:04:42.641773022 -0400
45+++ libgphoto2-2.5.8/camlibs/jl2005c/jpeg_memsrcdest.c 2016-06-15 09:04:48.657772901 -0400
46@@ -26,7 +26,7 @@
47
48 /* libjpeg8 and later come with their own (API compatible) memory source
49 and dest */
50-#if JPEG_LIB_VERSION < 80
51+#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
52
53 /* Expanded data source object for memory input */
54
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.8.bb b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.8.bb
index f0e8b13b7..dde14adcb 100644
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.8.bb
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.8.bb
@@ -14,6 +14,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2;name=libgphoto2
14 file://10-camera-libgphoto2.fdi \ 14 file://10-camera-libgphoto2.fdi \
15 file://40-libgphoto2.rules \ 15 file://40-libgphoto2.rules \
16 file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \ 16 file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \
17 file://0002-correct-jpeg-memsrcdest-support.patch \
17" 18"
18 19
19SRC_URI[libgphoto2.md5sum] = "873ab01aced49c6b92a98e515db5dcef" 20SRC_URI[libgphoto2.md5sum] = "873ab01aced49c6b92a98e515db5dcef"
@@ -52,7 +53,3 @@ FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*"
52FILES_${PN} += "${nonarch_base_libdir}/udev/* ${datadir}/hal" 53FILES_${PN} += "${nonarch_base_libdir}/udev/* ${datadir}/hal"
53FILES_${PN}-dbg += "${libdir}/*/*/.debug" 54FILES_${PN}-dbg += "${libdir}/*/*/.debug"
54FILES_${PN}-dev += "${libdir}/*/*/*.la" 55FILES_${PN}-dev += "${libdir}/*/*/*.la"
55
56# | ../../libgphoto2-2.5.8/camlibs/ax203/jpeg_memsrcdest.h:4:1: error: conflicting types for 'jpeg_mem_src'
57# | jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
58PNBLACKLIST[libgphoto2] ?= "Not compatible with libjpeg-turbo-1.5.0"