summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gimp
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-graphics/gimp
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-graphics/gimp')
-rw-r--r--meta-oe/recipes-graphics/gimp/gimp/freetype.patch30
-rw-r--r--meta-oe/recipes-graphics/gimp/gimp_2.8.10.bb30
2 files changed, 60 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gimp/gimp/freetype.patch b/meta-oe/recipes-graphics/gimp/gimp/freetype.patch
new file mode 100644
index 000000000..ed6c09791
--- /dev/null
+++ b/meta-oe/recipes-graphics/gimp/gimp/freetype.patch
@@ -0,0 +1,30 @@
1Include the freetype headers via macros ( recommended way)
2
3Signed-off-by: Khem Raj <raj.khem@gmail.com>
4Upstream-Status: Backport
5
6From 6c73f28b6d87a2afd11974552a075bffec52347f Mon Sep 17 00:00:00 2001
7From: Michael Natterer <mitch@gimp.org>
8Date: Fri, 29 Nov 2013 20:57:46 +0000
9Subject: Bug 719560 - Build failure with freetype 2.5.1
10
11Apply patch from su-v that fixes the freetype include to
12the madness devised and recommended by freetype.
13---
14diff --git a/app/text/gimpfont.c b/app/text/gimpfont.c
15index 4045ca9..66c6e52 100644
16--- a/app/text/gimpfont.c
17+++ b/app/text/gimpfont.c
18@@ -28,7 +28,9 @@
19
20 #define PANGO_ENABLE_ENGINE 1 /* Argh */
21 #include <pango/pango-ot.h>
22-#include <freetype/tttables.h>
23+
24+#include <ft2build.h>
25+#include FT_TRUETYPE_TABLES_H
26
27 #include "text-types.h"
28
29--
30cgit v0.9.2
diff --git a/meta-oe/recipes-graphics/gimp/gimp_2.8.10.bb b/meta-oe/recipes-graphics/gimp/gimp_2.8.10.bb
new file mode 100644
index 000000000..a893dc259
--- /dev/null
+++ b/meta-oe/recipes-graphics/gimp/gimp_2.8.10.bb
@@ -0,0 +1,30 @@
1SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = "babl gdk-pixbuf-native libart-lgpl gtk+ jpeg libpng libexif tiff lcms gegl poppler jasper bzip2"
8DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)}"
9
10inherit gnome
11
12PACKAGECONFIG ??= ""
13PACKAGECONFIG[helpbrowser] = "--with-webkit, --without-webkit, webkit-gtk"
14
15SRC_URI = "http://ftp.gimp.org/pub/gimp/v2.8/gimp-${PV}.tar.bz2 \
16 file://freetype.patch \
17 "
18SRC_URI[md5sum] = "84c964aab7044489af69f7319bb59b47"
19SRC_URI[sha256sum] = "e7fd8b19f989138d826003c75f56bd5b6f136eef597e86e3978ede0bba470ae6"
20
21EXTRA_OECONF = "--disable-python \
22 --without-wmf"
23
24do_configure_append() {
25 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
26 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
27}
28
29FILES_${PN}-dbg += "${libdir}/gimp/2.0/*/.debug"
30FILES_${PN} += "${datadir}/appdata"