summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gegl
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-22 19:35:58 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:32 +0100
commit465f6c491316dc1f3ce0adf5785f13d84acb3844 (patch)
tree12816013644cccb7db9c218592a7012465b51b68 /meta-oe/recipes-graphics/gegl
parent09489f472da1967c23426bdc805c52f80f8f3239 (diff)
downloadmeta-openembedded-465f6c491316dc1f3ce0adf5785f13d84acb3844.tar.gz
gegl: update to 0.3.4
This fixes gobject introspection support. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-graphics/gegl')
-rw-r--r--meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb26
-rw-r--r--meta-oe/recipes-graphics/gegl/gegl_0.3.4.bb30
2 files changed, 30 insertions, 26 deletions
diff --git a/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb b/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb
deleted file mode 100644
index bd2e5d4b4..000000000
--- a/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
2LICENSE = "LGPL-3.0"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4DEPENDS = "babl librsvg glib-2.0 gtk+ pango cairo expat zlib libpng jpeg virtual/libsdl"
5
6inherit gnome
7
8EXTRA_OECONF = "--disable-docs "
9
10PACKAGECONFIG ??= ""
11PACKAGECONFIG[jasper] = "--with-jasper,--without-jasper,jasper"
12PACKAGECONFIG[avformat] = "--with-libavformat,--without-libavformat,libav"
13
14SRC_URI = "http://ftp.gimp.org/pub/${BPN}/0.2/${BP}.tar.bz2 \
15 file://pkgconfig.patch "
16SRC_URI[md5sum] = "32b00002f1f1e316115c4ed922e1dec8"
17SRC_URI[sha256sum] = "df2e6a0d9499afcbc4f9029c18d9d1e0dd5e8710a75e17c9b1d9a6480dd8d426"
18
19FILES_${PN} += "${libdir}/gegl-*/*.so"
20FILES_${PN}-dev += "${libdir}/gegl-*/*.la"
21FILES_${PN}-dbg += "${libdir}/gegl-*/.debug"
22
23# Fails to build with thumb-1 (qemuarm)
24# gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process':
25# gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275
26ARM_INSTRUCTION_SET = "arm"
diff --git a/meta-oe/recipes-graphics/gegl/gegl_0.3.4.bb b/meta-oe/recipes-graphics/gegl/gegl_0.3.4.bb
new file mode 100644
index 000000000..15c1b64ee
--- /dev/null
+++ b/meta-oe/recipes-graphics/gegl/gegl_0.3.4.bb
@@ -0,0 +1,30 @@
1SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
2LICENSE = "LGPL-3.0"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4DEPENDS = "babl librsvg glib-2.0 gtk+ pango cairo expat zlib libpng jpeg virtual/libsdl json-glib"
5
6EXTRA_OECONF = "--disable-docs"
7
8inherit gnomebase vala gobject-introspection
9
10PACKAGECONFIG ??= ""
11PACKAGECONFIG[jasper] = "--with-jasper,--without-jasper,jasper"
12PACKAGECONFIG[avformat] = "--with-libavformat,--without-libavformat,libav"
13PACKAGECONFIG[lcms] = "--with-lcms,--without-lcms,lcms"
14PACKAGECONFIG[tiff] = "--with-libtiff,--without-libtiff,tiff"
15PACKAGECONFIG[webp] = "--with-webp,--without-webp,webp"
16
17SRC_URI = "http://ftp.gimp.org/pub/${BPN}/0.3/${BP}.tar.bz2 \
18 file://pkgconfig.patch "
19SRC_URI[md5sum] = "c19478321594d715a4cb324a0decda6f"
20SRC_URI[sha256sum] = "846290a790854d1e6b7c17a2d6f82ad7cb14c72e240bd3b81b98cc0ceddbc3ec"
21
22# There are a couple of non-symlink .so files installed into libdir, which need to go into main package
23FILES_${PN}_append = " ${libdir}/gegl-0.3/*.so ${libdir}/gegl-0.3/*.json ${libdir}/libgegl-npd-0.3.so ${libdir}/libgegl-sc-0.3.so"
24FILES_${PN}-dev_append = " ${libdir}/gegl-0.3/*.la ${libdir}/libgegl-0.3.so"
25FILES_${PN}-dev_remove = "${libdir}/lib*.so"
26
27# Fails to build with thumb-1 (qemuarm)
28# gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process':
29# gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275
30ARM_INSTRUCTION_SET = "arm"