summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gegl
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-graphics/gegl
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-graphics/gegl')
-rw-r--r--meta-oe/recipes-graphics/gegl/gegl/pkgconfig.patch21
-rw-r--r--meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb21
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gegl/gegl/pkgconfig.patch b/meta-oe/recipes-graphics/gegl/gegl/pkgconfig.patch
new file mode 100644
index 000000000..d145b625f
--- /dev/null
+++ b/meta-oe/recipes-graphics/gegl/gegl/pkgconfig.patch
@@ -0,0 +1,21 @@
1Index: gegl-0.2.0/configure.ac
2===================================================================
3--- gegl-0.2.0.orig/configure.ac 2012-04-02 21:56:49.000000000 +0000
4+++ gegl-0.2.0/configure.ac 2014-07-17 21:34:15.312546602 +0000
5@@ -765,15 +765,7 @@
6
7 have_sdl="no"
8 if test "x$with_sdl" != "xno"; then
9- AC_PATH_PROG(SDL_CONFIG, sdl-config, no)
10- if test "$SDL_CONFIG" = "no"; then
11- have_sdl="no (SDL library not found)"
12- AC_MSG_RESULT([*** Check for SDL library failed.])
13- else
14- have_sdl="yes"
15- SDL_CFLAGS=`$SDL_CONFIG --cflags`
16- SDL_LIBS=`$SDL_CONFIG --libs`
17- fi
18+ PKG_CHECK_MODULES([SDL], [sdl], [have_sdl="yes"], [have_sdl="no (SDL library not found)"])
19 fi
20
21 AM_CONDITIONAL(HAVE_SDL, test "$have_sdl" = "yes")
diff --git a/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb b/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb
new file mode 100644
index 000000000..58103f61b
--- /dev/null
+++ b/meta-oe/recipes-graphics/gegl/gegl_0.2.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
2LICENSE = "LGPL-3.0"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4DEPENDS = "babl librsvg glib-2.0 gtk+ pango cairo expat zlib libpng jpeg virtual/libsdl"
5
6inherit gnome
7
8EXTRA_OECONF = "--disable-docs "
9
10PACKAGECONFIG ??= ""
11PACKAGECONFIG[jasper] = "--with-jasper,--without-jasper,jasper"
12PACKAGECONFIG[avformat] = "--with-libavformat,--without-libavformat,libav"
13
14SRC_URI = "http://ftp.gimp.org/pub/${BPN}/0.2/${BP}.tar.bz2 \
15 file://pkgconfig.patch "
16SRC_URI[md5sum] = "32b00002f1f1e316115c4ed922e1dec8"
17SRC_URI[sha256sum] = "df2e6a0d9499afcbc4f9029c18d9d1e0dd5e8710a75e17c9b1d9a6480dd8d426"
18
19FILES_${PN} += "${libdir}/gegl-*/*.so"
20FILES_${PN}-dev += "${libdir}/gegl-*/*.la"
21FILES_${PN}-dbg += "${libdir}/gegl-*/.debug"