summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/directfb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-02 18:50:55 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:35 -0700
commite1eb39b36a93cb3603ece4a3e56e229d04473c63 (patch)
treee6117c798b985bec607205003763a80d2b7e2b4a /meta-oe/recipes-graphics/directfb
parent538612afdc6186535925bfbb57cf51d72e677c83 (diff)
downloadmeta-openembedded-e1eb39b36a93cb3603ece4a3e56e229d04473c63.tar.gz
directfb-examples: Fix pthread_t assignment type
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/directfb')
-rw-r--r--meta-oe/recipes-graphics/directfb/directfb-examples/0001-spacedream-Add-typecast-to-pthread_t-in-assignment.patch39
-rw-r--r--meta-oe/recipes-graphics/directfb/directfb-examples_1.7.0.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/directfb/directfb-examples/0001-spacedream-Add-typecast-to-pthread_t-in-assignment.patch b/meta-oe/recipes-graphics/directfb/directfb-examples/0001-spacedream-Add-typecast-to-pthread_t-in-assignment.patch
new file mode 100644
index 000000000..f40b7f144
--- /dev/null
+++ b/meta-oe/recipes-graphics/directfb/directfb-examples/0001-spacedream-Add-typecast-to-pthread_t-in-assignment.patch
@@ -0,0 +1,39 @@
1From 85a30903ea3ba4232379bbbcb54960307d5a2da0 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 2 Sep 2022 18:49:03 -0700
4Subject: [PATCH] spacedream: Add typecast to pthread_t in assignment
5
6render_loop_thread is of type pthread_t, therefore -1 which is int can
7not be assigned to it. Do the needed typecast conversion
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 src/spacedream/main.c | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/src/spacedream/main.c b/src/spacedream/main.c
16index 430800f..8e1887c 100644
17--- a/src/spacedream/main.c
18+++ b/src/spacedream/main.c
19@@ -205,7 +205,7 @@ void unload_stars()
20 int main( int argc, char *argv[] )
21 {
22 int quit = 0;
23- pthread_t render_loop_thread = -1;
24+ pthread_t render_loop_thread = (pthread_t)-1;
25
26 IDirectFBSurface *primary;
27 IDirectFBEventBuffer *buffer;
28@@ -344,7 +344,7 @@ int main( int argc, char *argv[] )
29 pthread_cancel( render_loop_thread );
30 pthread_mutex_unlock( &render_start );
31 pthread_join( render_loop_thread, NULL );
32- render_loop_thread = -1;
33+ render_loop_thread = (pthread_t)-1;
34
35
36 unload_stars();
37--
382.37.3
39
diff --git a/meta-oe/recipes-graphics/directfb/directfb-examples_1.7.0.bb b/meta-oe/recipes-graphics/directfb/directfb-examples_1.7.0.bb
index 7907c5c0d..398e33948 100644
--- a/meta-oe/recipes-graphics/directfb/directfb-examples_1.7.0.bb
+++ b/meta-oe/recipes-graphics/directfb/directfb-examples_1.7.0.bb
@@ -9,6 +9,7 @@ LICENSE = "MIT"
9SRC_URI = " \ 9SRC_URI = " \
10 http://downloads.yoctoproject.org/mirror/sources/DirectFB-examples-${PV}.tar.gz \ 10 http://downloads.yoctoproject.org/mirror/sources/DirectFB-examples-${PV}.tar.gz \
11 file://configure.in-Fix-string-argument-syntax.patch \ 11 file://configure.in-Fix-string-argument-syntax.patch \
12 file://0001-spacedream-Add-typecast-to-pthread_t-in-assignment.patch \
12 " 13 "
13 14
14LIC_FILES_CHKSUM = "file://COPYING;md5=ecf6fd2b19915afc4da56043926ca18f" 15LIC_FILES_CHKSUM = "file://COPYING;md5=ecf6fd2b19915afc4da56043926ca18f"