summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-06-02 15:46:03 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-02 21:07:27 +0200
commit6136b9f7544319b107b599fcb5ec8bea4fa08dca (patch)
tree768be8bd1fe0a86f6c093e8c87712009ee47c2c5 /meta-oe/recipes-gnome
parent6f3ca440cb00622ae42433a4088c59eb11fb0bb3 (diff)
downloadmeta-openembedded-6136b9f7544319b107b599fcb5ec8bea4fa08dca.tar.gz
gobject-introspection: move to recipes-gnome to match oe-core structure
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-gnome')
-rw-r--r--meta-oe/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch20
-rw-r--r--meta-oe/recipes-gnome/gnome/gobject-introspection_0.9.10.bb32
-rw-r--r--meta-oe/recipes-gnome/gnome/gobject-introspection_git.bb33
3 files changed, 85 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch b/meta-oe/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch
new file mode 100644
index 000000000..67b85470d
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch
@@ -0,0 +1,20 @@
1Index: gobject-introspection-0.9.10/tools/g-ir-annotation-tool.in
2===================================================================
3--- gobject-introspection-0.9.10.orig/tools/g-ir-annotation-tool.in
4+++ gobject-introspection-0.9.10/tools/g-ir-annotation-tool.in
5@@ -1,4 +1,4 @@
6-#!@PYTHON@
7+#!/usr/bin/env python
8 # -*- Mode: Python -*-
9 # GObject-Introspection - a framework for introspecting GObject libraries
10 # Copyright (C) 2008 Johan Dahlin
11Index: gobject-introspection-0.9.10/tools/g-ir-scanner.in
12===================================================================
13--- gobject-introspection-0.9.10.orig/tools/g-ir-scanner.in
14+++ gobject-introspection-0.9.10/tools/g-ir-scanner.in
15@@ -1,4 +1,4 @@
16-#!@PYTHON@
17+#!/usr/bin/env python
18 # -*- Mode: Python -*-
19 # GObject-Introspection - a framework for introspecting GObject libraries
20 # Copyright (C) 2008 Johan Dahlin
diff --git a/meta-oe/recipes-gnome/gnome/gobject-introspection_0.9.10.bb b/meta-oe/recipes-gnome/gnome/gobject-introspection_0.9.10.bb
new file mode 100644
index 000000000..f1a46a10b
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gobject-introspection_0.9.10.bb
@@ -0,0 +1,32 @@
1# NOTE: WIP! This recipe does not cross-compile atm., only -native
2SECTION = "libs"
3DEPENDS = "glib-2.0 libffi bison-native"
4BBCLASSEXTEND = "native"
5PR = "r1"
6
7LICENSE = "GPLv2+ & LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=90d577535a3898e1ae5dbf0ae3509a8c \
9 file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
10 file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7"
11
12SRC_URI[md5sum] = "e5cd63d6bcc5c105e898e7c33cf42175"
13SRC_URI[sha256sum] = "4bf244db75df04499dea704e7734376c0fc5a3a17fb59be2123c8d76111e6fb8"
14
15SRC_URI = "\
16 ${GNOME_MIRROR}/gobject-introspection/0.9/${BPN}-${PV}.tar.bz2 \
17 file://use-usr-bin-env-for-python.patch \
18"
19S = "${WORKDIR}/${BPN}-${PV}"
20
21inherit autotools
22
23do_configure_prepend() {
24 touch -f gtk-doc.make
25}
26
27EXTRA_OECONF = "\
28 --disable-gtk-doc \
29 --disable-gtk-doc-html \
30 --disable-gtk-doc-pdf \
31 --disable-tests \
32"
diff --git a/meta-oe/recipes-gnome/gnome/gobject-introspection_git.bb b/meta-oe/recipes-gnome/gnome/gobject-introspection_git.bb
new file mode 100644
index 000000000..2a7f30c11
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gobject-introspection_git.bb
@@ -0,0 +1,33 @@
1# NOTE: WIP! This recipe does not cross-compile atm., only -native
2DEPENDS = "glib-2.0 libffi python-native gobject-introspection-native"
3DEPENDS_virtclass-native = "libffi-native python-native bison-native flex-native"
4BBCLASSEXTEND = "native"
5
6SRC_URI = "git://git.gnome.org/gobject-introspection;protocol=git \
7 file://use-usr-bin-env-for-python.patch \
8"
9
10LICENSE = "GPLv2+ & LGPLv2+"
11LIC_FILES_CHKSUM = "file://COPYING.tools;md5=94d55d512a9ba36caa9b7df079bae19f \
12 file://COPYING.lib;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14SRCREV = "8d64bc23d2b837421ecf9c7b0e4b8d5d95ca0d21"
15PV = "1.29.0+gitr${SRCPV}"
16DEFAULT_PREFERENCE = "-1"
17
18S = "${WORKDIR}/git"
19
20inherit autotools
21
22BBCLASSEXTEND = "native"
23
24do_configure_prepend () {
25 echo "EXTRA_DIST = " > ${S}/gtk-doc.make
26}
27
28EXTRA_OECONF = "\
29 --disable-gtk-doc \
30 --disable-gtk-doc-html \
31 --disable-gtk-doc-pdf \
32 --disable-tests \
33"