diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-05-18 23:33:55 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-19 10:12:51 -0700 |
commit | 4921a6df059ad474e4451dde587640a3291d74b1 (patch) | |
tree | 5bfb4377ab66e110323d2eb2b5c3622056f2ca26 /meta-oe/recipes-gnome | |
parent | d68491eca0431dcab4a8962cff17f3056105c6f6 (diff) | |
download | meta-openembedded-4921a6df059ad474e4451dde587640a3291d74b1.tar.gz |
libpeas: Fix reference to TMPDIR in tests
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-gnome')
-rw-r--r-- | meta-oe/recipes-gnome/libpeas/libpeas/0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch | 82 | ||||
-rw-r--r-- | meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb | 1 |
2 files changed, 83 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/libpeas/libpeas/0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch b/meta-oe/recipes-gnome/libpeas/libpeas/0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch new file mode 100644 index 0000000000..6bb48777ec --- /dev/null +++ b/meta-oe/recipes-gnome/libpeas/libpeas/0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch | |||
@@ -0,0 +1,82 @@ | |||
1 | From d798af685e9e1166400acbdab082c17b02dad85b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 18 May 2023 23:28:10 -0700 | ||
4 | Subject: [PATCH] Remove builddir and srcdir paths from test binaries | ||
5 | |||
6 | Encoding buildtime paths is not needed since if these tests are to be | ||
7 | run they will be run on target where builddir structure most certainly | ||
8 | wont be available. | ||
9 | |||
10 | Fixes | ||
11 | WARNING: libpeas-1.36.0-r0 do_package_qa: QA Issue: File /usr/bin/peas-demo in package libpeas-demo contains reference to TMPDIR [buildpaths] | ||
12 | |||
13 | Upstream-Status: Inappropriate [Cross-compile specific] | ||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | peas-demo/meson.build | 2 +- | ||
17 | tests/libpeas-gtk/testing/meson.build | 4 ++-- | ||
18 | tests/libpeas/testing/meson.build | 4 ++-- | ||
19 | tests/testing-util/meson.build | 4 ++-- | ||
20 | 4 files changed, 7 insertions(+), 7 deletions(-) | ||
21 | |||
22 | diff --git a/peas-demo/meson.build b/peas-demo/meson.build | ||
23 | index a3ec53b..855ebf2 100644 | ||
24 | --- a/peas-demo/meson.build | ||
25 | +++ b/peas-demo/meson.build | ||
26 | @@ -9,7 +9,7 @@ peas_demo_c = [ | ||
27 | |||
28 | peas_demo_c_args = [ | ||
29 | '-DHAVE_CONFIG_H', | ||
30 | - '-DPEAS_BUILDDIR="@0@"'.format(builddir), | ||
31 | + '-DPEAS_BUILDDIR="/usr/src/debug/libpeas"', | ||
32 | '-DPEAS_PREFIX="@0@"'.format(prefix), | ||
33 | '-DPEAS_LIBDIR="@0@"'.format(libdir), | ||
34 | ] | ||
35 | diff --git a/tests/libpeas-gtk/testing/meson.build b/tests/libpeas-gtk/testing/meson.build | ||
36 | index 646f42d..fd9a692 100644 | ||
37 | --- a/tests/libpeas-gtk/testing/meson.build | ||
38 | +++ b/tests/libpeas-gtk/testing/meson.build | ||
39 | @@ -19,8 +19,8 @@ libpeas_gtk_testing_deps = [ | ||
40 | |||
41 | libpeas_gtk_testing_c_args = [ | ||
42 | '-DHAVE_CONFIG_H', | ||
43 | - '-DBUILDDIR="@0@"'.format(builddir), | ||
44 | - '-DSRCDIR="@0@"'.format(srcdir), | ||
45 | + '-DBUILDDIR="/usr/src/debug/libpeas"', | ||
46 | + '-DSRCDIR="/usr/src/debug/libpeas"', | ||
47 | ] | ||
48 | |||
49 | libpeas_gtk_testing_lib = library( | ||
50 | diff --git a/tests/libpeas/testing/meson.build b/tests/libpeas/testing/meson.build | ||
51 | index 74ba7b1..084daa9 100644 | ||
52 | --- a/tests/libpeas/testing/meson.build | ||
53 | +++ b/tests/libpeas/testing/meson.build | ||
54 | @@ -21,8 +21,8 @@ libpeas_testing_deps = [ | ||
55 | |||
56 | libpeas_testing_c_args = [ | ||
57 | '-DHAVE_CONFIG_H', | ||
58 | - '-DBUILDDIR="@0@"'.format(builddir), | ||
59 | - '-DSRCDIR="@0@"'.format(srcdir), | ||
60 | + '-DBUILDDIR="/usr/src/debug/libpeas"', | ||
61 | + '-DSRCDIR="/usr/src/debug/libpeas"', | ||
62 | ] | ||
63 | |||
64 | libpeas_testing_lib = library( | ||
65 | diff --git a/tests/testing-util/meson.build b/tests/testing-util/meson.build | ||
66 | index 1c40740..83ad059 100644 | ||
67 | --- a/tests/testing-util/meson.build | ||
68 | +++ b/tests/testing-util/meson.build | ||
69 | @@ -17,8 +17,8 @@ libtesting_util_deps = [ | ||
70 | |||
71 | libtesting_util_c_args = [ | ||
72 | '-DHAVE_CONFIG_H', | ||
73 | - '-DBUILDDIR="@0@"'.format(builddir), | ||
74 | - '-DSRCDIR="@0@"'.format(srcdir), | ||
75 | + '-DBUILDDIR="/usr/src/debug/libpeas"', | ||
76 | + '-DSRCDIR="/usr/src/debug/libpeas"', | ||
77 | '-UG_DISABLE_ASSERT', | ||
78 | '-UG_DISABLE_CAST_CHECKS', | ||
79 | ] | ||
80 | -- | ||
81 | 2.40.1 | ||
82 | |||
diff --git a/meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb b/meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb index 1282e93634..8262cc2212 100644 --- a/meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb +++ b/meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb | |||
@@ -12,6 +12,7 @@ inherit gnomebase gobject-introspection gtk-doc gtk-icon-cache features_check | |||
12 | 12 | ||
13 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" | 13 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
14 | 14 | ||
15 | SRC_URI += "file://0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch" | ||
15 | SRC_URI[archive.sha256sum] = "297cb9c2cccd8e8617623d1a3e8415b4530b8e5a893e3527bbfd1edd13237b4c" | 16 | SRC_URI[archive.sha256sum] = "297cb9c2cccd8e8617623d1a3e8415b4530b8e5a893e3527bbfd1edd13237b4c" |
16 | 17 | ||
17 | PACKAGECONFIG[python3] = "-Dpython3=true,-Dpython3=false,python3-pygobject" | 18 | PACKAGECONFIG[python3] = "-Dpython3=true,-Dpython3=false,python3-pygobject" |