summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-09-19 01:04:40 +0200
committerKhem Raj <raj.khem@gmail.com>2023-09-20 15:34:02 -0700
commit2c2b6c75227890c9738b48badab3d3b903a2e8ab (patch)
tree23f1e454161ad1b4a0eda41b28fc84bd7b1b4907 /meta-oe/recipes-gnome
parent86169af03a85c93e250920bab569eb7f147e0c1f (diff)
downloadmeta-openembedded-2c2b6c75227890c9738b48badab3d3b903a2e8ab.tar.gz
libxmlb: remove recipe
It was moved to oe-core Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-gnome')
-rw-r--r--meta-oe/recipes-gnome/libxmlb/libxmlb/0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch35
-rw-r--r--meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest3
-rw-r--r--meta-oe/recipes-gnome/libxmlb/libxmlb_0.3.14.bb25
3 files changed, 0 insertions, 63 deletions
diff --git a/meta-oe/recipes-gnome/libxmlb/libxmlb/0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch b/meta-oe/recipes-gnome/libxmlb/libxmlb/0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch
deleted file mode 100644
index da8ce68df..000000000
--- a/meta-oe/recipes-gnome/libxmlb/libxmlb/0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From dc208bafc57c1ccaa0ca260f99c8b4c976271ebc Mon Sep 17 00:00:00 2001
2From: Markus Volk <f_l_k@t-online.de>
3Date: Sat, 16 Sep 2023 14:02:57 +0200
4Subject: [PATCH] xb-self-test.c: hardcode G_TEST_SRCDIR
5
6This avoids:
7 libxmlb-0.3.14-r0 do_package_qa: QA Issue: File
8 /usr/libexec/installed-tests/libxmlb/xb-self-test in package libxmlb-ptest
9 contains reference to TMPDIR [buildpaths]
10
11and also fixes the runtime for the ptest.
12
13Upstream-Status: Inappropriate [oe-specific]
14
15Signed-off-by: Markus Volk <f_l_k@t-online.de>
16---
17 src/xb-self-test.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/src/xb-self-test.c b/src/xb-self-test.c
21index 47d9728..8b3dd0e 100644
22--- a/src/xb-self-test.c
23+++ b/src/xb-self-test.c
24@@ -2870,7 +2870,7 @@ xb_speed_func(void)
25 int
26 main(int argc, char **argv)
27 {
28- g_setenv("G_TEST_SRCDIR", SRCDIR, FALSE);
29+ g_setenv("G_TEST_SRCDIR", "/usr/libexec/installed-tests/libxmlb", FALSE);
30
31 g_test_init(&argc, &argv, NULL);
32
33--
342.41.0
35
diff --git a/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest b/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest
deleted file mode 100644
index 6d0bb95d3..000000000
--- a/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#! /bin/sh
2
3gnome-desktop-testing-runner libxmlb
diff --git a/meta-oe/recipes-gnome/libxmlb/libxmlb_0.3.14.bb b/meta-oe/recipes-gnome/libxmlb/libxmlb_0.3.14.bb
deleted file mode 100644
index 1d3b0de29..000000000
--- a/meta-oe/recipes-gnome/libxmlb/libxmlb_0.3.14.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1SUMMARY = "A library to help create and query binary XML blobs"
2HOMEPAGE = "https://github.com/hughsie/libxmlb"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
5
6SRC_URI = " \
7 git://github.com/hughsie/libxmlb.git;branch=main;protocol=https \
8 file://0001-xb-selftest.c-hardcode-G_TEST_SRCDIR.patch \
9 file://run-ptest \
10"
11SRCREV = "aa577b276adc66564f5777f9a522ca3bf0bfa65e"
12S = "${WORKDIR}/git"
13
14DEPENDS = "glib-2.0 xz zstd"
15
16inherit gobject-introspection gtk-doc meson ptest-gnome lib_package pkgconfig
17
18PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
19PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
20
21GTKDOC_MESON_OPTION = "gtkdoc"
22
23FILES:${PN} += "${datadir}"
24
25BBCLASSEXTEND = "native"