summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2020-06-12 17:13:39 +0100
committerKhem Raj <raj.khem@gmail.com>2020-06-13 21:34:21 -0700
commit2964b564f5e8eff7d8682b6190a84e3b12a7e750 (patch)
tree7612ec8e1e594fb0d8ecef2cf22fa00eeb7f6d61 /meta-oe/recipes-gnome
parent5fb2893684df6f005f8f5a98be74cfc424247343 (diff)
downloadmeta-openembedded-2964b564f5e8eff7d8682b6190a84e3b12a7e750.tar.gz
libjcat: Add recipe
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-gnome')
-rw-r--r--meta-oe/recipes-gnome/libjcat/libjcat/run-ptest3
-rw-r--r--meta-oe/recipes-gnome/libjcat/libjcat_0.1.2.bb34
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/libjcat/libjcat/run-ptest b/meta-oe/recipes-gnome/libjcat/libjcat/run-ptest
new file mode 100644
index 000000000..14980a7d0
--- /dev/null
+++ b/meta-oe/recipes-gnome/libjcat/libjcat/run-ptest
@@ -0,0 +1,3 @@
1#! /bin/sh
2
3gnome-desktop-testing-runner libjcat
diff --git a/meta-oe/recipes-gnome/libjcat/libjcat_0.1.2.bb b/meta-oe/recipes-gnome/libjcat/libjcat_0.1.2.bb
new file mode 100644
index 000000000..10f5a800b
--- /dev/null
+++ b/meta-oe/recipes-gnome/libjcat/libjcat_0.1.2.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Library for reading and writing Jcat files"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
4
5DEPENDS = "\
6 glib-2.0 \
7 json-glib \
8"
9
10SRC_URI = "\
11 git://github.com/hughsie/libjcat.git \
12 file://run-ptest \
13"
14SRCREV = "1a509ac60b7446254c3bd1f45ea53e6cffba30ac"
15S = "${WORKDIR}/git"
16
17inherit gobject-introspection gtk-doc meson ptest-gnome vala
18
19PACKAGECONFIG ??= "\
20 gpg \
21 pkcs7 \
22 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
23"
24PACKAGECONFIG[gpg] = "-Dgpg=true,-Dgpg=false,gpgme"
25PACKAGECONFIG[pkcs7] = "-Dpkcs7=true,-Dpkcs7=false,gnutls gnutls-native"
26PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
27
28# manpage generation is broken because help2man needs to run the target binary on the host...
29EXTRA_OEMESON = "-Dman=false"
30GTKDOC_MESON_OPTION = "gtkdoc"
31
32RDEPENDS_${PN}_class-target = "\
33 ${@bb.utils.contains('PACKAGECONFIG', 'gpg', 'gnupg', '', d)} \
34"