diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-21 11:43:19 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-21 11:43:19 +0100 |
commit | fdbc6ae58b2bddb2ba7bac1cad61c8526a702cc2 (patch) | |
tree | b3496296830a1f464d0144e4bda88f1ce2e62ebc /meta-oe/recipes-extended | |
parent | eeb018e16cfa403763b13d72d21dd080775eb9ef (diff) | |
download | meta-openembedded-fdbc6ae58b2bddb2ba7bac1cad61c8526a702cc2.tar.gz |
libwmf: add 0.2.8.4
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended')
3 files changed, 69 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-intoverflow.patch b/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-intoverflow.patch new file mode 100644 index 000000000..50d915c01 --- /dev/null +++ b/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-intoverflow.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | http://cvs.fedoraproject.org/viewvc/devel/libwmf/libwmf-0.2.8.4-intoverflow.patch?view=log | ||
2 | |||
3 | CVE-2006-3376 libwmf integer overflow | ||
4 | |||
5 | --- libwmf-0.2.8.4.orig/src/player.c 2002-12-10 19:30:26.000000000 +0000 | ||
6 | +++ libwmf-0.2.8.4/src/player.c 2006-07-12 15:12:52.000000000 +0100 | ||
7 | @@ -42,6 +42,7 @@ | ||
8 | #include "player/defaults.h" /* Provides: default settings */ | ||
9 | #include "player/record.h" /* Provides: parameter mechanism */ | ||
10 | #include "player/meta.h" /* Provides: record interpreters */ | ||
11 | +#include <stdint.h> | ||
12 | |||
13 | /** | ||
14 | * @internal | ||
15 | @@ -132,8 +134,14 @@ | ||
16 | } | ||
17 | } | ||
18 | |||
19 | -/* P->Parameters = (unsigned char*) wmf_malloc (API,(MAX_REC_SIZE(API)-3) * 2 * sizeof (unsigned char)); | ||
20 | - */ P->Parameters = (unsigned char*) wmf_malloc (API,(MAX_REC_SIZE(API) ) * 2 * sizeof (unsigned char)); | ||
21 | + if (MAX_REC_SIZE(API) > UINT32_MAX / 2) | ||
22 | + { | ||
23 | + API->err = wmf_E_InsMem; | ||
24 | + WMF_DEBUG (API,"bailing..."); | ||
25 | + return (API->err); | ||
26 | + } | ||
27 | + | ||
28 | + P->Parameters = (unsigned char*) wmf_malloc (API,(MAX_REC_SIZE(API) ) * 2 * sizeof (unsigned char)); | ||
29 | |||
30 | if (ERR (API)) | ||
31 | { WMF_DEBUG (API,"bailing..."); | ||
diff --git a/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-useafterfree.patch b/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-useafterfree.patch new file mode 100644 index 000000000..4d2d28564 --- /dev/null +++ b/meta-oe/recipes-extended/libwmf/libwmf/libwmf-0.2.8.4-useafterfree.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | |||
2 | http://cvs.fedoraproject.org/viewvc/devel/libwmf/libwmf-0.2.8.4-useafterfree.patch?view=log | ||
3 | Resolves: CVE-2009-1364 | ||
4 | |||
5 | --- libwmf-0.2.8.4/src/extra/gd/gd_clip.c.CVE-2009-1364-im-clip-list 2009-04-24 04:06:44.000000000 -0400 | ||
6 | +++ libwmf-0.2.8.4/src/extra/gd/gd_clip.c 2009-04-24 04:08:30.000000000 -0400 | ||
7 | @@ -70,6 +70,7 @@ void gdClipSetAdd(gdImagePtr im,gdClipRe | ||
8 | { more = gdRealloc (im->clip->list,(im->clip->max + 8) * sizeof (gdClipRectangle)); | ||
9 | if (more == 0) return; | ||
10 | im->clip->max += 8; | ||
11 | + im->clip->list = more; | ||
12 | } | ||
13 | im->clip->list[im->clip->count] = (*rect); | ||
14 | im->clip->count++; | ||
diff --git a/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb b/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb new file mode 100644 index 000000000..1e05da414 --- /dev/null +++ b/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "Library for converting WMF files" | ||
2 | HOMEPAGE = "http://wvware.sourceforge.net/libwmf.html" | ||
3 | SECTION = "libs" | ||
4 | |||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
7 | |||
8 | DEPENDS_virtclass-native = "libpng jpeg" | ||
9 | DEPENDS = "libpng jpeg expat gtk+" | ||
10 | |||
11 | BBCLASSEXTEND = "native" | ||
12 | |||
13 | inherit autotools | ||
14 | |||
15 | SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/${PN}/${PV}/${P}.tar.gz;name=tarball \ | ||
16 | file://libwmf-0.2.8.4-intoverflow.patch \ | ||
17 | file://libwmf-0.2.8.4-useafterfree.patch" | ||
18 | SRC_URI[tarball.md5sum] = "d1177739bf1ceb07f57421f0cee191e0" | ||
19 | SRC_URI[tarball.sha256sum] = "5b345c69220545d003ad52bfd035d5d6f4f075e65204114a9e875e84895a7cf8" | ||
20 | |||
21 | FILES_${PN}-dbg += "${libdir}/gtk-2.0/2.10.0/loaders/.debug" | ||
22 | FILES_${PN}-dev += "${libdir}/gtk-2.0/2.10.0/loaders/*.la ${libdir}/gtk-2.0/2.10.0/loaders/*.a" | ||
23 | FILES_${PN} += "${libdir}/gtk-2.0/2.10.0/loaders/*.so" | ||
24 | |||