diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-08-24 15:43:47 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-24 15:46:31 -0700 |
commit | fa2398e99968bc56b82e15e5f04dc6425174c8de (patch) | |
tree | cc3396d5179c91b872b70ec9bfe6d5da5a31c500 /meta-oe/recipes-extended | |
parent | 5d3486da55394b3efb6c7937a82d88c25ae2f483 (diff) | |
download | meta-openembedded-fa2398e99968bc56b82e15e5f04dc6425174c8de.tar.gz |
libblockdev: Fix build with latest e2fsprogs
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch | 92 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb | 1 |
2 files changed, 93 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch b/meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch new file mode 100644 index 0000000000..8129c1e2a7 --- /dev/null +++ b/meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch | |||
@@ -0,0 +1,92 @@ | |||
1 | From 3aad8d471201da4125bd03d7a6921707461fe182 Mon Sep 17 00:00:00 2001 | ||
2 | From: Vojtech Trefny <vtrefny@redhat.com> | ||
3 | Date: Fri, 7 Jun 2024 10:06:22 +0200 | ||
4 | Subject: [PATCH 1/3] fs: Ignore unused-parameter warning in the FS plugin | ||
5 | |||
6 | There are some unused parameters in the libext2fs header which | ||
7 | together with Wall and Werror means the plugin compilation fails. | ||
8 | As a workaround we'll disable the unused-parameter warning for | ||
9 | now. | ||
10 | |||
11 | Fixes: #1026 | ||
12 | |||
13 | Taken from Fedora | ||
14 | |||
15 | Upstream-Status: Pending | ||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | |||
18 | --- | ||
19 | src/plugins/fs/Makefile.am | 2 +- | ||
20 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/src/plugins/fs/Makefile.am b/src/plugins/fs/Makefile.am | ||
23 | index 7d4849c0..00474d5a 100644 | ||
24 | --- a/src/plugins/fs/Makefile.am | ||
25 | +++ b/src/plugins/fs/Makefile.am | ||
26 | @@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects | ||
27 | |||
28 | lib_LTLIBRARIES = libbd_fs.la | ||
29 | |||
30 | -libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror | ||
31 | +libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter | ||
32 | libbd_fs_la_LIBADD = ${builddir}/../../utils/libbd_utils.la $(GLIB_LIBS) $(GIO_LIBS) $(BLKID_LIBS) $(MOUNT_LIBS) $(UUID_LIBS) $(EXT2FS_LIBS) | ||
33 | libbd_fs_la_LDFLAGS = -L${srcdir}/../../utils/ -version-info 3:0:0 -Wl,--no-undefined -export-symbols-regex '^bd_.*' | ||
34 | libbd_fs_la_CPPFLAGS = -I${builddir}/../../../include/ -I${srcdir}/../ | ||
35 | -- | ||
36 | 2.45.2 | ||
37 | |||
38 | |||
39 | From da5c14f3e2f83c8c40203897154ee2b788782792 Mon Sep 17 00:00:00 2001 | ||
40 | From: Vojtech Trefny <vtrefny@redhat.com> | ||
41 | Date: Fri, 7 Jun 2024 15:21:09 +0200 | ||
42 | Subject: [PATCH 2/3] fs: Ignore shift-count-overflow warning in FS plugin | ||
43 | |||
44 | The warning happens in the libext2fs header. | ||
45 | --- | ||
46 | src/plugins/fs/Makefile.am | 2 +- | ||
47 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
48 | |||
49 | diff --git a/src/plugins/fs/Makefile.am b/src/plugins/fs/Makefile.am | ||
50 | index 00474d5a..42e1c777 100644 | ||
51 | --- a/src/plugins/fs/Makefile.am | ||
52 | +++ b/src/plugins/fs/Makefile.am | ||
53 | @@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects | ||
54 | |||
55 | lib_LTLIBRARIES = libbd_fs.la | ||
56 | |||
57 | -libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter | ||
58 | +libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter -Wno-shift-count-overflow | ||
59 | libbd_fs_la_LIBADD = ${builddir}/../../utils/libbd_utils.la $(GLIB_LIBS) $(GIO_LIBS) $(BLKID_LIBS) $(MOUNT_LIBS) $(UUID_LIBS) $(EXT2FS_LIBS) | ||
60 | libbd_fs_la_LDFLAGS = -L${srcdir}/../../utils/ -version-info 3:0:0 -Wl,--no-undefined -export-symbols-regex '^bd_.*' | ||
61 | libbd_fs_la_CPPFLAGS = -I${builddir}/../../../include/ -I${srcdir}/../ | ||
62 | -- | ||
63 | 2.45.2 | ||
64 | |||
65 | |||
66 | From 90ceb4b52fbda34673fe5303da84b9a902187503 Mon Sep 17 00:00:00 2001 | ||
67 | From: Vojtech Trefny <vtrefny@redhat.com> | ||
68 | Date: Wed, 12 Jun 2024 15:34:02 +0200 | ||
69 | Subject: [PATCH 3/3] fs: Fix ignoring errors from libext2fs | ||
70 | |||
71 | Follow-up for #1028, we still want to show the warning and not | ||
72 | completely supress it. | ||
73 | --- | ||
74 | src/plugins/fs/Makefile.am | 2 +- | ||
75 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
76 | |||
77 | diff --git a/src/plugins/fs/Makefile.am b/src/plugins/fs/Makefile.am | ||
78 | index 42e1c777..1ee256f0 100644 | ||
79 | --- a/src/plugins/fs/Makefile.am | ||
80 | +++ b/src/plugins/fs/Makefile.am | ||
81 | @@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects | ||
82 | |||
83 | lib_LTLIBRARIES = libbd_fs.la | ||
84 | |||
85 | -libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter -Wno-shift-count-overflow | ||
86 | +libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-error=unused-parameter -Wno-error=shift-count-overflow | ||
87 | libbd_fs_la_LIBADD = ${builddir}/../../utils/libbd_utils.la $(GLIB_LIBS) $(GIO_LIBS) $(BLKID_LIBS) $(MOUNT_LIBS) $(UUID_LIBS) $(EXT2FS_LIBS) | ||
88 | libbd_fs_la_LDFLAGS = -L${srcdir}/../../utils/ -version-info 3:0:0 -Wl,--no-undefined -export-symbols-regex '^bd_.*' | ||
89 | libbd_fs_la_CPPFLAGS = -I${builddir}/../../../include/ -I${srcdir}/../ | ||
90 | -- | ||
91 | 2.45.2 | ||
92 | |||
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb index fb778005ff..a42e09d336 100644 --- a/meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb +++ b/meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb | |||
@@ -14,6 +14,7 @@ DEPENDS = "autoconf-archive-native glib-2.0 kmod udev libnvme" | |||
14 | 14 | ||
15 | SRC_URI = "git://github.com/storaged-project/libblockdev;branch=3.1.x-devel;protocol=https \ | 15 | SRC_URI = "git://github.com/storaged-project/libblockdev;branch=3.1.x-devel;protocol=https \ |
16 | file://0001-fix-pythondir-for-multilib-when-cross-compiling.patch \ | 16 | file://0001-fix-pythondir-for-multilib-when-cross-compiling.patch \ |
17 | file://0001-libext2fs-unused-parameters-fix.patch \ | ||
17 | " | 18 | " |
18 | SRCREV = "68aaff5556afe26be749c29a2b7cbd714dce3050" | 19 | SRCREV = "68aaff5556afe26be749c29a2b7cbd714dce3050" |
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |