summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2015-11-05 09:47:30 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 17:53:58 +0100
commitf0fa58e2c5b6e5e0b9be3bdbd3100f773e17dacf (patch)
tree3803f2deab5591379d938d1e2b66e71955423b4e /meta-oe/recipes-extended
parent105e117645cfd1068db8d3522732dd9e76fc6953 (diff)
downloadmeta-openembedded-f0fa58e2c5b6e5e0b9be3bdbd3100f773e17dacf.tar.gz
wipe: add version 0.23
Wipe is a little command for securely erasing files from magnetic media. We do not support native, because wipe needs root permission. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/wipe/files/support-cross-compile-for-linux.patch36
-rw-r--r--meta-oe/recipes-extended/wipe/wipe_git.bb26
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/wipe/files/support-cross-compile-for-linux.patch b/meta-oe/recipes-extended/wipe/files/support-cross-compile-for-linux.patch
new file mode 100644
index 000000000..fb3aee806
--- /dev/null
+++ b/meta-oe/recipes-extended/wipe/files/support-cross-compile-for-linux.patch
@@ -0,0 +1,36 @@
1From 35f14bd5aba2ed6cee258e11eab42c408afc04d0 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 4 Nov 2015 02:29:05 -0500
4Subject: [PATCH] Makefile: support cross compile for linux
5
6Upstream-Status: Pending
7Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
8---
9 Makefile | 5 +++--
10 1 file changed, 3 insertions(+), 2 deletions(-)
11
12diff --git a/Makefile b/Makefile
13index 17d9758..9e74cdf 100644
14--- a/Makefile
15+++ b/Makefile
16@@ -41,7 +41,7 @@
17 # Linux 2.0.x
18 #
19
20-CC_LINUX=gcc
21+CC_LINUX=$(CC)
22 CCO_LINUX=-Wall -DHAVE_DEV_URANDOM -DHAVE_OSYNC -DHAVE_STRCASECMP -DHAVE_RANDOM -DWEAK_RC6 -DSYNC_WAITS_FOR_SYNC -DFIND_DEVICE_SIZE_BY_BLKGETSIZE -DSIXTYFOUR -D__USE_LARGEFILE -D_FILE_OFFSET_BITS=64
23 # default should be to turn off debugging and to turn on optimization.
24 #CCO_LINUX+=-O9 -pipe -fomit-frame-pointer -finline-functions -funroll-loops -fstrength-reduce
25@@ -185,6 +185,7 @@ clean :
26 rm -f wipe $(OBJECTS) wipe.tr-asc.1 version.h
27
28 install:
29- install -m755 -o root -g root wipe $(DESTDIR)/usr/bin
30+ [ -e $(DESTDIR)$(bindir) ] || mkdir -p $(DESTDIR)$(bindir)
31+ install -m755 -o root -g root wipe $(DESTDIR)$(bindir)
32
33 .PHONY: always clean install
34--
351.9.1
36
diff --git a/meta-oe/recipes-extended/wipe/wipe_git.bb b/meta-oe/recipes-extended/wipe/wipe_git.bb
new file mode 100644
index 000000000..70229f014
--- /dev/null
+++ b/meta-oe/recipes-extended/wipe/wipe_git.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A UNIX tool for secure deletion"
2DESCRIPTION = "Wipe is a little command for securely erasing files from \
3magnetic media. It compiles under various unix platforms, \
4including Linux 2. * , (Open, Net, Free)BSD, aix 4.1, SunOS \
55.5.1, Solaris 2.6. wipe is released under the GPL. Pre-compiled \
6packages are available on most Linux distributions. \
7Under Debian, the package name is wipe"
8HOMEPAGE = "http://lambda-diode.com/software/wipe/"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://GPL;md5=0636e73ff0215e8d672dc4c32c317bb3"
11
12SRC_URI = "git://github.com/berke/wipe.git;branch=master \
13 file://support-cross-compile-for-linux.patch \
14 "
15SRCREV = "d9c100c9cd0b1cbbe4359e4d6c9a035d11e7597c"
16PV = "0.23+git${SRCPV}"
17
18S = "${WORKDIR}/git"
19
20EXTRA_OEMAKE = "linux"
21
22do_install() {
23 make install DESTDIR=${D}
24}
25
26do_configure[noexec] = "1"