summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-09-25 21:19:07 +0800
committerKhem Raj <raj.khem@gmail.com>2018-09-25 22:24:15 -0700
commite46ed5b414d617a20c1e6cd78e50915e960fffd8 (patch)
treedbb4964a44a97f57de7f4f5a46ff418c0df58962 /meta-oe/recipes-extended
parent23d794b58661807307a3c4af3f3da1fc1027f41b (diff)
downloadmeta-openembedded-e46ed5b414d617a20c1e6cd78e50915e960fffd8.tar.gz
mailx: support openssl 1.1.x
Long time no maintain from upstream since 2013-06-04, backport a fix from openSUSE Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/mailx/files/0001-support-openssl-1.1.x.patch72
-rw-r--r--meta-oe/recipes-extended/mailx/mailx_12.5-5.bb3
2 files changed, 74 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/mailx/files/0001-support-openssl-1.1.x.patch b/meta-oe/recipes-extended/mailx/files/0001-support-openssl-1.1.x.patch
new file mode 100644
index 000000000..6a8911daf
--- /dev/null
+++ b/meta-oe/recipes-extended/mailx/files/0001-support-openssl-1.1.x.patch
@@ -0,0 +1,72 @@
1From 7db6d8a657d13bb562a27c6181accaf3e53c0efd Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Tue, 25 Sep 2018 14:03:10 +0800
4Subject: [PATCH] support openssl 1.1.x
5
6Long time no maintain from upstream since 2013-06-04
7(https://sourceforge.net/projects/nail/), backport a
8fix from openSUSE
9
10Upstream-Status: Backport [openSUSE]
11https://build.opensuse.org/package/view_file/openSUSE:Leap:15.0/mailx/mailx-12.5-openssl-1.1.0f.patch?expand=1
12
13Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
14---
15 openssl.c | 25 ++++++++++++++++++++++++-
16 1 file changed, 24 insertions(+), 1 deletion(-)
17
18diff --git a/openssl.c b/openssl.c
19index 44fe4e5..0ccc517 100644
20--- a/openssl.c
21+++ b/openssl.c
22@@ -137,7 +137,12 @@ ssl_rand_init(void)
23
24 if ((cp = value("ssl-rand-egd")) != NULL) {
25 cp = expand(cp);
26- if (RAND_egd(cp) == -1) {
27+#ifndef OPENSSL_NO_EGD
28+ if (RAND_egd(cp) == -1)
29+#else
30+ if (1)
31+#endif
32+ {
33 fprintf(stderr, catgets(catd, CATSET, 245,
34 "entropy daemon at \"%s\" not available\n"),
35 cp);
36@@ -216,6 +221,7 @@ ssl_select_method(const char *uhp)
37
38 cp = ssl_method_string(uhp);
39 if (cp != NULL) {
40+#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x1010006fL
41 if (equal(cp, "ssl3"))
42 method = SSLv3_client_method();
43 else if (equal(cp, "tls1"))
44@@ -225,8 +231,25 @@ ssl_select_method(const char *uhp)
45 "Invalid SSL method \"%s\"\n"), cp);
46 method = SSLv23_client_method();
47 }
48+#else
49+ method = NULL;
50+ if (equal(cp, "tls"))
51+ method = TLS_client_method();
52+ else if (equal(cp, "dtls"))
53+ method = DTLS_client_method();
54+
55+ if (!method) {
56+ fprintf(stderr, catgets(catd, CATSET, 244,
57+ "Invalid SSL method \"%s\"\n"), cp);
58+ method = TLS_client_method();
59+ }
60+#endif
61 } else
62+#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x1010006fL
63 method = SSLv23_client_method();
64+#else
65+ method = TLS_client_method();
66+#endif
67 return method;
68 }
69
70--
712.7.4
72
diff --git a/meta-oe/recipes-extended/mailx/mailx_12.5-5.bb b/meta-oe/recipes-extended/mailx/mailx_12.5-5.bb
index 0a191a00c..4161ea675 100644
--- a/meta-oe/recipes-extended/mailx/mailx_12.5-5.bb
+++ b/meta-oe/recipes-extended/mailx/mailx_12.5-5.bb
@@ -9,7 +9,7 @@ SECTION = "console/network"
9LICENSE = "BSD & MPL-1" 9LICENSE = "BSD & MPL-1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=4202a0a62910cf94f7af8a3436a2a2dd" 10LIC_FILES_CHKSUM = "file://COPYING;md5=4202a0a62910cf94f7af8a3436a2a2dd"
11 11
12DEPENDS = "openssl10" 12DEPENDS = "openssl"
13 13
14SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/h/heirloom-mailx/heirloom-mailx_12.5.orig.tar.gz;name=archive \ 14SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/h/heirloom-mailx/heirloom-mailx_12.5.orig.tar.gz;name=archive \
15 file://0001-Don-t-reuse-weak-symbol-optopt-to-fix-FTBFS-on-mips.patch \ 15 file://0001-Don-t-reuse-weak-symbol-optopt-to-fix-FTBFS-on-mips.patch \
@@ -21,6 +21,7 @@ SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/
21 file://0014-globname-Invoke-wordexp-with-WRDE_NOCMD.patch \ 21 file://0014-globname-Invoke-wordexp-with-WRDE_NOCMD.patch \
22 file://0015-usr-sbin-sendmail.patch \ 22 file://0015-usr-sbin-sendmail.patch \
23 file://explicitly.disable.krb5.support.patch \ 23 file://explicitly.disable.krb5.support.patch \
24 file://0001-support-openssl-1.1.x.patch \
24 " 25 "
25 26
26SRC_URI[archive.md5sum] = "29a6033ef1412824d02eb9d9213cb1f2" 27SRC_URI[archive.md5sum] = "29a6033ef1412824d02eb9d9213cb1f2"