diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-05-09 17:55:28 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-05-12 08:43:19 -0700 |
commit | de813392cf464bfadf7df67adfbb0e928f5f663d (patch) | |
tree | dee37ae64a45e7a69560bc53dcfcc2276ab73121 /meta-oe/recipes-extended | |
parent | 064f6fae4f7af1fffe8c417a5ed175da104dbc85 (diff) | |
download | meta-openembedded-de813392cf464bfadf7df67adfbb0e928f5f663d.tar.gz |
fluentbit: Upgrade to 1.9.9
Disable incompatible-pointer-types warning as error to fix build
with gcc-14
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Do-not-use-private-makefile-target.patch | 18 | ||||
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit_1.9.9.bb (renamed from meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb) | 5 |
2 files changed, 10 insertions, 13 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Do-not-use-private-makefile-target.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Do-not-use-private-makefile-target.patch index f5a1716c0..0cabed963 100644 --- a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Do-not-use-private-makefile-target.patch +++ b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Do-not-use-private-makefile-target.patch | |||
@@ -15,8 +15,6 @@ Upstream-Status: Pending [https://github.com/fluent/fluent-bit/issues/5492] | |||
15 | lib/cmetrics/CMakeLists.txt | 7 +------ | 15 | lib/cmetrics/CMakeLists.txt | 7 +------ |
16 | 3 files changed, 3 insertions(+), 17 deletions(-) | 16 | 3 files changed, 3 insertions(+), 17 deletions(-) |
17 | 17 | ||
18 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
19 | index 3dba5a8..d94b988 100644 | ||
20 | --- a/CMakeLists.txt | 18 | --- a/CMakeLists.txt |
21 | +++ b/CMakeLists.txt | 19 | +++ b/CMakeLists.txt |
22 | @@ -46,11 +46,7 @@ else() | 20 | @@ -46,11 +46,7 @@ else() |
@@ -32,8 +30,6 @@ index 3dba5a8..d94b988 100644 | |||
32 | 30 | ||
33 | if(${CMAKE_SYSTEM_PROCESSOR} MATCHES "armv7l") | 31 | if(${CMAKE_SYSTEM_PROCESSOR} MATCHES "armv7l") |
34 | set(CMAKE_C_LINK_FLAGS "${CMAKE_C_LINK_FLAGS} -latomic") | 32 | set(CMAKE_C_LINK_FLAGS "${CMAKE_C_LINK_FLAGS} -latomic") |
35 | diff --git a/lib/chunkio/CMakeLists.txt b/lib/chunkio/CMakeLists.txt | ||
36 | index bbe1f39..809ea93 100644 | ||
37 | --- a/lib/chunkio/CMakeLists.txt | 33 | --- a/lib/chunkio/CMakeLists.txt |
38 | +++ b/lib/chunkio/CMakeLists.txt | 34 | +++ b/lib/chunkio/CMakeLists.txt |
39 | @@ -14,12 +14,7 @@ else() | 35 | @@ -14,12 +14,7 @@ else() |
@@ -50,21 +46,19 @@ index bbe1f39..809ea93 100644 | |||
50 | 46 | ||
51 | include(cmake/macros.cmake) | 47 | include(cmake/macros.cmake) |
52 | 48 | ||
53 | diff --git a/lib/cmetrics/CMakeLists.txt b/lib/cmetrics/CMakeLists.txt | ||
54 | index 60e8774..e3d6149 100644 | ||
55 | --- a/lib/cmetrics/CMakeLists.txt | 49 | --- a/lib/cmetrics/CMakeLists.txt |
56 | +++ b/lib/cmetrics/CMakeLists.txt | 50 | +++ b/lib/cmetrics/CMakeLists.txt |
57 | @@ -34,12 +34,7 @@ set(CMT_VERSION_MINOR 3) | 51 | @@ -34,12 +34,7 @@ set(CMT_VERSION_MINOR 3) |
58 | set(CMT_VERSION_PATCH 5) | 52 | set(CMT_VERSION_PATCH 7) |
59 | set(CMT_VERSION_STR "${CMT_VERSION_MAJOR}.${CMT_VERSION_MINOR}.${CMT_VERSION_PATCH}") | 53 | set(CMT_VERSION_STR "${CMT_VERSION_MAJOR}.${CMT_VERSION_MINOR}.${CMT_VERSION_PATCH}") |
60 | 54 | ||
61 | -# Define __FILENAME__ consistently across Operating Systems | 55 | -# Define __CMT_FILENAME__ consistently across Operating Systems |
62 | -if(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Windows") | 56 | -if(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Windows") |
63 | - set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D__FILENAME__='\"$(subst ${CMAKE_SOURCE_DIR}/,,$(abspath $<))\"'") | 57 | - set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D__CMT_FILENAME__='\"$(subst ${CMAKE_SOURCE_DIR}/,,$(abspath $<))\"'") |
64 | -else() | 58 | -else() |
65 | - set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D__FILENAME__=__FILE__") | 59 | - set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D__CMT_FILENAME__=__FILE__") |
66 | -endif() | 60 | -endif() |
67 | +set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D__FILENAME__=__FILE__") | 61 | +set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D__CMT_FILENAME__=__FILE__") |
68 | 62 | ||
69 | # Configuration options | 63 | # Configuration options |
70 | option(CMT_DEV "Enable development mode" No) | 64 | option(CMT_DEV "Enable development mode" No) |
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.9.bb index fc0609547..ef0411113 100644 --- a/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.7.bb +++ b/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.9.bb | |||
@@ -29,7 +29,7 @@ SRC_URI:append:libc-musl = "\ | |||
29 | file://0001-Use-posix-strerror_r-with-musl.patch \ | 29 | file://0001-Use-posix-strerror_r-with-musl.patch \ |
30 | file://0002-chunkio-Link-with-fts-library-with-musl.patch \ | 30 | file://0002-chunkio-Link-with-fts-library-with-musl.patch \ |
31 | " | 31 | " |
32 | SRC_URI[sha256sum] = "8ca2ac081d7eee717483c06608adcb5e3d5373e182ad87dba21a23f8278c6540" | 32 | SRC_URI[sha256sum] = "3f6cd4bd1894cda16b465aef6ffec7e920d54c4209b3e2320fcffe7ae345700e" |
33 | S = "${WORKDIR}/fluent-bit-${PV}" | 33 | S = "${WORKDIR}/fluent-bit-${PV}" |
34 | 34 | ||
35 | DEPENDS = "zlib bison-native flex-native openssl" | 35 | DEPENDS = "zlib bison-native flex-native openssl" |
@@ -84,6 +84,9 @@ EXTRA_OECMAKE:append:x86 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic" | |||
84 | 84 | ||
85 | CFLAGS:append:x86 = " -DMBEDTLS_HAVE_SSE2" | 85 | CFLAGS:append:x86 = " -DMBEDTLS_HAVE_SSE2" |
86 | 86 | ||
87 | # Fixes build with GCC-14 | ||
88 | CFLAGS += "-Wno-error=incompatible-pointer-types" | ||
89 | |||
87 | inherit cmake systemd pkgconfig | 90 | inherit cmake systemd pkgconfig |
88 | 91 | ||
89 | SYSTEMD_SERVICE:${PN} = "td-agent-bit.service" | 92 | SYSTEMD_SERVICE:${PN} = "td-agent-bit.service" |