summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2020-03-30 15:54:18 +0200
committerKhem Raj <raj.khem@gmail.com>2020-03-30 22:02:13 -0700
commit48267d7954cee9f414896baf372165f568cbbcd9 (patch)
tree86c61585dbccd2718c333c392f93ac78dc20529e /meta-oe/recipes-extended
parentbe3eecf7cd4fad2e945854fc6be24fe19efbb789 (diff)
downloadmeta-openembedded-48267d7954cee9f414896baf372165f568cbbcd9.tar.gz
figlet: new package
This adds a recipe for figlet - a utility for creating large characters from regular console characters. It's useful to create custom banners at run-time. Include native and nativesdk support in case we want to create banners at build-time. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/figlet/figlet/0001-build-add-autotools-support-to-allow-easy-cross-comp.patch252
-rw-r--r--meta-oe/recipes-extended/figlet/figlet_git.bb15
2 files changed, 267 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/figlet/figlet/0001-build-add-autotools-support-to-allow-easy-cross-comp.patch b/meta-oe/recipes-extended/figlet/figlet/0001-build-add-autotools-support-to-allow-easy-cross-comp.patch
new file mode 100644
index 0000000000..4429a474dc
--- /dev/null
+++ b/meta-oe/recipes-extended/figlet/figlet/0001-build-add-autotools-support-to-allow-easy-cross-comp.patch
@@ -0,0 +1,252 @@
1From 902b022c03ad6769abe4d7e6fde1df7a883857ef Mon Sep 17 00:00:00 2001
2From: Bartosz Golaszewski <bgolaszewski@baylibre.com>
3Date: Tue, 24 Mar 2020 14:44:54 +0100
4Subject: [PATCH] build: add autotools support to allow easy cross-compilation
5
6Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
7Upstream-Status: Inappropriate [upstream uses a custom Makefile and builds on
8 linux as well as Windows. I'm not sure autotools
9 would be preferred as a general solution but it
10 works well enough for yocto.]
11---
12 Makefile | 122 ---------------------------------------------------
13 Makefile.am | 67 ++++++++++++++++++++++++++++
14 configure.ac | 23 ++++++++++
15 3 files changed, 90 insertions(+), 122 deletions(-)
16 delete mode 100644 Makefile
17 create mode 100644 Makefile.am
18 create mode 100644 configure.ac
19
20diff --git a/Makefile b/Makefile
21deleted file mode 100644
22index e92bcaf..0000000
23--- a/Makefile
24+++ /dev/null
25@@ -1,122 +0,0 @@
26-# Makefile for figlet version 2.2.4 (26 Jan 2011)
27-# adapted from Makefile for figlet version 2.2.2 (05 July 2005)
28-# adapted from Makefile for figlet version 2.2 (15 Oct 1996)
29-# Copyright 1993, 1994,1995 Glenn Chappell and Ian Chai
30-# Copyright 1996, 1997, 1998, 1999, 2000, 2001 John Cowan
31-# Copyright 2002 Christiaan Keet
32-# Copyright 2011 Claudio Matsuoka
33-
34-# Please notice that to follow modern standards and ease third-party
35-# package creation, binaries are now installed under BINDIR, and DESTDIR
36-# is reserved for the installation pathname prefix.
37-#
38-# Please make sure BINDIR, MANDIR, DEFAULTFONTDIR and
39-# DEFAULTFONTFILE are defined to reflect the situation
40-# on your computer. See README for details.
41-
42-# Don't change this even if your shell is different. The only reason
43-# for changing this is if sh is not in the same place.
44-SHELL = /bin/sh
45-
46-# The C compiler and linker to use
47-CC = gcc
48-CFLAGS = -g -O2 -Wall -Wno-unused-value
49-LD = gcc
50-LDFLAGS =
51-
52-# Feature flags:
53-# define TLF_FONTS to use TOIlet TLF fonts
54-XCFLAGS = -DTLF_FONTS
55-
56-# Where to install files
57-prefix = /usr/local
58-
59-# Where the executables should be put
60-BINDIR = $(prefix)/bin
61-
62-# Where the man page should be put
63-MANDIR = $(prefix)/man
64-
65-# Where figlet will search first for fonts (the ".flf" files).
66-DEFAULTFONTDIR = $(prefix)/share/figlet
67-# Use this definition if you can't put things in $(prefix)/share/figlet
68-#DEFAULTFONTDIR = fonts
69-
70-# The filename of the font to be used if no other is specified,
71-# without suffix.(standard is recommended, but any other can be
72-# used). This font file should reside in the directory specified
73-# by DEFAULTFONTDIR.
74-DEFAULTFONTFILE = standard
75-
76-##
77-## END OF CONFIGURATION SECTION
78-##
79-
80-VERSION = 2.2.5
81-DIST = figlet-$(VERSION)
82-OBJS = figlet.o zipio.o crc.o inflate.o utf8.o
83-BINS = figlet chkfont figlist showfigfonts
84-MANUAL = figlet.6 chkfont.6 figlist.6 showfigfonts.6
85-DFILES = Makefile Makefile.tc $(MANUAL) $(OBJS:.o=.c) chkfont.c getopt.c \
86- figlist showfigfonts CHANGES FAQ README LICENSE figfont.txt \
87- crc.h inflate.h zipio.h utf8.h run-tests.sh figmagic
88-
89-.c.o:
90- $(CC) -c $(CFLAGS) $(XCFLAGS) -DDEFAULTFONTDIR=\"$(DEFAULTFONTDIR)\" \
91- -DDEFAULTFONTFILE=\"$(DEFAULTFONTFILE)\" -o $*.o $<
92-
93-all: $(BINS)
94-
95-figlet: $(OBJS)
96- $(LD) $(LDFLAGS) -o $@ $(OBJS)
97-
98-chkfont: chkfont.o
99- $(LD) $(LDFLAGS) -o $@ chkfont.o
100-
101-clean:
102- rm -f *.o *~ core figlet chkfont
103-
104-install: all
105- mkdir -p $(DESTDIR)$(BINDIR)
106- mkdir -p $(DESTDIR)$(MANDIR)/man6
107- mkdir -p $(DESTDIR)$(DEFAULTFONTDIR)
108- cp $(BINS) $(DESTDIR)$(BINDIR)
109- cp $(MANUAL) $(DESTDIR)$(MANDIR)/man6
110- cp fonts/*.flf $(DESTDIR)$(DEFAULTFONTDIR)
111- cp fonts/*.flc $(DESTDIR)$(DEFAULTFONTDIR)
112-
113-dist:
114- rm -Rf $(DIST) $(DIST).tar.gz
115- mkdir $(DIST)/
116- cp $(DFILES) $(DIST)/
117- mkdir $(DIST)/fonts
118- cp fonts/*.fl[fc] $(DIST)/fonts
119- mkdir $(DIST)/tests
120- cp tests/*txt tests/emboss.tlf $(DIST)/tests
121- tar cvf - $(DIST) | gzip -9c > $(DIST).tar.gz
122- rm -Rf $(DIST)
123- tar xf $(DIST).tar.gz
124- (cd $(DIST); make all check vercheck)
125- @rm -Rf $(DIST)
126- @echo
127- @ls -l $(DIST).tar.gz
128-
129-check:
130- @echo "Run tests in `pwd`"
131- @./run-tests.sh fonts
132- @echo
133-
134-vercheck:
135- @printf "Infocode: "; ./figlet -I1
136- @./figlet -v|sed -n '/Version/s/.*\(Version\)/\1/p'
137- @printf "README: "; head -1 < README|sed 's/.*) //'
138- @printf "FAQ: "; grep latest FAQ|sed 's/ and can.*//'
139- @grep -h "^\.TH" *.6
140-
141-$(OBJS) chkfont.o getopt.o: Makefile
142-chkfont.o: chkfont.c
143-crc.o: crc.c crc.h
144-figlet.o: figlet.c zipio.h
145-getopt.o: getopt.c
146-inflate.o: inflate.c inflate.h
147-zipio.o: zipio.c zipio.h inflate.h crc.h
148diff --git a/Makefile.am b/Makefile.am
149new file mode 100644
150index 0000000..7feb42c
151--- /dev/null
152+++ b/Makefile.am
153@@ -0,0 +1,67 @@
154+AM_CFLAGS = -include $(top_builddir)/config.h -Wall -Wextra -g
155+
156+bin_PROGRAMS = figlet chkfont
157+dist_bin_SCRIPTS = figlist showfigfonts
158+
159+figlet_SOURCES = figlet.c zipio.c crc.c inflate.c utf8.c
160+chkfont_SOURCES = chkfont.c
161+
162+fontdir = $(prefix)/share/figlet
163+dist_font_DATA = \
164+ fonts/646-ca2.flc \
165+ fonts/646-fr.flc \
166+ fonts/646-no.flc \
167+ fonts/8859-4.flc \
168+ fonts/bubble.flf \
169+ fonts/lean.flf \
170+ fonts/smscript.flf \
171+ fonts/utf8.flc \
172+ fonts/646-ca.flc \
173+ fonts/646-gb.flc \
174+ fonts/646-pt2.flc \
175+ fonts/8859-5.flc \
176+ fonts/digital.flf \
177+ fonts/mini.flf \
178+ fonts/smshadow.flf \
179+ fonts/646-cn.flc \
180+ fonts/646-hu.flc \
181+ fonts/646-pt.flc \
182+ fonts/8859-7.flc \
183+ fonts/frango.flc \
184+ fonts/mnemonic.flf \
185+ fonts/smslant.flf \
186+ fonts/646-cu.flc \
187+ fonts/646-irv.flc \
188+ fonts/646-se2.flc \
189+ fonts/8859-8.flc \
190+ fonts/hz.flc \
191+ fonts/moscow.flc \
192+ fonts/standard.flf \
193+ fonts/646-de.flc \
194+ fonts/646-it.flc \
195+ fonts/646-se.flc \
196+ fonts/8859-9.flc \
197+ fonts/ilhebrew.flc \
198+ fonts/script.flf \
199+ fonts/term.flf \
200+ fonts/646-dk.flc \
201+ fonts/646-jp.flc \
202+ fonts/646-yu.flc \
203+ fonts/banner.flf \
204+ fonts/ivrit.flf \
205+ fonts/shadow.flf \
206+ fonts/upper.flc \
207+ fonts/646-es2.flc \
208+ fonts/646-kr.flc \
209+ fonts/8859-2.flc \
210+ fonts/big.flf \
211+ fonts/jis0201.flc \
212+ fonts/slant.flf \
213+ fonts/ushebrew.flc \
214+ fonts/646-es.flc \
215+ fonts/646-no2.flc \
216+ fonts/8859-3.flc \
217+ fonts/block.flf \
218+ fonts/koi8r.flc \
219+ fonts/small.flf \
220+ fonts/uskata.flc
221diff --git a/configure.ac b/configure.ac
222new file mode 100644
223index 0000000..72154e2
224--- /dev/null
225+++ b/configure.ac
226@@ -0,0 +1,23 @@
227+AC_PREREQ(2.61)
228+
229+AC_INIT([figlet], 2.2.5)
230+
231+AC_CONFIG_AUX_DIR([autostuff])
232+AC_CONFIG_MACRO_DIRS([m4])
233+AM_INIT_AUTOMAKE([foreign subdir-objects])
234+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
235+
236+AC_CONFIG_SRCDIR([figlet.c])
237+AC_CONFIG_HEADER([config.h])
238+
239+AC_DEFINE([DEFAULTFONTDIR], ["/usr/share/figlet"], [Default font directory])
240+AC_DEFINE([DEFAULTFONTFILE], ["standard"], [Default font])
241+
242+AM_PROG_AR
243+AC_PROG_CC
244+AC_PROG_INSTALL
245+AC_HEADER_STDC
246+
247+AC_CONFIG_FILES([Makefile])
248+
249+AC_OUTPUT
250--
2512.25.0
252
diff --git a/meta-oe/recipes-extended/figlet/figlet_git.bb b/meta-oe/recipes-extended/figlet/figlet_git.bb
new file mode 100644
index 0000000000..4611646b9b
--- /dev/null
+++ b/meta-oe/recipes-extended/figlet/figlet_git.bb
@@ -0,0 +1,15 @@
1SUMMARY = "FIGlet is a program that creates large characters out of ordinary screen characters"
2HOMEPAGE = "http://www.figlet.org/"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1688bcd97b27704f1afcac7336409857"
6
7SRC_URI = "git://github.com/cmatsuoka/figlet.git \
8 file://0001-build-add-autotools-support-to-allow-easy-cross-comp.patch"
9SRCREV = "5bbcd7383a8c3a531299b216b0c734e1495c6db3"
10S = "${WORKDIR}/git"
11PV = "2.2.5+git${SRCPV}"
12
13inherit autotools
14
15BBCLASSEXTEND = "native nativesdk"