diff options
author | Mikko Ylinen <mikko.ylinen@linux.intel.com> | 2017-10-27 16:35:46 +0300 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-11-15 16:34:05 -0800 |
commit | 2913f7073f39a216ba215868f2d7e18a1ed05a2c (patch) | |
tree | 80caa8d9fb89712dcab44d1d51602d60b614546e /meta-oe/recipes-extended | |
parent | 5fbf909b0f155d843c27be2313d2390b66251409 (diff) | |
download | meta-openembedded-2913f7073f39a216ba215868f2d7e18a1ed05a2c.tar.gz |
mraa/upm: drop HAVE_NODEJS conditional
HAVE_NODEJS is a leftover from meta-refkit-core where the
layer had to adapt to different BBLAYER combinations (some
where nodejs wasn't available but mraa/upm were).
mraa/upm nodejs bindings currently fail to build (due to a problem
in swig with nodejs > v7.x) so we keep them disabled until a newer
version of swig lands in OE-core.
The commit adds BINDINGS overrides for armv4/5 to remind that nodejs
isn't available on those architectures.
Signed-off-by: Mikko Ylinen <mikko.ylinen@linux.intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/mraa/mraa_git.bb | 8 | ||||
-rw-r--r-- | meta-oe/recipes-extended/upm/upm_git.bb | 8 |
2 files changed, 14 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb index 616048fac..c4b9c6f90 100644 --- a/meta-oe/recipes-extended/mraa/mraa_git.bb +++ b/meta-oe/recipes-extended/mraa/mraa_git.bb | |||
@@ -31,7 +31,13 @@ FILES_${PN}-utils = "${bindir}/" | |||
31 | # override this in local.conf to get needed bindings. | 31 | # override this in local.conf to get needed bindings. |
32 | # BINDINGS_pn-mraa="python" | 32 | # BINDINGS_pn-mraa="python" |
33 | # will result in only the python bindings being built/packaged. | 33 | # will result in only the python bindings being built/packaged. |
34 | BINDINGS ??= "python ${@ 'nodejs' if oe.types.boolean(d.getVar('HAVE_NODEJS') or '0') else '' }" | 34 | # Note: 'nodejs' is disabled by default because the bindings |
35 | # generation currently fails with nodejs (>v7.x). | ||
36 | BINDINGS ??= "python" | ||
37 | |||
38 | # nodejs isn't available for armv4/armv5 architectures | ||
39 | BINDINGS_armv4 ??= "python" | ||
40 | BINDINGS_armv5 ??= "python" | ||
35 | 41 | ||
36 | PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \ | 42 | PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \ |
37 | ${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}" | 43 | ${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}" |
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb index 38065ce53..a5c2bb321 100644 --- a/meta-oe/recipes-extended/upm/upm_git.bb +++ b/meta-oe/recipes-extended/upm/upm_git.bb | |||
@@ -26,7 +26,13 @@ inherit distutils3-base cmake | |||
26 | # override this in local.conf to get needed bindings. | 26 | # override this in local.conf to get needed bindings. |
27 | # BINDINGS_pn-upm="python" | 27 | # BINDINGS_pn-upm="python" |
28 | # will result in only the python bindings being built/packaged. | 28 | # will result in only the python bindings being built/packaged. |
29 | BINDINGS ??= "python ${@ 'nodejs' if oe.types.boolean(d.getVar('HAVE_NODEJS') or '0') else '' }" | 29 | # Note: 'nodejs' is disabled by default because the bindings |
30 | # generation currently fails with nodejs (>v7.x). | ||
31 | BINDINGS ??= "python" | ||
32 | |||
33 | # nodejs isn't available for armv4/armv5 architectures | ||
34 | BINDINGS_armv4 ??= "python" | ||
35 | BINDINGS_armv5 ??= "python" | ||
30 | 36 | ||
31 | PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \ | 37 | PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \ |
32 | ${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}" | 38 | ${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}" |