summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-10-29 20:31:22 +0200
committerKhem Raj <raj.khem@gmail.com>2019-11-01 17:22:52 -0700
commit1f381f4444609814d2d5c19b443c56600b5f4e3a (patch)
tree0b88a20506a787705d6689dd8c8f47e6b4620d48 /meta-oe/recipes-extended
parentf411152b72f6e4129e8ce8c58caef16c01198556 (diff)
downloadmeta-openembedded-1f381f4444609814d2d5c19b443c56600b5f4e3a.tar.gz
pegtl: Upgrade 2.1.4 -> 2.8.1
Removed patch for issue fixed upstream. Year updated in LICENSE. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/pegtl/pegtl/0001-Fix-clang-warning-about-non-virtual-dtor.patch25
-rw-r--r--meta-oe/recipes-extended/pegtl/pegtl_2.1.4.bb13
-rw-r--r--meta-oe/recipes-extended/pegtl/pegtl_2.8.1.bb12
3 files changed, 12 insertions, 38 deletions
diff --git a/meta-oe/recipes-extended/pegtl/pegtl/0001-Fix-clang-warning-about-non-virtual-dtor.patch b/meta-oe/recipes-extended/pegtl/pegtl/0001-Fix-clang-warning-about-non-virtual-dtor.patch
deleted file mode 100644
index 0c79c4c09..000000000
--- a/meta-oe/recipes-extended/pegtl/pegtl/0001-Fix-clang-warning-about-non-virtual-dtor.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From 340110292b35d367205953a59e7eab28e1f4a0bb Mon Sep 17 00:00:00 2001
2From: Daniel Frey <d.frey@gmx.de>
3Date: Sat, 7 Apr 2018 09:13:51 +0200
4Subject: [PATCH] Fix clang-warning about non-virtual dtor
5
6Upstream-Status: Backport [https://github.com/taocpp/PEGTL/commit/340110292b35d367205953a59e7eab28e1f4a0bb]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 src/example/pegtl/json_classes.hpp | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12--- a/src/example/pegtl/json_classes.hpp
13+++ b/src/example/pegtl/json_classes.hpp
14@@ -34,10 +34,7 @@ namespace examples
15 : type( in_type )
16 {
17 }
18-
19- ~json_base()
20- {
21- }
22+ virtual ~json_base() = default;
23 };
24
25 inline std::ostream& operator<<( std::ostream& o, const json_base& j )
diff --git a/meta-oe/recipes-extended/pegtl/pegtl_2.1.4.bb b/meta-oe/recipes-extended/pegtl/pegtl_2.1.4.bb
deleted file mode 100644
index 344a80524..000000000
--- a/meta-oe/recipes-extended/pegtl/pegtl_2.1.4.bb
+++ /dev/null
@@ -1,13 +0,0 @@
1DESCRIPTION="header-only library for creating parsers according to Parsing Expression Grammar"
2HOMEPAGE="https://github.com/taocpp/PEGTL"
3LICENSE="MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=80cb066ab204c7fe022f1cfe0c2c6818"
5
6SRCREV = "776fa4a1e8bda860008524f6dd9473967c8375b1"
7SRC_URI = "git://git@github.com/taocpp/PEGTL.git;protocol=https;branch=master \
8 file://0001-Fix-clang-warning-about-non-virtual-dtor.patch \
9 "
10
11inherit cmake
12
13S = "${WORKDIR}/git"
diff --git a/meta-oe/recipes-extended/pegtl/pegtl_2.8.1.bb b/meta-oe/recipes-extended/pegtl/pegtl_2.8.1.bb
new file mode 100644
index 000000000..7333363ec
--- /dev/null
+++ b/meta-oe/recipes-extended/pegtl/pegtl_2.8.1.bb
@@ -0,0 +1,12 @@
1DESCRIPTION="header-only library for creating parsers according to Parsing Expression Grammar"
2HOMEPAGE="https://github.com/taocpp/PEGTL"
3LICENSE="MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ae77b0d903a788cb48f4f0926ffc468b"
5
6SRCREV = "7aff80da2ca4fcb0b47f32ba684ff2e1cd48c579"
7SRC_URI = "git://github.com/taocpp/PEGTL.git;protocol=https;branch=2.x \
8 "
9
10inherit cmake
11
12S = "${WORKDIR}/git"