summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2015-09-11 15:41:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-23 15:37:18 +0200
commit15b4eabbfb172891b27b7e0974e0a3159e516870 (patch)
treea8db4a60ecc71c771ac05d8ade2fea3b8b971248 /meta-oe/recipes-extended
parenta74a34bd65f27b501a382895155504730d6890ad (diff)
downloadmeta-openembedded-15b4eabbfb172891b27b7e0974e0a3159e516870.tar.gz
redis: stylize
* remove trailing whitespaces * run through oe-stylize Signed-off-by: Andrea Galbusera <gizero@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/redis/redis_3.0.2.bb20
1 files changed, 8 insertions, 12 deletions
diff --git a/meta-oe/recipes-extended/redis/redis_3.0.2.bb b/meta-oe/recipes-extended/redis/redis_3.0.2.bb
index 4ed6879ff..55f2c9669 100644
--- a/meta-oe/recipes-extended/redis/redis_3.0.2.bb
+++ b/meta-oe/recipes-extended/redis/redis_3.0.2.bb
@@ -3,9 +3,9 @@ DESCRIPTION = "Redis is an open source, advanced key-value store."
3HOMEPAGE = "http://redis.io" 3HOMEPAGE = "http://redis.io"
4SECTION = "libs" 4SECTION = "libs"
5LICENSE = "BSD" 5LICENSE = "BSD"
6LIC_FILES_CHKSUM="file://COPYING;md5=3c01b49fed4df1a79843688fa3f7b9d6" 6LIC_FILES_CHKSUM = "file://COPYING;md5=3c01b49fed4df1a79843688fa3f7b9d6"
7
8DEPENDS = "" 7DEPENDS = ""
8
9SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \ 9SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \
10 file://hiredis-use-default-CC-if-it-is-set.patch \ 10 file://hiredis-use-default-CC-if-it-is-set.patch \
11 file://lua-update-Makefile-to-use-environment-build-setting.patch \ 11 file://lua-update-Makefile-to-use-environment-build-setting.patch \
@@ -13,26 +13,22 @@ SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \
13 file://redis.conf \ 13 file://redis.conf \
14 file://init-redis-server \ 14 file://init-redis-server \
15" 15"
16
17inherit autotools-brokensep update-rc.d
18
19INITSCRIPT_NAME = "redis-server"
20INITSCRIPT_PARAMS = "defaults 87"
21
22SRC_URI[md5sum] = "87be8867447f62524b584813e5a7bd14" 16SRC_URI[md5sum] = "87be8867447f62524b584813e5a7bd14"
23SRC_URI[sha256sum] = "93e422c0d584623601f89b956045be158889ebe594478a2c24e1bf218495633f" 17SRC_URI[sha256sum] = "93e422c0d584623601f89b956045be158889ebe594478a2c24e1bf218495633f"
24 18
19inherit autotools-brokensep update-rc.d
20
25do_install() { 21do_install() {
26 export PREFIX=${D}/${prefix} 22 export PREFIX=${D}/${prefix}
27 oe_runmake install 23 oe_runmake install
28
29 install -d ${D}/${sysconfdir}/redis 24 install -d ${D}/${sysconfdir}/redis
30 install -m 0644 ${WORKDIR}/redis.conf ${D}/${sysconfdir}/redis/redis.conf 25 install -m 0644 ${WORKDIR}/redis.conf ${D}/${sysconfdir}/redis/redis.conf
31 26 install -d ${D}/${sysconfdir}/init.d
32 install -d ${D}/${sysconfdir}/init.d
33 install -m 0755 ${WORKDIR}/init-redis-server ${D}/${sysconfdir}/init.d/redis-server 27 install -m 0755 ${WORKDIR}/init-redis-server ${D}/${sysconfdir}/init.d/redis-server
34
35 install -d ${D}/var/lib/redis/ 28 install -d ${D}/var/lib/redis/
36} 29}
37 30
38CONFFILES_${PN} = "${sysconfdir}/redis/redis.conf" 31CONFFILES_${PN} = "${sysconfdir}/redis/redis.conf"
32
33INITSCRIPT_NAME = "redis-server"
34INITSCRIPT_PARAMS = "defaults 87"