summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/zsync/zsync-curl_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-06-10 13:35:58 +0100
committerKhem Raj <raj.khem@gmail.com>2021-06-10 07:06:34 -0700
commit4c7254df86b32fd41f57d518f82a248241d45eec (patch)
tree4f51dc65e3d2378656268c4cca9065d6c58501e8 /meta-oe/recipes-extended/zsync/zsync-curl_git.bb
parente343088c7e7a28713b51135db91022e9784d555a (diff)
downloadmeta-openembedded-4c7254df86b32fd41f57d518f82a248241d45eec.tar.gz
zsync-curl: add recipe
zsync is a tool that is similar to rsync but optimised for transfering single large files where you have a previous version of the file locally. These qualities make it an excellent choice for transfering built images between hosts. zsync-curl is a maintained fork of the original zsync, that uses curl for HTTP requests allowing it to connect to HTTPS servers. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/zsync/zsync-curl_git.bb')
-rw-r--r--meta-oe/recipes-extended/zsync/zsync-curl_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/zsync/zsync-curl_git.bb b/meta-oe/recipes-extended/zsync/zsync-curl_git.bb
new file mode 100644
index 000000000..adb72d5de
--- /dev/null
+++ b/meta-oe/recipes-extended/zsync/zsync-curl_git.bb
@@ -0,0 +1,20 @@
1SUMMARY = "File transfer tool optimised for large files (curl port)"
2HOMEPAGE = "http://zsync.moria.org.uk/"
3DEPENDS = "curl"
4
5LICENSE = "Artistic-2.0"
6LIC_FILES_CHKSUM = "file://src/COPYING;md5=71c0ac4d86266533509aa0825b8d323c"
7
8SRC_URI = "git://github.com/probonopd/zsync-curl;protocol=https \
9 file://fixes.patch \
10 file://make.patch"
11SRCREV = "00141c2806ccc4ddf2ff6263ee1612d19c0b713f"
12
13PV = "0.6.2+git${SRCPV}"
14
15inherit autotools
16
17S = "${WORKDIR}/git"
18AUTOTOOLS_SCRIPT_PATH = "${S}/src"
19
20BBCLASSEXTEND = "native nativesdk"