summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/upm/upm_git.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-10-03 08:40:10 +1300
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-04 14:53:31 +0000
commita43751b149e1517ee59b0d7ea7484510f6ab420e (patch)
treef2b05577a3b7e88c22f624025da5030efb144e19 /meta-oe/recipes-extended/upm/upm_git.bb
parentc2a7348684763fffa7558b67cbc4fc8c88d0b137 (diff)
downloadmeta-openembedded-a43751b149e1517ee59b0d7ea7484510f6ab420e.tar.gz
upm: add recipe from meta-refkit-core
Make this recipe a little more widely visible (has previously appeared in meta-refkit-core and meta-intel-iot-middleware). Also make couple of minor tweaks: * Fix BINDINGS example to use the correct recipe name (copy-paste error) * Set HOMEPAGE * Drop AUTHOR as this is field is only really intended for older software where there is no real point of contact for upstream other than an author's email address. * Set same COMPATIBLE_HOST as mraa since upm depends upon it Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/upm/upm_git.bb')
-rw-r--r--meta-oe/recipes-extended/upm/upm_git.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb
new file mode 100644
index 000000000..38065ce53
--- /dev/null
+++ b/meta-oe/recipes-extended/upm/upm_git.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Sensor/Actuator repository for Mraa"
2HOMEPAGE = "https://github.com/intel-iot-devkit/upm"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=66493d54e65bfc12c7983ff2e884f37f"
7
8DEPENDS = "libjpeg-turbo mraa"
9
10SRCREV = "106b6c706268522ab0168a4ddb19e89ce832e084"
11PV = "1.3.0-git${SRCPV}"
12
13SRC_URI = " \
14 git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \
15 file://ads1x15-fixed-case-logic-in-getThresh-function.patch \
16"
17
18S = "${WORKDIR}/git"
19
20# Depends on mraa which only supports x86 and ARM for now
21COMPATIBLE_HOST = "(x86_64.*|i.86.*|aarch64.*|arm.*)-linux"
22
23inherit distutils3-base cmake
24
25
26# override this in local.conf to get needed bindings.
27# BINDINGS_pn-upm="python"
28# will result in only the python bindings being built/packaged.
29BINDINGS ??= "python ${@ 'nodejs' if oe.types.boolean(d.getVar('HAVE_NODEJS') or '0') else '' }"
30
31PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \
32 ${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}"
33
34PACKAGECONFIG[python] = "-DBUILDSWIGPYTHON=ON, -DBUILDSWIGPYTHON=OFF, swig-native ${PYTHON_PN},"
35PACKAGECONFIG[nodejs] = "-DBUILDSWIGNODE=ON, -DBUILDSWIGNODE=OFF, swig-native nodejs-native,"
36
37FILES_${PYTHON_PN}-${PN} = "${PYTHON_SITEPACKAGES_DIR}"
38RDEPENDS_${PYTHON_PN}-${PN} += "${PYTHON_PN}"
39
40FILES_node-${PN} = "${prefix}/lib/node_modules/"
41RDEPENDS_node-${PN} += "nodejs"
42
43### Include desired language bindings ###
44PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'nodejs', 'node-${PN}', '', d)}"
45PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'python', '${PYTHON_PN}-${PN}', '', d)}"