summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/uml-utilities
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-extended/uml-utilities
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-extended/uml-utilities')
-rw-r--r--meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch16
-rw-r--r--meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/unstrip.patch84
-rw-r--r--meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb26
3 files changed, 126 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
new file mode 100644
index 000000000..05cc5371f
--- /dev/null
+++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
@@ -0,0 +1,16 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- tools/mconsole/Makefile~fix-ldflags 2003-02-08 05:10:08.000000000 +0100
7+++ tools/mconsole/Makefile 2004-04-01 15:37:37.000000000 +0200
8@@ -7,7 +7,7 @@
9 all : $(BIN)
10
11 $(BIN) : $(OBJS)
12- $(CC) $(CFLAGS) -o $(BIN) $(OBJS) -lreadline -lncurses
13+ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS) -lreadline -lncurses
14
15 clean :
16 rm -f $(BIN) $(OBJS) *~
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/unstrip.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/unstrip.patch
new file mode 100644
index 000000000..868001dbd
--- /dev/null
+++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/unstrip.patch
@@ -0,0 +1,84 @@
1Dont strip during install let the packaging handle it
2
3Signed-off-by: Khem Raj <raj.khem@gmail.com>
4
5Index: tools/jailtest/Makefile
6===================================================================
7--- tools.orig/jailtest/Makefile 2003-02-07 20:10:27.000000000 -0800
8+++ tools/jailtest/Makefile 2012-09-05 12:13:56.061615854 -0700
9@@ -14,4 +14,4 @@
10
11 install : $(BIN)
12 install -d $(DESTDIR)$(BIN_DIR)
13- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
14+ install $(BIN) $(DESTDIR)$(BIN_DIR)
15Index: tools/mconsole/Makefile
16===================================================================
17--- tools.orig/mconsole/Makefile 2012-09-05 12:05:09.869607043 -0700
18+++ tools/mconsole/Makefile 2012-09-05 12:14:07.725607469 -0700
19@@ -14,4 +14,4 @@
20
21 install : $(BIN)
22 install -d $(DESTDIR)$(BIN_DIR)
23- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
24+ install $(BIN) $(DESTDIR)$(BIN_DIR)
25Index: tools/moo/Makefile
26===================================================================
27--- tools.orig/moo/Makefile 2003-06-26 09:27:00.000000000 -0700
28+++ tools/moo/Makefile 2012-09-05 12:14:20.981604580 -0700
29@@ -22,4 +22,4 @@
30
31 install : $(BIN)
32 install -d $(DESTDIR)$(BIN_DIR)
33- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
34+ install $(BIN) $(DESTDIR)$(BIN_DIR)
35Index: tools/port-helper/Makefile
36===================================================================
37--- tools.orig/port-helper/Makefile 2003-02-07 20:05:31.000000000 -0800
38+++ tools/port-helper/Makefile 2012-09-05 12:14:39.429609678 -0700
39@@ -14,4 +14,4 @@
40
41 install : $(BIN)
42 install -d $(DESTDIR)$(LIB_DIR)
43- install -s $(BIN) $(DESTDIR)$(LIB_DIR)
44+ install $(BIN) $(DESTDIR)$(LIB_DIR)
45Index: tools/tunctl/Makefile
46===================================================================
47--- tools.orig/tunctl/Makefile 2003-02-07 20:05:04.000000000 -0800
48+++ tools/tunctl/Makefile 2012-09-05 12:14:49.985606470 -0700
49@@ -14,4 +14,4 @@
50
51 install : $(BIN)
52 install -d $(DESTDIR)$(BIN_DIR)
53- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
54+ install $(BIN) $(DESTDIR)$(BIN_DIR)
55Index: tools/uml_net/Makefile
56===================================================================
57--- tools.orig/uml_net/Makefile 2003-02-07 20:04:55.000000000 -0800
58+++ tools/uml_net/Makefile 2012-09-05 12:15:00.961607290 -0700
59@@ -21,4 +21,4 @@
60
61 install : $(BIN)
62 install -d $(DESTDIR)$(BIN_DIR)
63- install -s -m 04755 $(BIN) $(DESTDIR)$(BIN_DIR)
64+ install -m 04755 $(BIN) $(DESTDIR)$(BIN_DIR)
65Index: tools/uml_router/Makefile
66===================================================================
67--- tools.orig/uml_router/Makefile 2003-02-07 20:04:39.000000000 -0800
68+++ tools/uml_router/Makefile 2012-09-05 12:15:10.649607571 -0700
69@@ -20,4 +20,4 @@
70
71 install : $(BIN)
72 install -d $(DESTDIR)$(BIN_DIR)
73- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
74+ install $(BIN) $(DESTDIR)$(BIN_DIR)
75Index: tools/watchdog/Makefile
76===================================================================
77--- tools.orig/watchdog/Makefile 2003-02-07 20:04:25.000000000 -0800
78+++ tools/watchdog/Makefile 2012-09-05 12:15:35.561612203 -0700
79@@ -14,4 +14,4 @@
80
81 install : $(BIN)
82 install -d $(DESTDIR)$(BIN_DIR)
83- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
84+ install $(BIN) $(DESTDIR)$(BIN_DIR)
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb
new file mode 100644
index 000000000..45cc2e751
--- /dev/null
+++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb
@@ -0,0 +1,26 @@
1SECTION = "console/utils"
2SUMMARY = "Utilities for User-Mode-Linux"
3LICENSE = "GPL-2.0"
4DEPENDS = "zlib ncurses readline"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
6SRC_URI = "http://downloads.sourceforge.net/project/user-mode-linux/tools/1/uml_utilities_${PV}.tar.bz2 \
7 file://fix-ldflags.patch \
8 file://unstrip.patch \
9"
10SRC_URI[md5sum] = "2c1ccd9efacbfb39e42d482b89b2550a"
11SRC_URI[sha256sum] = "4f179b1db021ef15ac7e9b2eed57c525db127a754c574f591c367460cded9f41"
12
13PR = "r1"
14
15S = "${WORKDIR}/tools"
16
17do_compile() {
18 oe_runmake
19}
20
21do_install() {
22 oe_runmake install DESTDIR=${D}
23}
24
25FILES_${PN} += "${exec_prefix}${nonarch_base_libdir}"
26FILES_${PN}-dbg += "${exec_prefix}${nonarch_base_libdir}/uml/.debug"