diff options
author | Armin Kuster <akuster808@gmail.com> | 2017-10-26 13:20:47 -0700 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-01 16:10:35 -0800 |
commit | b836c5b810898cf51baa012c8debe816a715717a (patch) | |
tree | e63c90a263e9d848ada145826fbcc204a49625f1 /meta-oe/recipes-extended/tcsh | |
parent | 7da35538ab4901671dbe441382ac118965513149 (diff) | |
download | meta-openembedded-b836c5b810898cf51baa012c8debe816a715717a.tar.gz |
tcsh: move to recipes-shells
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/tcsh')
3 files changed, 0 insertions, 134 deletions
diff --git a/meta-oe/recipes-extended/tcsh/tcsh/0001-Enable-system-malloc-on-all-linux.patch b/meta-oe/recipes-extended/tcsh/tcsh/0001-Enable-system-malloc-on-all-linux.patch deleted file mode 100644 index ff2f6a3b6..000000000 --- a/meta-oe/recipes-extended/tcsh/tcsh/0001-Enable-system-malloc-on-all-linux.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From 0553455813a1f717ef50cc911e4db73da3d23c32 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 22 Mar 2017 18:47:40 -0700 | ||
4 | Subject: [PATCH 1/2] Enable system malloc on all linux | ||
5 | |||
6 | Dont trigger on being just android or glibc | ||
7 | internal malloc falls flat on musl based systems | ||
8 | as well. So switch to using system malloc | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | config_f.h | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/config_f.h b/config_f.h | ||
16 | index 6a632a5..0a66960 100644 | ||
17 | --- a/config_f.h | ||
18 | +++ b/config_f.h | ||
19 | @@ -139,7 +139,7 @@ | ||
20 | * This can be much slower and no memory statistics will be | ||
21 | * provided. | ||
22 | */ | ||
23 | -#if defined(__MACHTEN__) || defined(PURIFY) || defined(MALLOC_TRACE) || defined(_OSD_POSIX) || defined(__MVS__) || defined (__CYGWIN__) || defined(__GLIBC__) || defined(__OpenBSD__) || defined(__APPLE__) || defined (__ANDROID__) | ||
24 | +#if defined(__MACHTEN__) || defined(PURIFY) || defined(MALLOC_TRACE) || defined(_OSD_POSIX) || defined(__MVS__) || defined (__CYGWIN__) || defined(__linux__) || defined(__OpenBSD__) || defined(__APPLE__) | ||
25 | # define SYSMALLOC | ||
26 | #else | ||
27 | # undef SYSMALLOC | ||
28 | -- | ||
29 | 2.12.1 | ||
30 | |||
diff --git a/meta-oe/recipes-extended/tcsh/tcsh/0002-Add-debian-csh-scripts.patch b/meta-oe/recipes-extended/tcsh/tcsh/0002-Add-debian-csh-scripts.patch deleted file mode 100644 index e4de6f7fe..000000000 --- a/meta-oe/recipes-extended/tcsh/tcsh/0002-Add-debian-csh-scripts.patch +++ /dev/null | |||
@@ -1,60 +0,0 @@ | |||
1 | From 60271713025f6b17dda29721be012a8428e77185 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 22 Mar 2017 18:56:49 -0700 | ||
4 | Subject: [PATCH 2/2] Add debian csh scripts | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | csh.cshrc | 15 +++++++++++++++ | ||
9 | csh.login | 8 ++++++++ | ||
10 | csh.logout | 1 + | ||
11 | 3 files changed, 24 insertions(+) | ||
12 | create mode 100644 csh.cshrc | ||
13 | create mode 100644 csh.login | ||
14 | create mode 100644 csh.logout | ||
15 | |||
16 | diff --git a/csh.cshrc b/csh.cshrc | ||
17 | new file mode 100644 | ||
18 | index 0000000..29c934a | ||
19 | --- /dev/null | ||
20 | +++ b/csh.cshrc | ||
21 | @@ -0,0 +1,15 @@ | ||
22 | +# /etc/csh.cshrc: system-wide .cshrc file for csh(1) and tcsh(1) | ||
23 | + | ||
24 | +if ($?tcsh && $?prompt) then | ||
25 | + | ||
26 | + bindkey "\e[1~" beginning-of-line # Home | ||
27 | + bindkey "\e[7~" beginning-of-line # Home rxvt | ||
28 | + bindkey "\e[2~" overwrite-mode # Ins | ||
29 | + bindkey "\e[3~" delete-char # Delete | ||
30 | + bindkey "\e[4~" end-of-line # End | ||
31 | + bindkey "\e[8~" end-of-line # End rxvt | ||
32 | + | ||
33 | + set autoexpand | ||
34 | + set autolist | ||
35 | + set prompt = "%U%m%u:%B%~%b%# " | ||
36 | +endif | ||
37 | diff --git a/csh.login b/csh.login | ||
38 | new file mode 100644 | ||
39 | index 0000000..2455c3c | ||
40 | --- /dev/null | ||
41 | +++ b/csh.login | ||
42 | @@ -0,0 +1,8 @@ | ||
43 | +# /etc/csh.login: system-wide .login file for csh(1) and tcsh(1) | ||
44 | + | ||
45 | +# allow for other packages/system admins to customize the shell environment | ||
46 | +if (-e /etc/csh/login.d && `/bin/ls /etc/csh/login.d` != "") then | ||
47 | + foreach FILE (`/bin/ls /etc/csh/login.d/*`) | ||
48 | + source $FILE; | ||
49 | + end; | ||
50 | +endif | ||
51 | diff --git a/csh.logout b/csh.logout | ||
52 | new file mode 100644 | ||
53 | index 0000000..a207eba | ||
54 | --- /dev/null | ||
55 | +++ b/csh.logout | ||
56 | @@ -0,0 +1 @@ | ||
57 | +# /etc/csh.logout: system-wide .logout file for csh(1) and tcsh(1) | ||
58 | -- | ||
59 | 2.12.1 | ||
60 | |||
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.20.00.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.20.00.bb deleted file mode 100644 index b59d88f5d..000000000 --- a/meta-oe/recipes-extended/tcsh/tcsh_6.20.00.bb +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \ | ||
2 | The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \ | ||
3 | It includes all features of 4.4BSD C shell, plus a command-line editor, \ | ||
4 | programmable word completion, spelling correction and more." | ||
5 | |||
6 | HOMEPAGE = "http://www.tcsh.org/" | ||
7 | LICENSE = "BSD-3-Clause" | ||
8 | LIC_FILES_CHKSUM = "file://Copyright;md5=575cf2715c3bf894e1f79aec1d4eaaf5" | ||
9 | SECTION = "base" | ||
10 | DEPENDS = "ncurses gettext-native" | ||
11 | SRC_URI = " \ | ||
12 | http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/${BP}.tar.gz \ | ||
13 | file://0001-Enable-system-malloc-on-all-linux.patch \ | ||
14 | file://0002-Add-debian-csh-scripts.patch \ | ||
15 | " | ||
16 | SRC_URI[md5sum] = "59d40ef40a68e790d95e182069431834" | ||
17 | SRC_URI[sha256sum] = "b89de7064ab54dac454a266cfe5d8bf66940cb5ed048d0c30674ea62e7ecef9d" | ||
18 | |||
19 | EXTRA_OEMAKE += "CC_FOR_GETHOST='${BUILD_CC}'" | ||
20 | inherit autotools | ||
21 | |||
22 | do_compile_prepend() { | ||
23 | oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' gethost | ||
24 | } | ||
25 | |||
26 | do_install_append () { | ||
27 | oe_runmake install.man DESTDIR=${D} | ||
28 | |||
29 | install -d ${D}${base_bindir} | ||
30 | ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh | ||
31 | ln -s /usr/bin/tcsh ${D}${base_bindir}/csh | ||
32 | install -d ${D}${sysconfdir}/csh/login.d | ||
33 | install -m 0644 ${S}/csh.cshrc ${S}/csh.login ${S}/csh.logout ${S}/complete.tcsh ${D}${sysconfdir} | ||
34 | install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el | ||
35 | } | ||
36 | |||
37 | FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el" | ||
38 | |||
39 | |||
40 | pkg_postinst_${PN} () { | ||
41 | #!/bin/sh -e | ||
42 | echo /usr/bin/tcsh >> $D/etc/shells | ||
43 | echo /usr/bin/csh >> $D/etc/shells | ||
44 | } | ||