summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/tcsh
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-extended/tcsh
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-extended/tcsh')
-rw-r--r--meta-oe/recipes-extended/tcsh/files/01_build.1.patch16
-rw-r--r--meta-oe/recipes-extended/tcsh/files/01_build.2.patch13
-rw-r--r--meta-oe/recipes-extended/tcsh/files/01_build.3.patch13
-rw-r--r--meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch24
-rw-r--r--meta-oe/recipes-extended/tcsh/files/15_no-strip.patch14
-rw-r--r--meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch14
-rw-r--r--meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch30
-rw-r--r--meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch23
-rw-r--r--meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch30
-rw-r--r--meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch18
-rw-r--r--meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb49
11 files changed, 244 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/tcsh/files/01_build.1.patch b/meta-oe/recipes-extended/tcsh/files/01_build.1.patch
new file mode 100644
index 000000000..b9f41ade9
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/01_build.1.patch
@@ -0,0 +1,16 @@
1Author: Franz Pletz <fpletz@franz-pletz.org>
2Description: Original comment: Fix build
3Not sure why we have this patch. Let's keep it for compatibility.
4--- a/pathnames.h
5+++ b/pathnames.h
6@@ -92,6 +92,10 @@
7 # define _PATH_TCSHELL "/local/bin/tcsh" /* use ram disk */
8 #endif /* _MINIX && !_PATH_TCSHELL */
9
10+#ifndef _PATH_TCSHELL
11+# define _PATH_TCSHELL "/bin/tcsh" /* Debian */
12+#endif /* !_PATH_TCSHELL */
13+
14 #if defined(__EMX__) && !defined(_PATH_DEVNULL)
15 # define _PATH_DEVNULL "nul"
16 #endif /* __EMX__ && !_PATH_DEVNULL */
diff --git a/meta-oe/recipes-extended/tcsh/files/01_build.2.patch b/meta-oe/recipes-extended/tcsh/files/01_build.2.patch
new file mode 100644
index 000000000..ff2753154
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/01_build.2.patch
@@ -0,0 +1,13 @@
1Author: Franz Pletz <fpletz@franz-pletz.org>
2Description: Update manpage.
3--- a/tcsh.man
4+++ b/tcsh.man
5@@ -578,7 +578,7 @@ Repeating \fIdabbrev-expand\fR without a
6 changes to the next previous word etc., skipping identical matches
7 much like \fIhistory-search-backward\fR does.
8 .TP 8
9-.B delete-char \fR(not bound)
10+.B delete-char \fR(bound to `Del' if using the standard \fI/etc/csh.cshrc\fR)
11 Deletes the character under the cursor.
12 See also \fIdelete-char-or-list-or-eof\fR.
13 .TP 8
diff --git a/meta-oe/recipes-extended/tcsh/files/01_build.3.patch b/meta-oe/recipes-extended/tcsh/files/01_build.3.patch
new file mode 100644
index 000000000..d36c177af
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/01_build.3.patch
@@ -0,0 +1,13 @@
1Author: Franz Pletz <fpletz@franz-pletz.org>
2Description: Enable NODOT
3--- a/config_f.h
4+++ b/config_f.h
5@@ -98,7 +98,7 @@
6 /*
7 * NODOT Don't put "." in the default path, for security reasons
8 */
9-#undef NODOT
10+#define NODOT
11
12 /*
13 * AUTOLOGOUT tries to determine if it should set autologout depending
diff --git a/meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch b/meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch
new file mode 100644
index 000000000..faa59cc80
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch
@@ -0,0 +1,24 @@
1Author: Franz Pletz <fpletz@franz-pletz.org>
2Description: Don't die on unknown LS_COLORS values
3Removing the patch causes a segfault when dircolors is set by coreutils' dircolors.
4Debian-Bug: #592089
5
6--- a/tw.color.c
7+++ b/tw.color.c
8@@ -239,13 +239,10 @@ parseLS_COLORS(const Char *value)
9 if ((Char)variables[i].variable[0] == (v[0] & CHAR) &&
10 (Char)variables[i].variable[1] == (v[1] & CHAR))
11 break;
12- if (i < nvariables) {
13- v += 3;
14+ v += 3;
15+ if (i < nvariables)
16 getstring(&c, &v, &variables[i].color, ':');
17- continue;
18- }
19- else
20- stderror(ERR_BADCOLORVAR, v[0], v[1]);
21+ continue;
22 }
23 break;
24 }
diff --git a/meta-oe/recipes-extended/tcsh/files/15_no-strip.patch b/meta-oe/recipes-extended/tcsh/files/15_no-strip.patch
new file mode 100644
index 000000000..cbc9f65d0
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/15_no-strip.patch
@@ -0,0 +1,14 @@
1Author: Lucas Nussbaum <lucas@debian.org>
2Description: do not strip binary
3 Stripping should be handled by dh_strip instead, so DEB_BUILD_OPTIONS=nostrip works.
4 Closes: #438109, #411607
5--- a/Makefile.in
6+++ b/Makefile.in
7@@ -596,7 +596,6 @@ install: tcsh$(EXEEXT)
8 -mkdir -p ${DESTBIN}
9 -mv -f ${DESTBIN}/tcsh$(EXEEXT) ${DESTBIN}/tcsh.old
10 cp tcsh$(EXEEXT) ${DESTBIN}/tcsh$(EXEEXT)
11- -strip ${DESTBIN}/tcsh$(EXEEXT)
12 chmod 755 ${DESTBIN}/tcsh$(EXEEXT)
13
14 install.man: tcsh.man
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch b/meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch
new file mode 100644
index 000000000..0bda0ba10
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch
@@ -0,0 +1,14 @@
1Author: Lucas Nussbaum <lucas@debian.org>
2Description: disable syntactically incorrect test
3--- a/tests/lexical.at
4+++ b/tests/lexical.at
5@@ -172,9 +172,6 @@
6 AT_DATA([nohist.csh],
7 [echo ! space ! tab != "!(" newline !
8 ])
9-AT_CHECK([tcsh -f nohist.csh], ,
10-[[! space ! tab != !( newline !
11-]])
12
13 AT_CLEANUP
14
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch b/meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch
new file mode 100644
index 000000000..98a9b2e1d
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch
@@ -0,0 +1,30 @@
1--- a/tests/lexical.at
2+++ b/tests/lexical.at
3@@ -27,27 +27,6 @@ AT_CHECK([tcsh -f oneword.csh], ,
4
5 AT_CLEANUP
6
7-
8-AT_SETUP([Comments])
9-
10-AT_CHECK([echo 'echo OK@%:@comment' | tcsh -f], , [OK
11-])
12-
13-AT_CHECK([tcsh -f -c 'echo @%:@no comment'], ,
14-[@%:@no comment
15-])
16-
17-AT_DATA([comment2.csh],
18-[[echo testing...@%:@\
19-OK
20-]])
21-AT_CHECK([tcsh -f comment2.csh], ,
22-[testing... OK
23-])
24-
25-AT_CLEANUP
26-
27-
28 AT_SETUP([Escaping special characters])
29
30 AT_DATA([nosplit.csh],
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch b/meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch
new file mode 100644
index 000000000..79f918c08
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch
@@ -0,0 +1,23 @@
1Author: Lucas Nussbaum <lucas@debian.org>
2Description: disable test that fails on the buildd with
3 "setpriority: Permission denied".
4--- a/tests/commands.at
5+++ b/tests/commands.at
6@@ -888,17 +888,6 @@ TCSH_UNTESTED([migrate])
7 TCSH_UNTESTED([newgrp])
8
9
10-AT_SETUP([nice])
11-
12-# Nothing really tested
13-AT_CHECK([tcsh -f -c 'nice set var=1; echo $?var'], ,
14-[0
15-])
16-
17-
18-AT_CLEANUP
19-
20-
21 AT_SETUP([nohup])
22
23 AT_DATA([nohup.csh],
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch b/meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch
new file mode 100644
index 000000000..69f0564e8
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch
@@ -0,0 +1,30 @@
1From: Lucas Nussbaum <lucas@debian.org>
2Description: Those tests fail when running the testsuite without a tty. Disabling them.
3
4--- a/tests/commands.at
5+++ b/tests/commands.at
6@@ -1203,11 +1203,6 @@ AT_SETUP([source])
7 AT_DATA([script.csh],
8 [[set var=$1
9 ]])
10-AT_CHECK([[tcsh -f -c 'source -h script.csh foo; history' \
11- | sed 's/ [^ ]* / TIME /']], ,
12-[ 1 TIME source -h script.csh foo ; history
13- 2 TIME set var=$1
14-])
15
16 AT_CHECK([tcsh -f -c 'source -h script.csh foo; echo $var'], 1, [],
17 [var: Undefined variable.
18--- a/tests/variables.at
19+++ b/tests/variables.at
20@@ -319,10 +319,6 @@ AT_CLEANUP
21
22 AT_SETUP([$ edit])
23
24-AT_CHECK([TERM=something tcsh -f -c 'echo $?edit'], ,
25-[1
26-])
27-
28 AT_CHECK([TERM=dumb tcsh -f -c 'echo $?edit'], ,
29 [0
30 ])
diff --git a/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch b/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch
new file mode 100644
index 000000000..3dd420a0e
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch
@@ -0,0 +1,18 @@
1Author: Jean-Luc Leger <reiga@dspnet.fr.eu.org>
2Description: fix broken globbing expansion
3Debian-Bug: #603545
4Index: tcsh-6.18.01/tc.str.c
5===================================================================
6--- tcsh-6.18.01.orig/tc.str.c 2012-01-10 13:34:31.000000000 -0800
7+++ tcsh-6.18.01/tc.str.c 2013-02-26 13:12:13.429153489 -0800
8@@ -122,8 +122,9 @@
9 #else
10 ret = mbtowc(&tmp, s, n);
11 #endif
12- if (ret > 0) {
13+ if (ret >= 0)
14 *pwc = tmp;
15+ if (ret >= 0) {
16 #if defined(UTF16_STRINGS) && defined(HAVE_MBRTOWC)
17 if (tmp >= 0xd800 && tmp <= 0xdbff) {
18 /* UTF-16 surrogate pair. Fetch second half and compute
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
new file mode 100644
index 000000000..1dd4cb580
--- /dev/null
+++ b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \
2 The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \
3 It includes all features of 4.4BSD C shell, plus a command-line editor, \
4 programmable word completion, spelling correction and more."
5
6HOMEPAGE = "http://www.tcsh.org/"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://Copyright;md5=1cf29be62df2be1a3763118b25b4c780"
9SECTION = "base"
10DEPENDS = "ncurses gettext-native"
11SRC_URI = " \
12 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}.orig.tar.gz;name=tarball \
13 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-2.diff.gz;name=diffs \
14 file://01_build.1.patch \
15 file://01_build.2.patch \
16 file://01_build.3.patch \
17 file://15_no-strip.patch \
18 file://disable-test-notty.patch \
19 file://disable-test-nice.patch \
20 file://disable-lexical.at-31.patch \
21 file://12_unknown_lscolors.patch \
22 file://tcsh-6.17.02-multibyte.patch \
23 file://disable-broken-test.patch \
24"
25SRC_URI[tarball.md5sum] = "6eed09dbd4223ab5b6955378450d228a"
26SRC_URI[tarball.sha256sum] = "d81ca27851f3e8545666399b4bcf25433e602a195113b3f7c73886fef84c9fa8"
27SRC_URI[diffs.md5sum] = "ea39b818b624aca49ebf2cd2708d6ff9"
28SRC_URI[diffs.sha256sum] = "95b0c1a339b745c47c5d2f9d02c22a71597462e2e882b51614a9d1f75bd3d16c"
29
30inherit autotools
31
32do_install_append () {
33 oe_runmake install.man DESTDIR=${D}
34
35 install -d ${D}${base_bindir}
36 ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh
37
38 install -d ${D}${sysconfdir}/csh/login.d
39 install -m 0644 ${S}/debian/csh.cshrc ${S}/debian/csh.login ${S}/debian/csh.logout ${S}/complete.tcsh ${D}${sysconfdir}
40 install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el
41}
42
43FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el"
44
45
46pkg_postinst_${PN} () {
47#!/bin/sh -e
48echo /usr/bin/tcsh >> $D/etc/shells
49}