summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-22 19:26:44 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-05 19:26:13 +0200
commit4ecaaf8c1d62d05a82a086c9ca5327ee9358502d (patch)
tree9996f8e3f8d76138c5b9b51951c1d66b8df4037a /meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
parentc142219d33d80fe9525dfda10650fb6f88270b29 (diff)
downloadmeta-openembedded-4ecaaf8c1d62d05a82a086c9ca5327ee9358502d.tar.gz
tcsh: Update to 6.20.00 release
Fix segfaults on musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb')
-rw-r--r--meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb55
1 files changed, 0 insertions, 55 deletions
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
deleted file mode 100644
index 1cfd96c54..000000000
--- a/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
+++ /dev/null
@@ -1,55 +0,0 @@
1DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \
2 The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \
3 It includes all features of 4.4BSD C shell, plus a command-line editor, \
4 programmable word completion, spelling correction and more."
5
6HOMEPAGE = "http://www.tcsh.org/"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://Copyright;md5=1cf29be62df2be1a3763118b25b4c780"
9SECTION = "base"
10DEPENDS = "ncurses gettext-native"
11SRC_URI = " \
12 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}.orig.tar.gz;name=tarball \
13 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-2.diff.gz;name=diffs2 \
14 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-5.diff.gz;name=diffs5 \
15 file://01_build.1.patch \
16 file://01_build.2.patch \
17 file://01_build.3.patch \
18 file://15_no-strip.patch \
19 file://disable-test-notty.patch \
20 file://disable-test-nice.patch \
21 file://disable-lexical.at-31.patch \
22 file://12_unknown_lscolors.patch \
23 file://tcsh-6.17.02-multibyte.patch \
24 file://disable-broken-test.patch \
25 file://fix-gcc6-wait-union.patch \
26"
27SRC_URI[tarball.md5sum] = "6eed09dbd4223ab5b6955378450d228a"
28SRC_URI[tarball.sha256sum] = "d81ca27851f3e8545666399b4bcf25433e602a195113b3f7c73886fef84c9fa8"
29SRC_URI[diffs2.md5sum] = "ea39b818b624aca49ebf2cd2708d6ff9"
30SRC_URI[diffs2.sha256sum] = "95b0c1a339b745c47c5d2f9d02c22a71597462e2e882b51614a9d1f75bd3d16c"
31SRC_URI[diffs5.md5sum] = "d536c12a02dc48c332cc472b86927319"
32SRC_URI[diffs5.sha256sum] = "7548d64bf996548bfbc13f3e0959fd2e8455f8375381a31da67d79554aabc7af"
33
34inherit autotools
35
36do_install_append () {
37 oe_runmake install.man DESTDIR=${D}
38
39 install -d ${D}${base_bindir}
40 ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh
41
42 install -d ${D}${sysconfdir}/csh/login.d
43 install -m 0644 ${S}/debian/csh.cshrc ${S}/debian/csh.login ${S}/debian/csh.logout ${S}/complete.tcsh ${D}${sysconfdir}
44 install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el
45}
46
47FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el"
48
49
50pkg_postinst_${PN} () {
51#!/bin/sh -e
52echo /usr/bin/tcsh >> $D/etc/shells
53}
54
55PNBLACKLIST[tcsh] ?= "Doesn't respect CC variable and fails with HOSTTOOLS http://errors.yoctoproject.org/Errors/Details/138244/"