summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/subsurface
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-15 18:40:36 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-15 18:40:36 +0200
commitde2f5c9c87cd413aa954fdeb459b502c27168bd9 (patch)
tree01111b52a04259da39d3b243a94362c59f3ea4e6 /meta-oe/recipes-extended/subsurface
parent3b592422e98a9eda79970807ace52aa372314200 (diff)
downloadmeta-openembedded-de2f5c9c87cd413aa954fdeb459b502c27168bd9.tar.gz
subsurface: inital add
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended/subsurface')
-rw-r--r--meta-oe/recipes-extended/subsurface/subsurface_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/subsurface/subsurface_git.bb b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
new file mode 100644
index 000000000..b1a7e3ee1
--- /dev/null
+++ b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Subsurface is an open source dive log program."
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS = "libdivecomputer gtk+ libxml2 glib-2.0"
6
7inherit gtk-icon-cache
8
9PV = "1.0"
10SRCREV = "f2c61aefa762ce2ef7dea61886afeb23b0fe5eff"
11SRC_URI = "git://subsurface.hohndel.org/subsurface.git"
12S = "${WORKDIR}/git"
13
14EXTRA_OEMAKE = "CC='${CC}' \
15 libdc-usr=${STAGING_INCDIR}/libdivecomputer/* \
16 LIBDIVECOMPUTERINCLUDES=${STAGING_INCDIR}/libdivecomputer \
17 LIBDIVECOMPUTERARCHIVE=${STAGING_LIBDIR}/libdivecomputer.a \
18 "
19
20do_install() {
21 install -d ${D}${datadir}/man/man1
22 oe_runmake install prefix=${D}${prefix}
23 rm ${D}${datadir}/icons/hicolor/icon-theme.cache
24}
25
26FILES_${PN} += "${datadir}/icons/hicolor/scalable/apps/subsurface.svg"
27RRECOMMENDS_${PN}_append_libc-glibc = " eglibc-gconv-iso8859-15"
28