diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-09-02 15:23:34 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-05 22:49:35 -0700 |
commit | 697293421df0a294223eb131eb9a5389e41113e5 (patch) | |
tree | ec1700e253ce9c832f36259ea87c14f463d8a13a /meta-oe/recipes-extended/sblim-sfcc | |
parent | f056cc98bb7d543d5e73890c8cd13b9bd53dba4c (diff) | |
download | meta-openembedded-697293421df0a294223eb131eb9a5389e41113e5.tar.gz |
sblim-sfcc: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sblim-sfcc')
-rw-r--r-- | meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-Fix-function-declararions.patch | 80 | ||||
-rw-r--r-- | meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb | 1 |
2 files changed, 81 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-Fix-function-declararions.patch b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-Fix-function-declararions.patch new file mode 100644 index 0000000000..c498c55692 --- /dev/null +++ b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-Fix-function-declararions.patch | |||
@@ -0,0 +1,80 @@ | |||
1 | From f97c26f5effd4372f7e03f9e4178d42a9ad8d4b3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 2 Sep 2022 13:33:16 -0700 | ||
4 | Subject: [PATCH] Fix function declararions | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | TEST/v2test_ec.c | 2 ++ | ||
11 | TEST/v2test_ein.c | 1 + | ||
12 | backend/cimxml/cimXmlParser.c | 6 +++++- | ||
13 | backend/cimxml/grammar.c | 2 ++ | ||
14 | 4 files changed, 10 insertions(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/TEST/v2test_ec.c b/TEST/v2test_ec.c | ||
17 | index ad34dcc..d3e566d 100644 | ||
18 | --- a/TEST/v2test_ec.c | ||
19 | +++ b/TEST/v2test_ec.c | ||
20 | @@ -6,6 +6,8 @@ | ||
21 | #include "cmcimacs.h" | ||
22 | |||
23 | extern char *value2Chars(CMPIType type, CMPIValue * value); | ||
24 | +extern void showClass( CMPIConstClass * in_class ); | ||
25 | + | ||
26 | /* | ||
27 | * comment out this define to use v2 http XML interface | ||
28 | */ | ||
29 | diff --git a/TEST/v2test_ein.c b/TEST/v2test_ein.c | ||
30 | index c1b4692..5d5ef5d 100644 | ||
31 | --- a/TEST/v2test_ein.c | ||
32 | +++ b/TEST/v2test_ein.c | ||
33 | @@ -6,6 +6,7 @@ | ||
34 | #include "cmcimacs.h" | ||
35 | |||
36 | extern char *value2Chars(CMPIType type, CMPIValue * value); | ||
37 | +extern void showObjectPath( CMPIObjectPath * objectpath ); | ||
38 | void showProperty( CMPIData , char * ); | ||
39 | void showInstance( CMPIInstance * ); | ||
40 | static char * CMPIState_str(CMPIValueState); | ||
41 | diff --git a/backend/cimxml/cimXmlParser.c b/backend/cimxml/cimXmlParser.c | ||
42 | index d1ab86e..9f5d1ca 100644 | ||
43 | --- a/backend/cimxml/cimXmlParser.c | ||
44 | +++ b/backend/cimxml/cimXmlParser.c | ||
45 | @@ -34,6 +34,8 @@ | ||
46 | |||
47 | #include <pthread.h> | ||
48 | |||
49 | +void startParsing(ParserControl *parm); | ||
50 | + | ||
51 | static int attrsOk(XmlBuffer * xb, const XmlElement * e, XmlAttr * r, | ||
52 | const char *tag, int etag); | ||
53 | static char *getValue(XmlBuffer * xb, const char *v); | ||
54 | @@ -1350,7 +1352,9 @@ ResponseHdr scanCimXmlResponse(const char *xmlData, CMPIObjectPath *cop) | ||
55 | |||
56 | control.heap = parser_heap_init(); | ||
57 | |||
58 | - control.respHdr.rc = startParsing(&control); | ||
59 | + control.respHdr.rc = 0; | ||
60 | + | ||
61 | + startParsing(&control); | ||
62 | |||
63 | parser_heap_term(control.heap); | ||
64 | |||
65 | diff --git a/backend/cimxml/grammar.c b/backend/cimxml/grammar.c | ||
66 | index 6a0a969..a3dcdea 100644 | ||
67 | --- a/backend/cimxml/grammar.c | ||
68 | +++ b/backend/cimxml/grammar.c | ||
69 | @@ -23,6 +23,8 @@ | ||
70 | #include "sfcUtil/utilft.h" | ||
71 | #include "parserUtil.h" | ||
72 | |||
73 | +CMPIType guessType(char *val); | ||
74 | +void setClassMethods(CMPIConstClass *cls, XtokMethods *ms); | ||
75 | |||
76 | static int ct = 0; | ||
77 | static int dontLex = 0; | ||
78 | -- | ||
79 | 2.37.3 | ||
80 | |||
diff --git a/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb index df55a67996..20bd2b6fc1 100644 --- a/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb +++ b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb | |||
@@ -4,6 +4,7 @@ HOMEPAGE = "http://www.sblim.org" | |||
4 | 4 | ||
5 | SRC_URI = "http://netcologne.dl.sourceforge.net/project/sblim/${BPN}/${BPN}-${PV}.tar.bz2 \ | 5 | SRC_URI = "http://netcologne.dl.sourceforge.net/project/sblim/${BPN}/${BPN}-${PV}.tar.bz2 \ |
6 | file://0001-cimxml-Include-sys-select.h-for-fd_set.patch \ | 6 | file://0001-cimxml-Include-sys-select.h-for-fd_set.patch \ |
7 | file://0001-Fix-function-declararions.patch \ | ||
7 | " | 8 | " |
8 | 9 | ||
9 | SRC_URI[md5sum] = "0bac0dec19f17ec065b6c332a56d7bae" | 10 | SRC_URI[md5sum] = "0bac0dec19f17ec065b6c332a56d7bae" |