diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-08-19 10:28:56 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-08-19 10:46:09 -0700 |
commit | b320682bf5cbc280fc916725fb8a2f4ea38eeef4 (patch) | |
tree | 5f2f2d55e43d4779d045de8999a1a6f7db65cbb6 /meta-oe/recipes-extended/rsyslog | |
parent | e34c58ed66886ee2c964aa21aee2268d87c65699 (diff) | |
download | meta-openembedded-b320682bf5cbc280fc916725fb8a2f4ea38eeef4.tar.gz |
librelp: Fix ptests builds on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/rsyslog')
-rw-r--r-- | meta-oe/recipes-extended/rsyslog/librelp/0001-tests-Include-missing-sys-time.h.patch | 41 | ||||
-rw-r--r-- | meta-oe/recipes-extended/rsyslog/librelp_1.11.0.bb | 1 |
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/librelp/0001-tests-Include-missing-sys-time.h.patch b/meta-oe/recipes-extended/rsyslog/librelp/0001-tests-Include-missing-sys-time.h.patch new file mode 100644 index 0000000000..6fed23c1d1 --- /dev/null +++ b/meta-oe/recipes-extended/rsyslog/librelp/0001-tests-Include-missing-sys-time.h.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From 5c32487a9c127f37141488d416cdb5d5bec6aca1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 19 Aug 2023 10:24:40 -0700 | ||
4 | Subject: [PATCH] tests: Include missing sys/time.h | ||
5 | |||
6 | This is found when building for musl C library systems where sys/time.h | ||
7 | is not included indirectly and select() and timeval structs are used | ||
8 | |||
9 | Fixes | ||
10 | |||
11 | ../../git/tests/receive.c:64:17: error: variable has incomplete type 'struct timeval' | ||
12 | 64 | struct timeval tvSelectTimeout; | ||
13 | | ^ | ||
14 | ../../git/tests/receive.c:64:9: note: forward declaration of 'struct timeval' | ||
15 | 64 | struct timeval tvSelectTimeout; | ||
16 | | ^ | ||
17 | ../../git/tests/receive.c:67:2: error: call to undeclared function 'select'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration] | ||
18 | 67 | select(0, NULL, NULL, NULL, &tvSelectTimeout); | ||
19 | | ^ | ||
20 | |||
21 | Upstream-Status: Submitted [https://github.com/rsyslog/librelp/pull/261] | ||
22 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
23 | --- | ||
24 | tests/receive.c | 3 ++- | ||
25 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
26 | |||
27 | diff --git a/tests/receive.c b/tests/receive.c | ||
28 | index f376cb4..e20861e 100644 | ||
29 | --- a/tests/receive.c | ||
30 | +++ b/tests/receive.c | ||
31 | @@ -33,6 +33,7 @@ | ||
32 | #include <limits.h> | ||
33 | #include <errno.h> | ||
34 | #include <signal.h> | ||
35 | +#include <sys/time.h> | ||
36 | #include "librelp.h" | ||
37 | |||
38 | #define TRY(f) { const int TRY_r = f; if(TRY_r != RELP_RET_OK) { \ | ||
39 | -- | ||
40 | 2.41.0 | ||
41 | |||
diff --git a/meta-oe/recipes-extended/rsyslog/librelp_1.11.0.bb b/meta-oe/recipes-extended/rsyslog/librelp_1.11.0.bb index c64eaf2c48..705452734a 100644 --- a/meta-oe/recipes-extended/rsyslog/librelp_1.11.0.bb +++ b/meta-oe/recipes-extended/rsyslog/librelp_1.11.0.bb | |||
@@ -10,6 +10,7 @@ SRC_URI = "git://github.com/rsyslog/librelp.git;protocol=https;branch=stable \ | |||
10 | file://0001-Fix-function-inline-errors-in-debug-optimization-Og.patch \ | 10 | file://0001-Fix-function-inline-errors-in-debug-optimization-Og.patch \ |
11 | file://0001-tests-Fix-callback-prototype.patch \ | 11 | file://0001-tests-Fix-callback-prototype.patch \ |
12 | file://0001-tcp-fix-some-compiler-warnings-with-enable-tls-opens.patch \ | 12 | file://0001-tcp-fix-some-compiler-warnings-with-enable-tls-opens.patch \ |
13 | file://0001-tests-Include-missing-sys-time.h.patch \ | ||
13 | file://run-ptest \ | 14 | file://run-ptest \ |
14 | " | 15 | " |
15 | 16 | ||