summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-04-21 02:21:05 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-03 20:45:01 +0200
commit9ef1b542367416e2f2e418f33871f773d63a7bda (patch)
treea183162557e70b928fd0441e06c8de0af3002fae /meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb
parent1760dd3e8995db842c06194d76600281390ce58c (diff)
downloadmeta-openembedded-9ef1b542367416e2f2e418f33871f773d63a7bda.tar.gz
rsyslog: add PACKAGECONFIG for optional features
rsyslog supports many optional features, add PACKAGECONFIG for them to ensures that the dependency on related packages is deterministic and so that we can easily enable/disable features. Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Diffstat (limited to 'meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb')
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb34
1 files changed, 32 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb
index b1392e9b3..3801933b5 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb
@@ -10,7 +10,6 @@ Rsyslog is an enhanced syslogd supporting, among others, MySQL,\
10 very easy to setup for the novice user." 10 very easy to setup for the novice user."
11 11
12DEPENDS = "zlib libestr json-c" 12DEPENDS = "zlib libestr json-c"
13DEPENDS += "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
14HOMEPAGE = "http://www.rsyslog.com/" 13HOMEPAGE = "http://www.rsyslog.com/"
15LICENSE = "GPLv3 & LGPLv3 & Apache-2.0" 14LICENSE = "GPLv3 & LGPLv3 & Apache-2.0"
16LIC_FILES_CHKSUM = "file://COPYING;md5=51d9635e646fb75e1b74c074f788e973 \ 15LIC_FILES_CHKSUM = "file://COPYING;md5=51d9635e646fb75e1b74c074f788e973 \
@@ -27,7 +26,38 @@ SRC_URI[sha256sum] = "276d094d1e4c62c770ec8a72723667f119eee038912b79cf3337d439bc
27 26
28inherit autotools pkgconfig systemd update-rc.d 27inherit autotools pkgconfig systemd update-rc.d
29 28
30EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)} --enable-cached-man-pages" 29EXTRA_OECONF += "--enable-cached-man-pages"
30
31# first line is default yes in configure
32PACKAGECONFIG ??= " \
33 zlib rsyslogd rsyslogrt klog inet regexp uuid libgcrypt \
34 imdiag gnutls \
35 ${@base_contains('DISTRO_FEATURES', 'snmp', 'snmp', '', d)} \
36 ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
37"
38
39# default yes in configure
40PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
41PACKAGECONFIG[rsyslogd] = "--enable-rsyslogd,--disable-rsyslogd,,"
42PACKAGECONFIG[rsyslogrt] = "--enable-rsyslogrt,--disable-rsyslogrt,,"
43PACKAGECONFIG[inet] = "--enable-inet,--disable-inet,,"
44PACKAGECONFIG[klog] = "--enable-klog,--disable-klog,,"
45PACKAGECONFIG[regexp] = "--enable-regexp,--disable-regexp,,"
46PACKAGECONFIG[uuid] = "--enable-uuid,--disable-uuid,util-linux,"
47PACKAGECONFIG[libgcrypt] = "--enable-libgcrypt,--disable-libgcrypt,libgcrypt,"
48PACKAGECONFIG[testbench] = "--enable-testbench,--disable-testbench,,"
49
50# default no in configure
51PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
52PACKAGECONFIG[imdiag] = "--enable-imdiag,--disable-imdiag,,"
53PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp,"
54PACKAGECONFIG[gnutls] = "--enable-gnutls,--disable-gnutls,gnutls,"
55PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--without-systemdsystemunitdir,systemd,"
56PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5,"
57PACKAGECONFIG[postgresql] = "--enable-pgsql,--disable-pgsql,postgresql,"
58PACKAGECONFIG[libdbi] = "--enable-libdbi,--disable-libdbi,libdbi,"
59PACKAGECONFIG[mail] = "--enable-mail,--disable-mail,,"
60PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
31 61
32do_install_append() { 62do_install_append() {
33 install -d "${D}${sysconfdir}/init.d" 63 install -d "${D}${sysconfdir}/init.d"