summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/rrdtool
diff options
context:
space:
mode:
authorJiaying Song <jiaying.song.cn@windriver.com>2024-06-04 11:20:18 +0800
committerKhem Raj <raj.khem@gmail.com>2024-06-06 21:45:27 -0700
commit05c17b63fe0bbc7f94154017f2c54237576df94c (patch)
tree86614b1042735a34b48e8c1e5cb3ecb49c858f0b /meta-oe/recipes-extended/rrdtool
parent95fbda562580781c740de786b538070efd079ae7 (diff)
downloadmeta-openembedded-05c17b63fe0bbc7f94154017f2c54237576df94c.tar.gz
rrdtool: Fix do_populate_sysroot QA issues
This commit addresses the shebang size issue encountered in the do_populate_sysroot task of the rrdtool-native recipe. The issue was caused by the shebang line in the cgi-demo.cgi file exceeding the maximum allowed length of 128 characters. The following error was observed: ERROR: rrdtool-native-1.8.0-r0 do_populate_sysroot: QA Issue: : /work/x86_64-linux/rrdtool-native/1.8.0/sysroot-destdir/work/x86_64-linux/rrdtool-native/1.8.0/recipe-sysroot-native/usr/share/rrdtool/examples/cgi-demo.cgi maximum shebang size exceeded, the maximum size is 128. [shebang-size] ERROR: rrdtool-native-1.8.0-r0 do_populate_sysroot: do_populate_sysroot for this recipe installed files with QA issues  The solution implemented involves modifying the shebang line in the cgi-demo.cgi file to use '/usr/bin/env rrdcgi', ensuring it adheres to the length limit. Signed-off-by: Jiaying Song <jiaying.song.cn@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/rrdtool')
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb
index 425a98f0c0..ff173dec5b 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb
@@ -104,6 +104,11 @@ do_configure() {
104 ${B}/examples/*.pl 104 ${B}/examples/*.pl
105} 105}
106 106
107do_install:append:class-native() {
108 # Replace the shebang line in cgi-demo.cgi
109 sed -i '1s|^.*$|#!/usr/bin/env rrdcgi|' ${D}${datadir}/rrdtool/examples/cgi-demo.cgi
110}
111
107PACKAGES =+ "${PN}-perl ${PN}-python" 112PACKAGES =+ "${PN}-perl ${PN}-python"
108PACKAGES =+ "rrdcached" 113PACKAGES =+ "rrdcached"
109 114