summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/rrdtool/rrdtool_1.4.8.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-extended/rrdtool/rrdtool_1.4.8.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-extended/rrdtool/rrdtool_1.4.8.bb')
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.4.8.bb122
1 files changed, 122 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.4.8.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.4.8.bb
new file mode 100644
index 000000000..6bc5e9863
--- /dev/null
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.4.8.bb
@@ -0,0 +1,122 @@
1SUMMARY = "High performance data logging and graphing system for time series data"
2HOMEPAGE = "http://oss.oetiker.ch/rrdtool/"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0"
6
7DEPENDS = "libpng zlib cairo pango glib-2.0 libxml2 groff-native"
8
9SRCREV = "1850e00a17e25e93c39e608f4e2da50f29c5c712"
10PV = "1.4.8"
11
12SRC_URI = "\
13 git://github.com/oetiker/rrdtool-1.x.git;branch=1.4 \
14 file://remove_hardcoded_xml_include.patch \
15 file://0001-removing-testing-leftovers.patch \
16"
17
18S = "${WORKDIR}/git"
19
20inherit autotools-brokensep gettext pythonnative perlnative python-dir cpan-base
21
22EXTRA_AUTORECONF = "-I m4"
23
24PACKAGECONFIG ??= "python perl"
25
26PACKAGECONFIG[python] = "--enable-python=yes \
27am_cv_python_pythondir=${STAGING_LIBDIR}/python${PYTHON_BASEVERSION}/site-packages \
28am_cv_python_pyexecdir=${STAGING_LIBDIR}/python${PYTHON_BASEVERSION}/site-packages,\
29--disable-python,python,"
30
31PACKAGECONFIG[perl] = \
32"--enable-perl=yes --with-perl-options='INSTALLDIRS="vendor"' \
33ac_cv_path_PERL_CC='${CC}', \
34--disable-perl,perl,"
35
36PACKAGECONFIG[dbi] = "--enable-libdbi,--disable-libdbi,libdbi"
37
38EXTRA_OECONF = " \
39 --enable-shared \
40 --disable-libwrap \
41 --program-prefix='' \
42 rd_cv_ieee_works=yes \
43 --disable-ruby \
44 --disable-lua \
45 --disable-tcl \
46 --disable-rpath \
47"
48
49# don't use perl.real, this results in break issues with prebuilts since perl.real doesn't
50# know where the PERL5LIB is...
51# use wrapper perl instead
52EXTRA_OEMAKE = "PERL=${STAGING_BINDIR_NATIVE}/perl-native/perl FULLPERL=${STAGING_BINDIR_NATIVE}/perl-native/perl"
53
54export BUILD_SYS
55export HOST_SYS
56export STAGING_LIBDIR
57export STAGING_INCDIR
58
59# Env var which tells perl if it should use host (no) or target (yes) settings
60export PERLCONFIGTARGET = "${@is_target(d)}"
61export PERL_INC = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}/CORE"
62export PERL_LIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
63export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
64
65do_configure() {
66 #fix the pkglib problem with newer automake
67 #perl
68 sed -i -e "s|-Wl,--rpath -Wl,\$rp||g" \
69 ${S}/bindings/perl-shared/Makefile.PL
70
71 #python
72 sed -i -e '/PYTHON_INCLUDES="-I${/c \
73 PYTHON_INCLUDES="-I=/usr/include/python${PYTHON_BASEVERSION}"' \
74 ${S}/m4/acinclude.m4
75 #remove the hardcoded $(libdir) rpath
76 sed -i -e 's|--rpath=$(libdir)||g' ${S}/bindings/Makefile.am
77
78 autotools_do_configure
79
80 #modify python sitepkg
81 #remove the dependency of perl-shared:Makefile
82 #or perl-shared/Makefile will be regenerated
83 #if any code touch bindings/Makefile after below perl bindings code
84 sed -i -e "s:\$(PYTHON) setup.py install:\$(PYTHON) setup.py install \
85 --install-lib=${D}${PYTHON_SITEPACKAGES_DIR}:" \
86 -e "s:perl-shared/Makefile.PL Makefile:perl-shared/Makefile.PL:" \
87 ${B}/bindings/Makefile
88
89 #redo the perl bindings
90 (
91 cd ${S}/bindings/perl-shared;
92 perl Makefile.PL INSTALLDIRS="vendor" INSTALLPRIVLIB="abc";
93
94 cd ../../bindings/perl-piped;
95 perl Makefile.PL INSTALLDIRS="vendor";
96 )
97
98 #change the interpreter in file
99 sed -i -e "s|^PERL = ${STAGING_BINDIR_NATIVE}/.*|PERL = /usr/bin/perl|g" \
100 ${B}/examples/Makefile
101 sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl|/usr/bin/perl|g" \
102 ${B}/examples/*.pl
103}
104
105PACKAGES =+ "${PN}-perl ${PN}-python"
106
107FILES_${PN}-doc += "${datadir}/examples"
108
109DESCRIPTION_${PN}-perl = \
110"The ${PN}-perl package includes RRDtool bindings for perl."
111FILES_${PN}-perl = "${libdir}/perl/vendor_perl/*/*.pm ${datadir}/rrdtool/examples \
112 ${libdir}/perl/vendor_perl/*/auto/RRDs/RRDs.*"
113RDEPENDS_${PN}-perl = "perl perl-module-lib perl-module-getopt-long perl-module-time-hires \
114 perl-module-io-file perl-module-ipc-open2 perl-module-io-socket"
115
116DESCRIPTION_${PN}-python = \
117"The ${PN}-python package includes RRDtool bindings for python."
118FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
119RDEPENDS_${PN}-python = "python"
120
121FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/RRDs/.debug \
122 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"