summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/redis
diff options
context:
space:
mode:
authorYi Fan Yu <yifan.yu@windriver.com>2021-04-12 16:54:18 -0400
committerKhem Raj <raj.khem@gmail.com>2021-04-13 08:09:17 -0700
commit0c006765426bc41c1344e856528b499637574f97 (patch)
tree0f30fb286e3c691e9591cfbd532ce395865f047a /meta-oe/recipes-extended/redis
parentf186377359fa1f4db8e6c6a8a4f40f774591af8e (diff)
downloadmeta-openembedded-0c006765426bc41c1344e856528b499637574f97.tar.gz
redis: upgrade 6.0.9 -> 6.2.1
Refresh 3 patches. Removed Patch: ilp32.patch fixed by upstream 0719388cfb1a79160204314beb1de1f9c29a3684 Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/redis')
-rw-r--r--meta-oe/recipes-extended/redis/redis/0006-Define-correct-gregs-for-RISCV32.patch (renamed from meta-oe/recipes-extended/redis/redis/riscv32.patch)26
-rw-r--r--meta-oe/recipes-extended/redis/redis/ilp32.patch29
-rw-r--r--meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch66
-rw-r--r--meta-oe/recipes-extended/redis/redis/oe-use-libc-malloc.patch12
-rw-r--r--meta-oe/recipes-extended/redis/redis_6.2.1.bb (renamed from meta-oe/recipes-extended/redis/redis_6.0.9.bb)5
5 files changed, 62 insertions, 76 deletions
diff --git a/meta-oe/recipes-extended/redis/redis/riscv32.patch b/meta-oe/recipes-extended/redis/redis/0006-Define-correct-gregs-for-RISCV32.patch
index 79ec7423d..b2d1a32ed 100644
--- a/meta-oe/recipes-extended/redis/redis/riscv32.patch
+++ b/meta-oe/recipes-extended/redis/redis/0006-Define-correct-gregs-for-RISCV32.patch
@@ -1,21 +1,33 @@
1Define correct gregs for RISCV32 1From 6134b471c35df826ccb41aab9a47e5c89e15a0c4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 26 Oct 2020 21:32:22 -0700
4Subject: [PATCH] Define correct gregs for RISCV32
2 5
3Upstream-Status: Pending 6Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com> 7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8
9Updated patch for 6.2.1
10Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com>
11---
12 src/debug.c | 26 ++++++++++++++++++++++++--
13 1 file changed, 24 insertions(+), 2 deletions(-)
14
15diff --git a/src/debug.c b/src/debug.c
16index e7fec29..5abb404 100644
5--- a/src/debug.c 17--- a/src/debug.c
6+++ b/src/debug.c 18+++ b/src/debug.c
7@@ -942,7 +942,9 @@ static void *getMcontextEip(ucontext_t * 19@@ -1039,7 +1039,9 @@ static void *getMcontextEip(ucontext_t *uc) {
8 #endif 20 #endif
9 #elif defined(__linux__) 21 #elif defined(__linux__)
10 /* Linux */ 22 /* Linux */
11- #if defined(__i386__) || defined(__ILP32__) 23- #if defined(__i386__) || ((defined(__X86_64__) || defined(__x86_64__)) && defined(__ILP32__))
12+ #if defined(__riscv) && __riscv_xlen == 32 24+ #if defined(__riscv) && __riscv_xlen == 32
13+ return (void*) uc->uc_mcontext.__gregs[REG_PC]; 25+ return (void*) uc->uc_mcontext.__gregs[REG_PC];
14+ #elif defined(__i386__) || defined(__ILP32__) 26+ #elif defined(__i386__) || ((defined(__X86_64__) || defined(__x86_64__)) && defined(__ILP32__))
15 return (void*) uc->uc_mcontext.gregs[14]; /* Linux 32 */ 27 return (void*) uc->uc_mcontext.gregs[14]; /* Linux 32 */
16 #elif defined(__X86_64__) || defined(__x86_64__) 28 #elif defined(__X86_64__) || defined(__x86_64__)
17 return (void*) uc->uc_mcontext.gregs[16]; /* Linux 64 */ 29 return (void*) uc->uc_mcontext.gregs[16]; /* Linux 64 */
18@@ -1102,8 +1104,28 @@ void logRegisters(ucontext_t *uc) { 30@@ -1206,8 +1208,28 @@ void logRegisters(ucontext_t *uc) {
19 #endif 31 #endif
20 /* Linux */ 32 /* Linux */
21 #elif defined(__linux__) 33 #elif defined(__linux__)
@@ -40,8 +52,8 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
40+ ); 52+ );
41+ logStackContent((void**)uc->uc_mcontext.__gregs[REG_SP]); 53+ logStackContent((void**)uc->uc_mcontext.__gregs[REG_SP]);
42 /* Linux x86 */ 54 /* Linux x86 */
43- #if defined(__i386__) || defined(__ILP32__) 55- #if defined(__i386__) || ((defined(__X86_64__) || defined(__x86_64__)) && defined(__ILP32__))
44+ #elif defined(__i386__) || defined(__ILP32__) 56+ #elif defined(__i386__) || ((defined(__X86_64__) || defined(__x86_64__)) && defined(__ILP32__))
45 serverLog(LL_WARNING, 57 serverLog(LL_WARNING,
46 "\n" 58 "\n"
47 "EAX:%08lx EBX:%08lx ECX:%08lx EDX:%08lx\n" 59 "EAX:%08lx EBX:%08lx ECX:%08lx EDX:%08lx\n"
diff --git a/meta-oe/recipes-extended/redis/redis/ilp32.patch b/meta-oe/recipes-extended/redis/redis/ilp32.patch
deleted file mode 100644
index 48d01a1d6..000000000
--- a/meta-oe/recipes-extended/redis/redis/ilp32.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1__ILP32__ is defined for all 32bit architectures with clang e.g.
2which is right but it is causing issues on non-x86 architectures
3where this condition becomes true and wrongly starts using this
4code, this issue is hidden with gcc becuase gcc does not define
5__ILP32__ for all 32bit architectures but for selected 64bit arches
6who choose to use 32bit ABI e.g. x32
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10--- a/src/debug.c
11+++ b/src/debug.c
12@@ -944,7 +944,7 @@ static void *getMcontextEip(ucontext_t *
13 /* Linux */
14 #if defined(__riscv) && __riscv_xlen == 32
15 return (void*) uc->uc_mcontext.__gregs[REG_PC];
16- #elif defined(__i386__) || defined(__ILP32__)
17+ #elif defined(__i386__) || (defined(__X86_64__) && defined(__ILP32__))
18 return (void*) uc->uc_mcontext.gregs[14]; /* Linux 32 */
19 #elif defined(__X86_64__) || defined(__x86_64__)
20 return (void*) uc->uc_mcontext.gregs[16]; /* Linux 64 */
21@@ -1125,7 +1125,7 @@ void logRegisters(ucontext_t *uc) {
22 );
23 logStackContent((void**)uc->uc_mcontext.__gregs[REG_SP]);
24 /* Linux x86 */
25- #elif defined(__i386__) || defined(__ILP32__)
26+ #elif defined(__i386__) || ( defined(__X86_64__) && defined(__ILP32__))
27 serverLog(LL_WARNING,
28 "\n"
29 "EAX:%08lx EBX:%08lx ECX:%08lx EDX:%08lx\n"
diff --git a/meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch b/meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch
index 7e62ae131..1619e9db3 100644
--- a/meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch
+++ b/meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch
@@ -1,4 +1,4 @@
1From 394108035d350ae662a431c80131f812b5f72dff Mon Sep 17 00:00:00 2001 1From 097a2b259cb266c2c861dc74fa6f80712d6138c5 Mon Sep 17 00:00:00 2001
2From: Venture Research <tech@ventureresearch.com> 2From: Venture Research <tech@ventureresearch.com>
3Date: Fri, 8 Feb 2013 20:22:19 -0600 3Date: Fri, 8 Feb 2013 20:22:19 -0600
4Subject: [PATCH] lua: update Makefile to use environment build settings 4Subject: [PATCH] lua: update Makefile to use environment build settings
@@ -12,14 +12,42 @@ Updated to work with 3.0.x
12 12
13Signed-off-by: Armin Kuster <akust808@gmail.com> 13Signed-off-by: Armin Kuster <akust808@gmail.com>
14 14
15updated to work wtih 6.2.1
16Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com>
15--- 17---
16 deps/lua/src/Makefile | 18 +++++++----------- 18 deps/Makefile | 1 -
17 1 file changed, 7 insertions(+), 11 deletions(-) 19 deps/lua/Makefile | 1 -
20 deps/lua/src/Makefile | 16 ++++++----------
21 3 files changed, 6 insertions(+), 12 deletions(-)
18 22
19Index: redis-3.0.2/deps/lua/src/Makefile 23diff --git a/deps/Makefile b/deps/Makefile
20=================================================================== 24index ff16ee9..d8d64aa 100644
21--- redis-3.0.2.orig/deps/lua/src/Makefile 25--- a/deps/Makefile
22+++ redis-3.0.2/deps/lua/src/Makefile 26+++ b/deps/Makefile
27@@ -74,7 +74,6 @@ LUA_LDFLAGS+= $(LDFLAGS)
28 # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
29 # challenging to cross-compile lua (and redis). These defines make it easier
30 # to fit redis into cross-compilation environments, which typically set AR.
31-AR=ar
32 ARFLAGS=rc
33
34 lua: .make-prerequisites
35diff --git a/deps/lua/Makefile b/deps/lua/Makefile
36index 209a132..72f4b2b 100644
37--- a/deps/lua/Makefile
38+++ b/deps/lua/Makefile
39@@ -33,7 +33,6 @@ INSTALL_DATA= $(INSTALL) -m 0644
40
41 # Utilities.
42 MKDIR= mkdir -p
43-RANLIB= ranlib
44
45 # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
46
47diff --git a/deps/lua/src/Makefile b/deps/lua/src/Makefile
48index f3bba2f..1555ec0 100644
49--- a/deps/lua/src/Makefile
50+++ b/deps/lua/src/Makefile
23@@ -5,18 +5,14 @@ 51@@ -5,18 +5,14 @@
24 # == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT ======================= 52 # == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT =======================
25 53
@@ -45,27 +73,3 @@ Index: redis-3.0.2/deps/lua/src/Makefile
45 73
46 # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE ========= 74 # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
47 75
48Index: redis-3.0.2/deps/Makefile
49===================================================================
50--- redis-3.0.2.orig/deps/Makefile
51+++ redis-3.0.2/deps/Makefile
52@@ -63,7 +63,6 @@ LUA_LDFLAGS+= $(LDFLAGS)
53 # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
54 # challenging to cross-compile lua (and redis). These defines make it easier
55 # to fit redis into cross-compilation environments, which typically set AR.
56-AR=ar
57 ARFLAGS=rcu
58
59 lua: .make-prerequisites
60Index: redis-3.0.2/deps/lua/Makefile
61===================================================================
62--- redis-3.0.2.orig/deps/lua/Makefile
63+++ redis-3.0.2/deps/lua/Makefile
64@@ -33,7 +33,6 @@ INSTALL_DATA= $(INSTALL) -m 0644
65
66 # Utilities.
67 MKDIR= mkdir -p
68-RANLIB= ranlib
69
70 # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
71
diff --git a/meta-oe/recipes-extended/redis/redis/oe-use-libc-malloc.patch b/meta-oe/recipes-extended/redis/redis/oe-use-libc-malloc.patch
index 6745f3d0e..a0f66b845 100644
--- a/meta-oe/recipes-extended/redis/redis/oe-use-libc-malloc.patch
+++ b/meta-oe/recipes-extended/redis/redis/oe-use-libc-malloc.patch
@@ -1,4 +1,4 @@
1From f8861d2129b9e18bba137705bfa38c6bd9be1790 Mon Sep 17 00:00:00 2001 1From 1fa047162983d4a7e0576f0837a73a6027a783bd Mon Sep 17 00:00:00 2001
2From: Venture Research <tech@ventureresearch.com> 2From: Venture Research <tech@ventureresearch.com>
3Date: Wed, 6 Feb 2013 20:51:02 -0600 3Date: Wed, 6 Feb 2013 20:51:02 -0600
4Subject: [PATCH] hack to force use of libc malloc 4Subject: [PATCH] hack to force use of libc malloc
@@ -6,7 +6,7 @@ Subject: [PATCH] hack to force use of libc malloc
6Hack to force libc usage as it seems the option to pass it in has been 6Hack to force libc usage as it seems the option to pass it in has been
7removed in favor of magic. 7removed in favor of magic.
8 8
9Note that this of course doesn't allow tcmalloc and jemalloc, however 9Note that this of course doesn't allow tcmalloc and jemalloc, however
10jemalloc wasn't building correctly. 10jemalloc wasn't building correctly.
11 11
12Signed-off-by: Venture Research <tech@ventureresearch.com> 12Signed-off-by: Venture Research <tech@ventureresearch.com>
@@ -15,11 +15,11 @@ Update to work with 4.0.8
15Signed-off-by: Alistair Francis <alistair.francis@wdc.com> 15Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
16 16
17--- 17---
18 src/Makefile | 2 +- 18 src/Makefile | 3 ++-
19 1 file changed, 1 insertion(+), 1 deletion(-) 19 1 file changed, 2 insertions(+), 1 deletion(-)
20 20
21diff --git a/src/Makefile b/src/Makefile 21diff --git a/src/Makefile b/src/Makefile
22index 86e0b3fe..a810180b 100644 22index ecd6929..c7f43c5 100644
23--- a/src/Makefile 23--- a/src/Makefile
24+++ b/src/Makefile 24+++ b/src/Makefile
25@@ -13,7 +13,8 @@ 25@@ -13,7 +13,8 @@
@@ -31,4 +31,4 @@ index 86e0b3fe..a810180b 100644
31+uname_S := "USE_LIBC_MALLOC" 31+uname_S := "USE_LIBC_MALLOC"
32 uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not') 32 uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
33 OPTIMIZATION?=-O2 33 OPTIMIZATION?=-O2
34 DEPENDENCY_TARGETS=hiredis linenoise lua 34 DEPENDENCY_TARGETS=hiredis linenoise lua hdr_histogram
diff --git a/meta-oe/recipes-extended/redis/redis_6.0.9.bb b/meta-oe/recipes-extended/redis/redis_6.2.1.bb
index 50571ed55..89990df3d 100644
--- a/meta-oe/recipes-extended/redis/redis_6.0.9.bb
+++ b/meta-oe/recipes-extended/redis/redis_6.2.1.bb
@@ -15,10 +15,9 @@ SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \
15 file://oe-use-libc-malloc.patch \ 15 file://oe-use-libc-malloc.patch \
16 file://0001-src-Do-not-reset-FINAL_LIBS.patch \ 16 file://0001-src-Do-not-reset-FINAL_LIBS.patch \
17 file://GNU_SOURCE.patch \ 17 file://GNU_SOURCE.patch \
18 file://riscv32.patch \ 18 file://0006-Define-correct-gregs-for-RISCV32.patch \
19 file://ilp32.patch \
20 " 19 "
21SRC_URI[sha256sum] = "dc2bdcf81c620e9f09cfd12e85d3bc631c897b2db7a55218fd8a65eaa37f86dd" 20SRC_URI[sha256sum] = "cd222505012cce20b25682fca931ec93bd21ae92cb4abfe742cf7b76aa907520"
22 21
23inherit autotools-brokensep update-rc.d systemd useradd 22inherit autotools-brokensep update-rc.d systemd useradd
24 23