summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-10 20:40:10 -0700
committerArmin Kuster <akuster808@gmail.com>2019-10-05 07:45:32 -0700
commitb3a244153414fa627b247dd29f95197fdaae69e1 (patch)
treeb2bcbd15ceb0eb21785993cb003a09f0b3c283dc /meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
parent6a98afe854907a6263ab5f08ccbc155943470c59 (diff)
downloadmeta-openembedded-b3a244153414fa627b247dd29f95197fdaae69e1.tar.gz
redis: Fix build with clang/x86
Need to link with libatomics for 64bit atomics support Fixes i686-yoe-linux/i686-yoe-linux-ld: networking.o: in function `createClient': | /usr/src/debug/redis/4.0.14-r0/redis-4.0.14/src/networking.c:103: undefined reference to `__atomic_fetch_add_8' Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 2b49254d61ca817799a206cd022617854aa5bc0b) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch')
-rw-r--r--meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch b/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
new file mode 100644
index 000000000..04af15dd8
--- /dev/null
+++ b/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
@@ -0,0 +1,32 @@
1From 97584e1eb78dc18599534b47b6670c20c63f5ee2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 10 Sep 2019 20:04:26 -0700
4Subject: [PATCH] src: Do not reset FINAL_LIBS
5
6This helps case where additional libraries are needed to be passed from
7environment to get it going
8
9e.g. -latomic is needed on clang/x86 to provide for 64bit atomics
10
11Upstream-Status: Pending
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 src/Makefile | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/src/Makefile b/src/Makefile
18index 7f7c625..c71dd3b 100644
19--- a/src/Makefile
20+++ b/src/Makefile
21@@ -66,7 +66,7 @@ endif
22
23 FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
24 FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
25-FINAL_LIBS=-lm
26+FINAL_LIBS+=-lm
27 DEBUG=-g -ggdb
28
29 ifeq ($(uname_S),SunOS)
30--
312.23.0
32