summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/redis-plus-plus
diff options
context:
space:
mode:
authorPeter Bergin <peter.bergin@windriver.com>2023-05-23 14:05:23 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-23 15:04:38 -0700
commitea516e9563e5c827466fd8ca674e5ab1cc8cd5f9 (patch)
treeb661870789dc46e973b68b6a5ab0315bc1a729c6 /meta-oe/recipes-extended/redis-plus-plus
parentfa1910548c33d60bb6b9023c805aa54bef77150d (diff)
downloadmeta-openembedded-ea516e9563e5c827466fd8ca674e5ab1cc8cd5f9.tar.gz
redis-plus-plus: clean up recipe and make use of packageconfig
Remove unneeded statements in the code. Align with style guide. Introduce PACKAGECONFIG for ssl and test. Remove QA warning. Signed-off-by: Peter Bergin <peter.bergin@windriver.com> Signed-off-by: Peter Bergin <peter@berginkonsult.se> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/redis-plus-plus')
-rw-r--r--meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
index 8e906a448..8483331fa 100644
--- a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
+++ b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
@@ -4,6 +4,8 @@ SECTION = "libs"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6 6
7DEPENDS += "hiredis"
8
7SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \ 9SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \
8 file://0001-include-cstdint.patch" 10 file://0001-include-cstdint.patch"
9SRCREV = "f3b19a8a1f609d1a1b79002802e5cf8c336dc262" 11SRCREV = "f3b19a8a1f609d1a1b79002802e5cf8c336dc262"
@@ -12,13 +14,13 @@ S = "${WORKDIR}/git"
12 14
13inherit cmake 15inherit cmake
14 16
15EXTRA_OECMAKE += "-DREDIS_PLUS_PLUS_USE_TLS=ON" 17# if ssl is enabled for redis-plus-plus it must also be enabled for hiredis
16 18PACKAGECONFIG ??= "ssl"
17DEPENDS += "hiredis openssl" 19PACKAGECONFIG[ssl] = "-DREDIS_PLUS_PLUS_USE_TLS=ON, -DREDIS_PLUS_PLUS_USE_TLS=OFF, openssl"
18 20PACKAGECONFIG[test] = "-DREDIS_PLUS_PLUS_BUILD_TEST=ON, -DREDIS_PLUS_PLUS_BUILD_TEST=OFF"
19RDEPENDS:${PN} += "hiredis"
20
21FILES_SOLIBSDEV = ""
22FILES:${PN} += " ${libdir}/libredis++.so*"
23 21
24INSANE_SKIP:${PN} += "dev-so" 22do_install:append() {
23 # To remove absolute path in .cmake found by QA warning [buildpaths]
24 sed -i -e 's|${STAGING_LIBDIR}/libcrypto.so|crypto|g' ${D}${datadir}/cmake/redis++/redis++-targets.cmake
25 sed -i -e 's|${STAGING_LIBDIR}/libssl.so|ssl|g' ${D}${datadir}/cmake/redis++/redis++-targets.cmake
26}