summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/redis-plus-plus
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-07-23 13:38:19 +0800
committerKhem Raj <raj.khem@gmail.com>2022-07-26 20:49:05 -0400
commitb85feca2818c78591579f20c0d0ed8e12d4122f6 (patch)
tree71ad16640d817a32bd64c3198d9ee257a6c6295a /meta-oe/recipes-extended/redis-plus-plus
parent82c6f50e0d1d012368e4fa2eb695abc838abbeb7 (diff)
downloadmeta-openembedded-b85feca2818c78591579f20c0d0ed8e12d4122f6.tar.gz
redis-plus-plus: upgrade 1.3.3 -> 1.3.5
0001-cmake-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallDirs.patch removed since it's included in 1.3.5 Changelog: ========== Ensure running async callback when error happens. Add sentinel support for coroutine interface. Add publish command for async interface. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/redis-plus-plus')
-rw-r--r--meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus/0001-cmake-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallDirs.patch45
-rw-r--r--meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.5.bb (renamed from meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.3.bb)6
2 files changed, 2 insertions, 49 deletions
diff --git a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus/0001-cmake-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallDirs.patch b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus/0001-cmake-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallDirs.patch
deleted file mode 100644
index 9ce39f3f7..000000000
--- a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus/0001-cmake-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallDirs.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From fbb13cdb0b3591616c3f77b6bc76e75af8906cda Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 19 Mar 2022 22:59:58 -0700
4Subject: [PATCH] cmake: Use CMAKE_INSTALL_LIBDIR from GNUInstallDirs
5
6makes it portable across platforms e.g. ppc64/linux uses usr/lib64 for
7system libs
8
9Upstream-Status: Submitted [https://github.com/sewenew/redis-plus-plus/pull/344]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 CMakeLists.txt | 8 +++++---
13 1 file changed, 5 insertions(+), 3 deletions(-)
14
15diff --git a/CMakeLists.txt b/CMakeLists.txt
16index 4f28ee4..8150f5c 100644
17--- a/CMakeLists.txt
18+++ b/CMakeLists.txt
19@@ -239,10 +239,12 @@ if(REDIS_PLUS_PLUS_BUILD_TEST)
20 add_subdirectory(test)
21 endif()
22
23+include(GNUInstallDirs)
24+
25 install(TARGETS ${REDIS_PLUS_PLUS_TARGETS}
26 EXPORT redis++-targets
27- LIBRARY DESTINATION lib
28- ARCHIVE DESTINATION lib
29+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
30+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
31 RUNTIME DESTINATION bin
32 INCLUDES DESTINATION include)
33
34@@ -284,7 +286,7 @@ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/cmake/redis++.pc.in"
35 "${CMAKE_CURRENT_BINARY_DIR}/cmake/redis++.pc" @ONLY)
36
37 install(FILES "${CMAKE_CURRENT_BINARY_DIR}/cmake/redis++.pc"
38- DESTINATION "lib/pkgconfig")
39+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
40
41 # All the Debian-specific cpack defines.
42 if(${CMAKE_VERSION} VERSION_GREATER 3.6)
43--
442.35.1
45
diff --git a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.3.bb b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.5.bb
index 575443f0e..de19dca38 100644
--- a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.3.bb
+++ b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.5.bb
@@ -4,10 +4,8 @@ SECTION = "libs"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6 6
7SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \ 7SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https"
8 file://0001-cmake-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallDirs.patch \ 8SRCREV = "58084931ed1a056d91fe96da7b9ea81fa023560a"
9 "
10SRCREV = "389ffdf9e72035ea2096b03cda7f4a6809ae6363"
11 9
12S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
13 11