summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/polkit
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-09-26 23:47:41 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-27 10:04:35 -0700
commitf2feb70bffb82a89f6b2138c685a96cb610470d2 (patch)
tree13a7ec12021440f55a3dfff43b6fd7ba2b10b183 /meta-oe/recipes-extended/polkit
parent05c8f83f4f5cb05b0a7cc3fa98e785a9d11c0321 (diff)
downloadmeta-openembedded-f2feb70bffb82a89f6b2138c685a96cb610470d2.tar.gz
polkit: refresh patch
Refresh patch to avoid QA issue about patch fuzz. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/polkit')
-rw-r--r--meta-oe/recipes-extended/polkit/polkit/0004-Make-netgroup-support-optional.patch30
1 files changed, 15 insertions, 15 deletions
diff --git a/meta-oe/recipes-extended/polkit/polkit/0004-Make-netgroup-support-optional.patch b/meta-oe/recipes-extended/polkit/polkit/0004-Make-netgroup-support-optional.patch
index 09be3b7280..181aca16ca 100644
--- a/meta-oe/recipes-extended/polkit/polkit/0004-Make-netgroup-support-optional.patch
+++ b/meta-oe/recipes-extended/polkit/polkit/0004-Make-netgroup-support-optional.patch
@@ -1,4 +1,4 @@
1From 501e6df3468f5da05881fc38cf68740e153ab403 Mon Sep 17 00:00:00 2001 1From a334fac72112c01cd322f7c97ef7ca21457ab52f Mon Sep 17 00:00:00 2001
2From: "A. Wilcox" <AWilcox@Wilcox-Tech.com> 2From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
3Date: Sun, 15 May 2022 05:04:10 +0000 3Date: Sun, 15 May 2022 05:04:10 +0000
4Subject: [PATCH] Make netgroup support optional 4Subject: [PATCH] Make netgroup support optional
@@ -37,12 +37,12 @@ Signed-off-by: Marta Rybczynska <marta.rybczynska@huawei.com>
37 9 files changed, 43 insertions(+), 8 deletions(-) 37 9 files changed, 43 insertions(+), 8 deletions(-)
38 38
39diff --git a/configure.ac b/configure.ac 39diff --git a/configure.ac b/configure.ac
40index 18e422300bb7..0f87ea0e8a26 100644 40index ca4b9f2..4c5d596 100644
41--- a/configure.ac 41--- a/configure.ac
42+++ b/configure.ac 42+++ b/configure.ac
43@@ -117,7 +117,7 @@ CFLAGS="$CFLAGS $PTHREAD_CFLAGS" 43@@ -100,7 +100,7 @@ AC_CHECK_LIB(expat,XML_ParserCreate,[EXPAT_LIBS="-lexpat"],
44 CC="$PTHREAD_CC" 44 [AC_MSG_ERROR([Can't find expat library. Please install expat.])])
45 AC_CHECK_FUNCS([pthread_condattr_setclock]) 45 AC_SUBST(EXPAT_LIBS)
46 46
47-AC_CHECK_FUNCS(clearenv fdatasync) 47-AC_CHECK_FUNCS(clearenv fdatasync)
48+AC_CHECK_FUNCS(clearenv fdatasync setnetgrent) 48+AC_CHECK_FUNCS(clearenv fdatasync setnetgrent)
@@ -50,7 +50,7 @@ index 18e422300bb7..0f87ea0e8a26 100644
50 if test "x$GCC" = "xyes"; then 50 if test "x$GCC" = "xyes"; then
51 LDFLAGS="-Wl,--as-needed $LDFLAGS" 51 LDFLAGS="-Wl,--as-needed $LDFLAGS"
52diff --git a/meson.build b/meson.build 52diff --git a/meson.build b/meson.build
53index 750623179750..2d9d67a23409 100644 53index 733bbff..d840926 100644
54--- a/meson.build 54--- a/meson.build
55+++ b/meson.build 55+++ b/meson.build
56@@ -82,6 +82,7 @@ config_h.set('_GNU_SOURCE', true) 56@@ -82,6 +82,7 @@ config_h.set('_GNU_SOURCE', true)
@@ -62,7 +62,7 @@ index 750623179750..2d9d67a23409 100644
62 62
63 foreach func: check_functions 63 foreach func: check_functions
64diff --git a/src/polkit/polkitidentity.c b/src/polkit/polkitidentity.c 64diff --git a/src/polkit/polkitidentity.c b/src/polkit/polkitidentity.c
65index 3aa1f7f1c762..793f17d5d1fe 100644 65index 3aa1f7f..793f17d 100644
66--- a/src/polkit/polkitidentity.c 66--- a/src/polkit/polkitidentity.c
67+++ b/src/polkit/polkitidentity.c 67+++ b/src/polkit/polkitidentity.c
68@@ -182,7 +182,15 @@ polkit_identity_from_string (const gchar *str, 68@@ -182,7 +182,15 @@ polkit_identity_from_string (const gchar *str,
@@ -105,7 +105,7 @@ index 3aa1f7f1c762..793f17d5d1fe 100644
105 else 105 else
106 { 106 {
107diff --git a/src/polkit/polkitunixnetgroup.c b/src/polkit/polkitunixnetgroup.c 107diff --git a/src/polkit/polkitunixnetgroup.c b/src/polkit/polkitunixnetgroup.c
108index 8a2b36938ac5..83f8d4a13efd 100644 108index 8a2b369..83f8d4a 100644
109--- a/src/polkit/polkitunixnetgroup.c 109--- a/src/polkit/polkitunixnetgroup.c
110+++ b/src/polkit/polkitunixnetgroup.c 110+++ b/src/polkit/polkitunixnetgroup.c
111@@ -194,6 +194,9 @@ polkit_unix_netgroup_set_name (PolkitUnixNetgroup *group, 111@@ -194,6 +194,9 @@ polkit_unix_netgroup_set_name (PolkitUnixNetgroup *group,
@@ -119,7 +119,7 @@ index 8a2b36938ac5..83f8d4a13efd 100644
119 return POLKIT_IDENTITY (g_object_new (POLKIT_TYPE_UNIX_NETGROUP, 119 return POLKIT_IDENTITY (g_object_new (POLKIT_TYPE_UNIX_NETGROUP,
120 "name", name, 120 "name", name,
121diff --git a/src/polkitbackend/polkitbackendinteractiveauthority.c b/src/polkitbackend/polkitbackendinteractiveauthority.c 121diff --git a/src/polkitbackend/polkitbackendinteractiveauthority.c b/src/polkitbackend/polkitbackendinteractiveauthority.c
122index 056d9a8f27f8..36c2f3dc1a79 100644 122index 056d9a8..36c2f3d 100644
123--- a/src/polkitbackend/polkitbackendinteractiveauthority.c 123--- a/src/polkitbackend/polkitbackendinteractiveauthority.c
124+++ b/src/polkitbackend/polkitbackendinteractiveauthority.c 124+++ b/src/polkitbackend/polkitbackendinteractiveauthority.c
125@@ -2233,25 +2233,26 @@ get_users_in_net_group (PolkitIdentity *group, 125@@ -2233,25 +2233,26 @@ get_users_in_net_group (PolkitIdentity *group,
@@ -164,10 +164,10 @@ index 056d9a8f27f8..36c2f3dc1a79 100644
164 } 164 }
165 165
166diff --git a/src/polkitbackend/polkitbackendjsauthority.cpp b/src/polkitbackend/polkitbackendjsauthority.cpp 166diff --git a/src/polkitbackend/polkitbackendjsauthority.cpp b/src/polkitbackend/polkitbackendjsauthority.cpp
167index 11e91c045da1..9ee0391b8c70 100644 167index 5027815..bcb040c 100644
168--- a/src/polkitbackend/polkitbackendjsauthority.cpp 168--- a/src/polkitbackend/polkitbackendjsauthority.cpp
169+++ b/src/polkitbackend/polkitbackendjsauthority.cpp 169+++ b/src/polkitbackend/polkitbackendjsauthority.cpp
170@@ -1291,6 +1291,7 @@ js_polkit_user_is_in_netgroup (JSContext *cx, 170@@ -1524,6 +1524,7 @@ js_polkit_user_is_in_netgroup (JSContext *cx,
171 171
172 JS::CallArgs args = JS::CallArgsFromVp (argc, vp); 172 JS::CallArgs args = JS::CallArgsFromVp (argc, vp);
173 173
@@ -175,7 +175,7 @@ index 11e91c045da1..9ee0391b8c70 100644
175 JS::RootedString usrstr (authority->priv->cx); 175 JS::RootedString usrstr (authority->priv->cx);
176 usrstr = args[0].toString(); 176 usrstr = args[0].toString();
177 user = JS_EncodeStringToUTF8 (cx, usrstr); 177 user = JS_EncodeStringToUTF8 (cx, usrstr);
178@@ -1305,6 +1306,7 @@ js_polkit_user_is_in_netgroup (JSContext *cx, 178@@ -1538,6 +1539,7 @@ js_polkit_user_is_in_netgroup (JSContext *cx,
179 { 179 {
180 is_in_netgroup = true; 180 is_in_netgroup = true;
181 } 181 }
@@ -184,7 +184,7 @@ index 11e91c045da1..9ee0391b8c70 100644
184 ret = true; 184 ret = true;
185 185
186diff --git a/test/polkit/polkitidentitytest.c b/test/polkit/polkitidentitytest.c 186diff --git a/test/polkit/polkitidentitytest.c b/test/polkit/polkitidentitytest.c
187index e91967bec5b9..2635c4c4c64b 100644 187index e91967b..2635c4c 100644
188--- a/test/polkit/polkitidentitytest.c 188--- a/test/polkit/polkitidentitytest.c
189+++ b/test/polkit/polkitidentitytest.c 189+++ b/test/polkit/polkitidentitytest.c
190@@ -145,11 +145,15 @@ struct ComparisonTestData comparison_test_data [] = { 190@@ -145,11 +145,15 @@ struct ComparisonTestData comparison_test_data [] = {
@@ -219,7 +219,7 @@ index e91967bec5b9..2635c4c4c64b 100644
219 add_comparison_tests (); 219 add_comparison_tests ();
220 220
221diff --git a/test/polkit/polkitunixnetgrouptest.c b/test/polkit/polkitunixnetgrouptest.c 221diff --git a/test/polkit/polkitunixnetgrouptest.c b/test/polkit/polkitunixnetgrouptest.c
222index 3701ba1671b7..e1d211e47634 100644 222index 3701ba1..e1d211e 100644
223--- a/test/polkit/polkitunixnetgrouptest.c 223--- a/test/polkit/polkitunixnetgrouptest.c
224+++ b/test/polkit/polkitunixnetgrouptest.c 224+++ b/test/polkit/polkitunixnetgrouptest.c
225@@ -69,7 +69,9 @@ int 225@@ -69,7 +69,9 @@ int
@@ -233,7 +233,7 @@ index 3701ba1671b7..e1d211e47634 100644
233 return g_test_run (); 233 return g_test_run ();
234 } 234 }
235diff --git a/test/polkitbackend/test-polkitbackendjsauthority.c b/test/polkitbackend/test-polkitbackendjsauthority.c 235diff --git a/test/polkitbackend/test-polkitbackendjsauthority.c b/test/polkitbackend/test-polkitbackendjsauthority.c
236index 2103b174d58d..b187a2ffee3e 100644 236index f97e0e0..fc52149 100644
237--- a/test/polkitbackend/test-polkitbackendjsauthority.c 237--- a/test/polkitbackend/test-polkitbackendjsauthority.c
238+++ b/test/polkitbackend/test-polkitbackendjsauthority.c 238+++ b/test/polkitbackend/test-polkitbackendjsauthority.c
239@@ -137,12 +137,14 @@ test_get_admin_identities (void) 239@@ -137,12 +137,14 @@ test_get_admin_identities (void)