summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/polkit
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-22 19:32:24 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:31 +0100
commit2ba35c90c0ff16585d6c37c99fd72647efba5c4e (patch)
tree4727af30c0e3dffd8b2b18a52997435844395594 /meta-oe/recipes-extended/polkit
parent9ef817812c4f41bb920258afd7c2a244138e82dd (diff)
downloadmeta-openembedded-2ba35c90c0ff16585d6c37c99fd72647efba5c4e.tar.gz
polkit: fix gobject introspection support
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-extended/polkit')
-rw-r--r--meta-oe/recipes-extended/polkit/polkit_0.113.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/meta-oe/recipes-extended/polkit/polkit_0.113.bb b/meta-oe/recipes-extended/polkit/polkit_0.113.bb
index 8a613ef7a..aab4f549d 100644
--- a/meta-oe/recipes-extended/polkit/polkit_0.113.bb
+++ b/meta-oe/recipes-extended/polkit/polkit_0.113.bb
@@ -5,9 +5,9 @@ LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4" 6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7 7
8DEPENDS = "expat glib-2.0 intltool-native gobject-introspection-stub mozjs" 8DEPENDS = "expat glib-2.0 intltool-native mozjs"
9 9
10inherit autotools gtk-doc pkgconfig useradd systemd 10inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection
11 11
12PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ 12PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
13 ${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}" 13 ${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}"
@@ -25,18 +25,20 @@ SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.
25SRC_URI[md5sum] = "4b77776c9e4f897dcfe03b2c34198edf" 25SRC_URI[md5sum] = "4b77776c9e4f897dcfe03b2c34198edf"
26SRC_URI[sha256sum] = "e1c095093c654951f78f8618d427faf91cf62abdefed98de40ff65eca6413c81" 26SRC_URI[sha256sum] = "e1c095093c654951f78f8618d427faf91cf62abdefed98de40ff65eca6413c81"
27 27
28EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages --disable-introspection" 28EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages"
29
30do_compile_prepend () {
31 export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
32}
29 33
30PACKAGES =+ "${PN}-examples" 34PACKAGES =+ "${PN}-examples"
31 35
32FILES_${PN} += " \ 36FILES_${PN}_append = " \
33 ${libdir}/${BPN}-1 \ 37 ${libdir}/${BPN}-1 \
34 ${nonarch_libdir}/${BPN}-1 \ 38 ${nonarch_libdir}/${BPN}-1 \
35 ${datadir}/dbus-1 \ 39 ${datadir}/dbus-1 \
36 ${datadir}/${BPN}-1 \ 40 ${datadir}/${BPN}-1 \
37" 41"
38FILES_${PN}-dbg += "${libdir}/${BPN}-1/.debug \
39 ${nonarch_libdir}/${BPN}-1/.debug"
40 42
41FILES_${PN}-examples = "${bindir}/*example*" 43FILES_${PN}-examples = "${bindir}/*example*"
42 44