summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/polkit/polkit_0.115.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-05-22 14:25:02 -0700
committerKhem Raj <raj.khem@gmail.com>2019-05-29 02:26:16 -0700
commit866daa14e30e2141a025fd9e71ba5406a8b0329a (patch)
tree226231b27d62edc3469be33be66ddd86d2f2d82a /meta-oe/recipes-extended/polkit/polkit_0.115.bb
parent9ca3aad9cf7170f352f2d18e335916feeebe0ee4 (diff)
downloadmeta-openembedded-866daa14e30e2141a025fd9e71ba5406a8b0329a.tar.gz
polkit: Upgrade to 0.116
Make netgroup support optional so it can be disabled on musl Drop backported patch 0001-backend-Compare-PolkitUnixProcess-uids-for-temporary.patch Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/polkit/polkit_0.115.bb')
-rw-r--r--meta-oe/recipes-extended/polkit/polkit_0.115.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/meta-oe/recipes-extended/polkit/polkit_0.115.bb b/meta-oe/recipes-extended/polkit/polkit_0.115.bb
deleted file mode 100644
index 562a754b2..000000000
--- a/meta-oe/recipes-extended/polkit/polkit_0.115.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7
8DEPENDS = "expat glib-2.0 intltool-native mozjs"
9
10inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection distro_features_check
11
12REQUIRED_DISTRO_FEATURES = "polkit"
13
14PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
15 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', \
16 bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
17 "
18
19PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
20PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
21# there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
22PACKAGECONFIG[consolekit] = ",,,consolekit"
23
24PAM_SRC_URI = "file://polkit-1_pam.patch"
25SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
26 file://0001-make-netgroup-support-configurable.patch \
27 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
28 file://0001-backend-Compare-PolkitUnixProcess-uids-for-temporary.patch \
29 "
30SRC_URI[md5sum] = "f03b055d6ae5fc8eac76838c7d83d082"
31SRC_URI[sha256sum] = "2f87ecdabfbd415c6306673ceadc59846f059b18ef2fce42bac63fe283f12131"
32
33EXTRA_OECONF = "--with-os-type=moblin \
34 --disable-man-pages \
35 --disable-libelogind \
36 "
37
38do_compile_prepend () {
39 export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
40}
41
42PACKAGES =+ "${PN}-examples"
43
44FILES_${PN}_append = " \
45 ${libdir}/${BPN}-1 \
46 ${nonarch_libdir}/${BPN}-1 \
47 ${datadir}/dbus-1 \
48 ${datadir}/${BPN}-1 \
49 ${datadir}/gettext \
50"
51
52FILES_${PN}-examples = "${bindir}/*example*"
53
54USERADD_PACKAGES = "${PN}"
55USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
56
57SYSTEMD_SERVICE_${PN} = "${BPN}.service"
58SYSTEMD_AUTO_ENABLE = "disable"