summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/p7zip
diff options
context:
space:
mode:
authorYannick Gicquel <yannick.gicquel@iot.bzh>2016-03-31 13:55:46 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-12 11:07:44 +0200
commitc7cb15542e94d58748c005656cacee3bc921253d (patch)
treea0ad000f24503d67a9d7486d3d7410d7d559cf32 /meta-oe/recipes-extended/p7zip
parent81cc98ef714ab383d8ec8063b9b74b2a012ef95a (diff)
downloadmeta-openembedded-c7cb15542e94d58748c005656cacee3bc921253d.tar.gz
p7zip: add native extend
This add a support for native build of 7za, 7z and 7zr binaries. Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/p7zip')
-rw-r--r--meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb b/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb
index be706e1ac..b89fc42de 100644
--- a/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb
+++ b/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb
@@ -15,3 +15,21 @@ do_install() {
15 install -d ${D}${bindir} 15 install -d ${D}${bindir}
16 install -m 0755 ${S}/bin/* ${D}${bindir} 16 install -m 0755 ${S}/bin/* ${D}${bindir}
17} 17}
18
19# all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
20EXTRA_OEMAKE_class-native = "all3"
21
22do_install_class-native() {
23 install -d ${D}${bindir}
24 install -d ${D}${bindir}/Codecs
25 install -m 0755 ${S}/bin/7* ${D}${bindir}
26 install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
27
28 # Create a shell script wrapper to execute next to 7z.so
29 mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
30 echo "#! /bin/sh" > ${D}${bindir}/7z
31 echo "exec ${D}${bindir}/7z.bin \"\$@\"" >> ${D}${bindir}/7z
32 chmod 0755 ${D}${bindir}/7z
33}
34
35BBCLASSEXTEND += "native"