diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-09-15 08:55:46 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-09-22 22:56:13 +0000 |
commit | f841648657069051dffa1012a42eb1524b894d50 (patch) | |
tree | 24d41a5fd1ca127106b718edf052eefe3571a23c /meta-oe/recipes-extended/openwsman | |
parent | 9de8ce7f3ae6f4ded76496ada28ac6c3c4c22122 (diff) | |
download | meta-openembedded-f841648657069051dffa1012a42eb1524b894d50.tar.gz |
openwsman: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/openwsman')
-rw-r--r-- | meta-oe/recipes-extended/openwsman/openwsman/0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb | 4 |
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/openwsman/openwsman/0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch b/meta-oe/recipes-extended/openwsman/openwsman/0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch new file mode 100644 index 0000000000..7823fde7a0 --- /dev/null +++ b/meta-oe/recipes-extended/openwsman/openwsman/0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From e05bad73f5fe4be1626560d92465893a5fc931e5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 15 Sep 2017 00:01:19 -0700 | ||
4 | Subject: [PATCH] lock.c: Define PTHREAD_MUTEX_RECURSIVE_NP if undefined | ||
5 | |||
6 | Check for PTHREAD_MUTEX_RECURSIVE_NP being defined instead of | ||
7 | checking for OS | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/lib/u/lock.c | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/src/lib/u/lock.c b/src/lib/u/lock.c | ||
15 | index 025eea4c..b31c77b5 100644 | ||
16 | --- a/src/lib/u/lock.c | ||
17 | +++ b/src/lib/u/lock.c | ||
18 | @@ -50,7 +50,7 @@ | ||
19 | extern int pthread_mutexattr_settype(pthread_mutexattr_t *attr, int type); | ||
20 | #endif | ||
21 | |||
22 | -#if defined (__SVR4) && defined (__sun) | ||
23 | +#ifndef PTHREAD_MUTEX_RECURSIVE_NP | ||
24 | #define PTHREAD_MUTEX_RECURSIVE_NP PTHREAD_MUTEX_RECURSIVE | ||
25 | #endif | ||
26 | |||
27 | -- | ||
28 | 2.14.1 | ||
29 | |||
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb index 2925f4b9e2..c4778ca38a 100644 --- a/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb +++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb | |||
@@ -17,7 +17,9 @@ PV = "2.6.3" | |||
17 | 17 | ||
18 | SRC_URI = "git://github.com/Openwsman/openwsman.git \ | 18 | SRC_URI = "git://github.com/Openwsman/openwsman.git \ |
19 | file://libssl-is-required-if-eventint-supported.patch \ | 19 | file://libssl-is-required-if-eventint-supported.patch \ |
20 | file://openwsmand.service" | 20 | file://openwsmand.service \ |
21 | file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \ | ||
22 | " | ||
21 | 23 | ||
22 | S = "${WORKDIR}/git" | 24 | S = "${WORKDIR}/git" |
23 | 25 | ||