summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/openwsman
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-extended/openwsman
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/openwsman')
-rw-r--r--meta-oe/recipes-extended/openwsman/openwsman_2.6.11.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.11.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.11.bb
index 9d5a2307e..23db7c679 100644
--- a/meta-oe/recipes-extended/openwsman/openwsman_2.6.11.bb
+++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.11.bb
@@ -30,10 +30,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba"
30 30
31inherit systemd cmake pkgconfig python3native perlnative 31inherit systemd cmake pkgconfig python3native perlnative
32 32
33SYSTEMD_SERVICE_${PN} = "openwsmand.service" 33SYSTEMD_SERVICE:${PN} = "openwsmand.service"
34SYSTEMD_AUTO_ENABLE = "disable" 34SYSTEMD_AUTO_ENABLE = "disable"
35 35
36LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}" 36LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
37 37
38EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \ 38EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
39 -DBUILD_LIBCIM=NO \ 39 -DBUILD_LIBCIM=NO \
@@ -44,12 +44,12 @@ EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
44 -DLIB=${baselib} \ 44 -DLIB=${baselib} \
45 " 45 "
46 46
47do_configure_prepend() { 47do_configure:prepend() {
48 export STAGING_INCDIR=${STAGING_INCDIR} 48 export STAGING_INCDIR=${STAGING_INCDIR}
49 export STAGING_LIBDIR=${STAGING_LIBDIR} 49 export STAGING_LIBDIR=${STAGING_LIBDIR}
50} 50}
51 51
52do_install_append() { 52do_install:append() {
53 install -d ${D}/${sysconfdir}/init.d 53 install -d ${D}/${sysconfdir}/init.d
54 install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand 54 install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand
55 ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand 55 ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand
@@ -64,9 +64,9 @@ do_install_append() {
64 fi 64 fi
65} 65}
66 66
67FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \ 67FILES:${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \
68 ${libdir}/openwsman/authenticators/.debug/ \ 68 ${libdir}/openwsman/authenticators/.debug/ \
69 " 69 "
70 70
71INSANE_SKIP_${PN} = "dev-so" 71INSANE_SKIP:${PN} = "dev-so"
72RDEPENDS_${PN} = "ruby" 72RDEPENDS:${PN} = "ruby"