summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2015-08-25 13:19:56 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:11:12 +0200
commit1f7e41d5570eef9b3f33a2c002ab9894be41917d (patch)
tree57a9b8f88bf3ddac8094fbcb8a271c4df84aaa90 /meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb
parentbe019b379479f4df346b34a940ec46aaa3534d22 (diff)
downloadmeta-openembedded-1f7e41d5570eef9b3f33a2c002ab9894be41917d.tar.gz
openlmi: add openlmi
OpenLMI = Open Linux Management Infrastructure. OpenLMI is open-source project aiming to improve management of Linux systems using WBEM standards. Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb')
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb b/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb
new file mode 100644
index 000000000..015d80339
--- /dev/null
+++ b/meta-oe/recipes-extended/openlmi/openlmi-storage_0.8.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "CIM providers for storage management"
2DESCRIPTION = "\
3The openlmi-storage package contains CMPI providers for management of storage \
4using Common Information Managemen (CIM) protocol. \
5\
6The providers can be registered in any CMPI-aware CIMOM, both OpenPegasus and \
7SFCB were tested."
8HOMEPAGE = "http://www.openlmi.org/"
9LICENSE = "LGPL-2.1+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
11SECTION = "System/Management"
12DEPENDS = "openlmi-providers pywbem cmpi-bindings"
13RDEPENDS_${PN} += "bash"
14
15SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz"
16SRC_URI[md5sum] = "898cf0d8c03b8ad6b45d65f335ddee0d"
17SRC_URI[sha256sum] = "4a1ba9957750f94ea58a89cea28985564f38d7cc9aa00fcae20c51e7b32bd0a8"
18
19inherit setuptools
20
21do_install_append() {
22 install -m 755 -d ${D}${datadir}/${BPN}
23 install -m 644 ${S}/mof/* ${D}${datadir}/${BPN}/
24
25 install -m 755 -d ${D}${sysconfdir}/openlmi/storage
26 install -m 644 storage.conf ${D}${sysconfdir}/openlmi/storage/storage.conf
27
28 install -m 755 -d ${D}${libexecdir}/pegasus
29 install -m 755 pycmpiLMI_Storage-cimprovagt ${D}${libexecdir}/pegasus/
30}
31
32FILES_${PN} =+ "${sysconfdir}/openlmi/storage/storage.conf ${datadir}/${BPN}/*"