summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/minifi-cpp
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-extended/minifi-cpp
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/minifi-cpp')
-rw-r--r--meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb b/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
index ef82a8fb0..596ec0b43 100644
--- a/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
+++ b/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
@@ -8,7 +8,7 @@ LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=f9534eb5f4ab800b573a37bffc62f3a7" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=f9534eb5f4ab800b573a37bffc62f3a7"
9 9
10DEPENDS = "virtual/crypt expat flex python3 bison-native libxml2 nettle lz4" 10DEPENDS = "virtual/crypt expat flex python3 bison-native libxml2 nettle lz4"
11RDEPENDS_${PN} = "python3-core" 11RDEPENDS:${PN} = "python3-core"
12 12
13SRCREV = "aa42957a2e227df41510047cece3cd606dc1cb6a" 13SRCREV = "aa42957a2e227df41510047cece3cd606dc1cb6a"
14SRC_URI = "git://github.com/apache/nifi-minifi-cpp.git \ 14SRC_URI = "git://github.com/apache/nifi-minifi-cpp.git \
@@ -47,7 +47,7 @@ S = "${WORKDIR}/git"
47inherit pkgconfig cmake systemd 47inherit pkgconfig cmake systemd
48 48
49SYSTEMD_PACKAGES = "minifi-cpp" 49SYSTEMD_PACKAGES = "minifi-cpp"
50SYSTEMD_SERVICE_${PN} = "minifi.service" 50SYSTEMD_SERVICE:${PN} = "minifi.service"
51SYSTEMD_AUTO_ENABLE = "disable" 51SYSTEMD_AUTO_ENABLE = "disable"
52 52
53OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH" 53OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"
@@ -58,23 +58,23 @@ EXTRA_OECMAKE += " \
58 -DGCC_AR=${STAGING_BINDIR_TOOLCHAIN}/${AR} \ 58 -DGCC_AR=${STAGING_BINDIR_TOOLCHAIN}/${AR} \
59 -DGCC_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${RANLIB} \ 59 -DGCC_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${RANLIB} \
60 " 60 "
61EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}llvm-ranlib" 61EXTRA_OECMAKE:append:toolchain-clang = " -DCMAKE_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}llvm-ranlib"
62LDFLAGS_append_toolchain-clang = " -fuse-ld=lld" 62LDFLAGS:append:toolchain-clang = " -fuse-ld=lld"
63 63
64# RV lld errors out: 64# RV lld errors out:
65# riscv64-yoe-linux-ld.lld: error: init.c:(.text+0x0): relocation R_RISCV_ALIGN requires unimplemented linker relaxation; recompile with -mno-relax 65# riscv64-yoe-linux-ld.lld: error: init.c:(.text+0x0): relocation R_RISCV_ALIGN requires unimplemented linker relaxation; recompile with -mno-relax
66LDFLAGS_remove_riscv32 = "-fuse-ld=lld" 66LDFLAGS:remove:riscv32 = "-fuse-ld=lld"
67LDFLAGS_remove_riscv64 = "-fuse-ld=lld" 67LDFLAGS:remove:riscv64 = "-fuse-ld=lld"
68 68
69# There are endian issues when communicating with the x86 nifi on the the mips and the ppc machines. 69# There are endian issues when communicating with the x86 nifi on the the mips and the ppc machines.
70COMPATIBLE_MACHINE_mips = "(!.*mips).*" 70COMPATIBLE_MACHINE:mips = "(!.*mips).*"
71COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*" 71COMPATIBLE_MACHINE:mips64 = "(!.*mips64).*"
72COMPATIBLE_MACHINE_powerpc = "(!.*ppc).*" 72COMPATIBLE_MACHINE:powerpc = "(!.*ppc).*"
73 73
74TARGET_CFLAGS_append_riscv32 = " -fpic" 74TARGET_CFLAGS:append:riscv32 = " -fpic"
75TARGET_CXXFLAGS_append_riscv32 = " -fpic" 75TARGET_CXXFLAGS:append:riscv32 = " -fpic"
76TARGET_CFLAGS_append_riscv64 = " -fpic" 76TARGET_CFLAGS:append:riscv64 = " -fpic"
77TARGET_CXXFLAGS_append_riscv64 = " -fpic" 77TARGET_CXXFLAGS:append:riscv64 = " -fpic"
78 78
79do_install[cleandirs] += "${WORKDIR}/minifi-install" 79do_install[cleandirs] += "${WORKDIR}/minifi-install"
80PSEUDO_CONSIDER_PATHS .= ",${WORKDIR}/minifi-install" 80PSEUDO_CONSIDER_PATHS .= ",${WORKDIR}/minifi-install"
@@ -130,7 +130,7 @@ do_install() {
130 fi 130 fi
131} 131}
132 132
133pkg_postinst_${PN}() { 133pkg_postinst:${PN}() {
134 if [ -z "$D" ]; then 134 if [ -z "$D" ]; then
135 if type systemd-tmpfiles >/dev/null; then 135 if type systemd-tmpfiles >/dev/null; then
136 systemd-tmpfiles --create 136 systemd-tmpfiles --create