diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-10-25 00:16:34 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-10-26 10:20:34 -0700 |
commit | ae0d7b3a0ef1611b721276c0821e8299d8d51623 (patch) | |
tree | 748ab31ef415fe17e1369a048ba9ebdf993b2f14 /meta-oe/recipes-extended/minifi-cpp | |
parent | 2493507916e4262cd48559a854ad5d202aafa9ce (diff) | |
download | meta-openembedded-ae0d7b3a0ef1611b721276c0821e8299d8d51623.tar.gz |
minifi-cpp: Do not use lld on riscv32
Fixes errors like
| riscv32-yoe-linux-ld.lld: error: init.c:(.text+0x0): relocation R_RISCV_ALIGN requires unimplemented linker relaxation; recompile with -mno-relax
| riscv32-yoe-linux-ld.lld: error: testCCompiler.c:(.text+0x0): relocation R_RISCV_ALIGN requires unimplemented linker relaxation; recompile with -mno-relax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/minifi-cpp')
-rw-r--r-- | meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb b/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb index 5127e11d81..9113fa67ad 100644 --- a/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb +++ b/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb | |||
@@ -55,6 +55,7 @@ EXTRA_OECMAKE += " \ | |||
55 | " | 55 | " |
56 | EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}llvm-ranlib" | 56 | EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}llvm-ranlib" |
57 | LDFLAGS_append_toolchain-clang = " -fuse-ld=lld" | 57 | LDFLAGS_append_toolchain-clang = " -fuse-ld=lld" |
58 | LDFLAGS_remove_riscv32 = "-fuse-ld=lld" | ||
58 | 59 | ||
59 | # There are endian issues when communicating with the x86 nifi on the the mips and the ppc machines. | 60 | # There are endian issues when communicating with the x86 nifi on the the mips and the ppc machines. |
60 | COMPATIBLE_MACHINE_mips = "(!.*mips).*" | 61 | COMPATIBLE_MACHINE_mips = "(!.*mips).*" |