summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/minifi-cpp/files
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-18 09:26:38 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-18 09:35:23 -0700
commitaef9af7697671d68632740342f22efa674d73405 (patch)
tree5223a8516339003823d5be27e6afebc2ca462bcb /meta-oe/recipes-extended/minifi-cpp/files
parentfa9f26ee02e26280b30aac8bdf018af2f2630b6a (diff)
downloadmeta-openembedded-aef9af7697671d68632740342f22efa674d73405.tar.gz
minifi-cpp: Fix linking with libxml2
when libxml2-native is staged, then on x86 it starts to detect that for target and fail to build Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/minifi-cpp/files')
-rw-r--r--meta-oe/recipes-extended/minifi-cpp/files/0001-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/minifi-cpp/files/0001-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch b/meta-oe/recipes-extended/minifi-cpp/files/0001-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch
new file mode 100644
index 000000000..d813b37f9
--- /dev/null
+++ b/meta-oe/recipes-extended/minifi-cpp/files/0001-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch
@@ -0,0 +1,39 @@
1From 609e1745d26d6f42d426018a4dd8d2342d6fc170 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 18 Aug 2020 08:37:57 -0700
4Subject: [PATCH] Add -lxml2 to linker cmdline of xml is found
5
6When cross compiling for systems where static libs
7for libxml are not available cmake's detection mechanism
8resort to linking with libxml.so but doesnt use -lxml2
9liblldbHost.a however requires libxml on linker
10cmdline _after_ itself so its use of symbols from libxml2
11can be resolved. Here check for libxml2 being detected and
12add it if its found.
13
14Fixes
15minifi-cpp/0.7.0-r0/recipe-sysroot-native/usr/lib/libxml2.so is incompatible with elf32-i386
16| clang-11: error: linker command failed with exit code 1 (use -v to see invocation)
17
18Upstream-Status: Pending
19Signed-off-by: Khem Raj <raj.khem@gmail.com>
20---
21 thirdparty/libarchive-3.3.2/CMakeLists.txt | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/thirdparty/libarchive-3.3.2/CMakeLists.txt b/thirdparty/libarchive-3.3.2/CMakeLists.txt
25index 0c1ea6f7..cde0cc51 100644
26--- a/thirdparty/libarchive-3.3.2/CMakeLists.txt
27+++ b/thirdparty/libarchive-3.3.2/CMakeLists.txt
28@@ -1031,7 +1031,7 @@ ENDIF()
29 IF(LIBXML2_FOUND)
30 CMAKE_PUSH_CHECK_STATE() # Save the state of the variables
31 INCLUDE_DIRECTORIES(${LIBXML2_INCLUDE_DIR})
32- LIST(APPEND ADDITIONAL_LIBS ${LIBXML2_LIBRARIES})
33+ LIST(APPEND ADDITIONAL_LIBS xml2)
34 SET(HAVE_LIBXML2 1)
35 # libxml2's include files use iconv.h
36 SET(CMAKE_REQUIRED_INCLUDES ${ICONV_INCLUDE_DIR} ${LIBXML2_INCLUDE_DIR})
37--
382.28.0
39